КриптоПро CSP 3.6

127018, Москва, ул. Сущёвский вал, д. 16 строение 5
Телефон: +7 (495) 780 4820
Факс: +7 (495) 780 4820
http://www.CryptoPro.ru
E-mail: info@CryptoPro.ru

Средство Криптографической Защиты Информации

КриптоПро CSP

Версия 3.6

Руководство программиста
Часть 4
Reader Development Kit (RDK)

ЖТЯИ.00050-03 90 05

© OOO "Крипто-Про", 2000-2010. Все права защищены.
Авторские права на средство криптографической защиты информации КриптоПро CSP и эксплуатационную документацию зарегистрированы в Российском агентстве по патентам и товарным знакам (Роспатент). Свидетельство об официальной регистрации программ для ЭВМ № 2008612300 от 12 мая 2008 года.
Документ входит в комплект поставки программного обеспечения КриптоПРО CSP, и на него распространяются все условия лицензионного соглашения. Без специального письменного разрешения OOO "Крипто-Про" документ или его часть в электронном или печатном виде не могут быть скопированы и переданы третьим лицам с коммерческой целью.


Руководство программиста

Средство Криптографической Защиты Информации КриптоПро CSP 3.6

СКЗИ КриптоПро CSP (RDK) - комплект для разработки модулей поддержки для СКЗИ КриптоПро CSP.

КриптоПр CSP (RDK)

Reader Development Kit - комплект разработчика модулей поддержки для СКЗИ КриптоПро CSP.

Данный документ описывает программный интерфейс СКЗИ КриптоПро CSP.

Область применения

Позволяет создавать библиотеки для поддержки новых считыватлей, носителей и датчиков случайных чисел (ДСЧ).

См. в этой главе | Важные внешние ссылки
Архитектура RDK |
Структура подключаемого модуля | Конференция Крипто-Про World Wide Web link
Описание изменений | Использование CryptoAPI в MSDN World Wide Web link

Крипто-Про RDK Версия: 4.0

Обратная связь для этой статьи

(c) ООО Крипто-Про. Все права защищены.


Список устаревших определений и описаний

Глобальный RSCARD_FUN_CONNECT_CARRIER

  • Заменена на пару RSCARD_FUN_PRECONNECT_CARRIER и RSCARD_FUN_POSTCONNECT_CARRIER

    • Крипто-Про RDK Версия: 4.0


Аннотация

В этой главе содержится общая информация необходимая для создания собственного модуля поддержки. Рекомендуется ознакомится с ней в том порядке как она приведена ниже.

  • Описание изменений
  • Архитектура RDK
  • Структура подключаемого модуля
  • Криптографические замечания
  • Соглашения о вызовах
  • Замечания по втраиванию носителя в Winlogon


Описание изменений

  • Изменения 3.0
  • Изменения 3.6


Изменения 3.0

Описание изменений в интерфейсе RDK CSP 3.0 от RDK CSP 2.0
  • RDK для Windows переведен на Unicode.
  • Добавлена обязательная для реализации функция SUPSYS_FUN_VERSIONSUPPORT, которая должна возвращать номер версии CSP, с которым она совместима. На данный момент функция должна возвращать версию 3.0.0.0.
  • Изменился способ подключения смарт-карт:
    • Смарт-карты теперь регистрируются в ключе реестра

      HKLM\SOFTWARE\Crypto Pro\Cryptography\CurrentVersion\KeyCarriers\xxx,
      а не в ключе реестра

      HKLM\SOFTWARE\Crypto Pro\Cryptography\CurrentVersion\KeyCarriers\SCard
      как ранее.
    • Точка входа переименована в xxxx_media_get_handle, а не как было ранее xxxx_scard_get_handle
    • Функцию SUPSYS_FUN_GROUP_NICKNAME необходимо не реализовывать (соответственно не вставлять в ресурс строку с номером SUPSYS_IDS_GROUP_NICKNAME)
  • Для носителей сделана поддержка информационных функций, используемых в контрольной панели для конфигурирования носителей.
  • Для всех носителей предполагается адекватное поведение при чтении файлов из корня.
  • Добавлена возможность создания дополнительных панелей wizard для настроек специфичных для конкретного носителя, считывателя, ДСЧ. Эта особенность может использоваться и для активации, серийных номеров:
  • Добавлен стандартный способ установки считывателей, носителей, ДСЧ.
  • Права доступа на файл header.key (номер 3) изменены на "файл открыт всем для чтения", "файл открыт на запись при предъявлении пароля".
  • Изменены длины файлов masks.key и primary.key (номера 1, 2, 4, 5).
    Максимальные размеры файлов:
    • primary.key - 72 байта
    • masks.key - 60 байт
  • Добавлена опциональная поддержка "контейнера на носителе по умолчанию".
  • Добавлена возможность не спрашивать пароль при первичной генерации ключевого контейнера после первичной разметки карты. Никакой дополнительной функциональности для поддержки этой возможности не требуется. В случае использования этой возможности файл name.key (номер 6) должен содержать последовательность "PIN:<passwd>", где "PIN:" предопределенная RDK последовательность 4 символов <passwd> - пароль (пин-код) доступа к файлам "открытым для записи по предъявлению пароля" в виде текстовой строки оканчивающийся нулем. Эту информацию записывает программа предварительной разметки. Информация записывается в начало файла. Такая функциональность используется, когда носитель требует предварительной разметки. Для e-Token это не используется, так как там один пароль на весь носитель.

    • Крипто-Про RDK Версия: 4.0


Изменения 3.6

Описание изменений в интерфейсе RDK CSP 3.6 от RDK CSP 3.0
  • Добавлена поддержка новых платформ: Itanium, x64, Pocket PC 2003 (ARMV4), WinCEx86
  • Изменен компилятор на Visual Studio 2005
  • Изменилось положение solution на rdk\csp\
  • Изменилось положение и состав базовых библиотек: rdk\csp\out\[Платформа]\[debug|release]
  • Изменен состав файла версии ресурса
  • Изменены пути в реестре с для KeyCarriers, KeyDevices, Random

 HKEY_LOCAL_MACHINE\SOFTWARE\Crypto Pro\App Paths
    на

 HKEY_LOCAL_MACHINE\SOFTWARE\Crypto Pro\Cryptography\CurrentVersion\App Paths
  • На 64-х битных платформах App Path отдельно определяется для 64-х битных и WOW64. Все настройки KeyCarriers, KeyDevices, Random хранятся в ветке WOW64.

    • Крипто-Про RDK Версия: 4.0


Архитектура RDK

RDK состоит из 3 основных компонент: cpsuprt.dll, cprdr.dll, cprndm.dll и подключаемых модулей. Подключаемые модули разделены по своему назначению:

  • считыватели
  • датчики случайных чисел
  • носители

Общая схема взаимодействия CSP и модуля.

Общая схема взаимодействия DLL представлена на схеме: Структура взаимодействия модулей RDK и CSP

Примечания

Схема представлена для Windows. На других операционных системах схема взаимодействия аналогична с точностью до имен динамически подключамых библиотек.

Как видно из схемы, CSP не обращается напрямую со считывателями, носителями и ДСЧ. Для определенности рассмотрим схему взаимодействия CSP и считывателя.

При загрузке CSP (подробнее см. TODO) прогружает все доступные считыватели. При последующей работе CSP обращается к Reader, который в свою очередь обращается к нужному считывателю. Считыватель, отработав операцию, возвращает данные Reader. Reader возвращает данные CSP.

Взаимодействие с модуля ДСЧ с CSP происходит аналогично.

Взаимодействия носителя с CSP осуществляется в 3 этапа. Часть операций выполняет считыватель, а часть операций считыватель перенаправляет на носитель. Например, при чтении данных из файла, CSP вызывает функцию Reader, который перенаправляет операцию чтения на конкретный считыватель, тот в свою очередь перенаправляет эту операцию на конкретный носитель. Прогрузка списка всех носителей происходит на старте CSP аналогично считывателям. Выбор носителя, с которым работает CSP, считыватель осуществляет исходя из специфических данных носителя (например, ATR для смарт-карт).


Структура подключаемого модуля

В простейшем случае подключаемый модуль состоит из имени, динамически подключаемой библиотеки, точки входа и записях в реестре (конфигурационном файлее). Кроме того, для установки модуля может использоваться инсталятор специального вида.

Каждому модулю соответствует ровно одно имя, одна точка входа, одна регистрационная запись в реестре. Несколько модулей могут быть объеденены в один DLL. Каждый модуль должен быть зарегистрирован. Каждая динамически подгружаемая библиотека должна быть зарегистрирована.

Далее будет расписан состав подключаемого модуля более подробно.

Динамически подгружаемая библиотека

Все подключаемые модули должны состоять как минимум из одной динамически подгружаемой библиотеки. Именно эта библиотека и прогружается CSP. Прогрузку остальных библиотек, если это требуется, должна осуществлять, эта библиотека на этапе регистрации. Эта библиотека должна в случае Windows находиться в каталоге с криптопровайдером, а в случае Unix - зарегистрирована в файле конфигурации (раздел [AppPath]).

Имя библиотеки произвольное, и выбирается исходя из требований ОС.

Кроме того рекомендуется при установке добавлять в реестр данные для контроля целостности установленной библиотеки. Подробнее см. описание cpverify из состава документации по CSP.

Выполнение тестов

Все тестовые приложения, обращающиеся к подключаемому модулю через библиотеки провайдера, должны быть зарегистрированны аналогично библиотеке модуля поддержки (см. выше). Это касается в том числе тестов из примеров, входящих в состав данного RDK: fat12tst, pcsc_tst, rndm_tst.

Имя модуля

Имя модуля должно состоять из букв и цифр латинского алфавита. Знаки препинания не допускаются. Размер ограничен SUPSYSE_NICKNAME_LENGTH символами. Это имя используется только внутри и при правильно оформленном модуле не показывается пользователю. Имя устройства берется для Windows из реестра и для Unix из файла config.ini. Запись имени устройства в реестр и в файл config.ini осуществляется при инсталляции библиотеки устройства. При определении доступного оборудования CSP просматривает реестр или config.ini и определяет имена установленных библиотек и пути к ним.

Регистрация модуля в реестре (файле настройки)

Для Windows для регистрации считывателя: Должен быть содан ключ

 HKLM\SOFTWARE\Crypto Pro\Cryptography\CurrentVersion\KeyDevices\<name>
Содержащий параметр "DLL", значение которого должно быть имя (короткое) динамически подгружаемой библиотеки.

Для Windows для регистрации ДСЧ: Должен быть содан ключ

 HKLM\SOFTWARE\Crypto Pro\Cryptography\CurrentVersion\Random\<name>
Содержащий параметр "DLL", значение которого должно быть имя (короткое) динамически подгружаемой библиотеки.

Для Windows для регистрации носителя: Должен быть содан ключ

 HKLM\SOFTWARE\Crypto Pro\Cryptography\CurrentVersion\KeyCarriers\<name>
Содержащий параметр "DLL", значение которого должно быть имя (короткое) динамически подгружаемой библиотеки.

Точка входа

Для создания подключаемего модуля динамически подключаемая библиотека должна иметь хотя бы одну точку входа. Если модуль поддерживает несколько устройств (как например, dallas, который поддерживает 3 устройства: DS9097E, DS9097U, DS1410E), то количество точек входа должно совпадать с количеством поддерживаемых устройств.

Для каждой библиотеки должна быть определена функция экспорта, которая возвращает таблицу функций.

 static const TSupSysFunctionTable fat12_table =
 {
    sizeof( TSupSysFunctionTable ),
    sizeof( fat12_funs ) / sizeof( TSupSysFunctionTableItem ),
    fat12_funs
 };

 const TSupSysEHandle *fat12_reader_get_handle( void )
 {
     return (const TSupSysEHandle*)((void*)&fat12_table);
 }
Пример. Точка входа для считывателя.

Имя такой функции должно быть сформировано определенным образом. Оно состоит из двух частей. Из имени устройства и обязательной части. Обязательная часть зависит от типа устройства и может быть _reader_get_handle, _rndm_get_handle, _media_get_handle соответственно для считывателя, ДСЧ, или носителя.

Важно. Одна библиотека может поддерживать несколько устройств. Для каждого устройства должна быть своя точка входа и своя функция возвращающая эту точку. А также своя таблица интерфейсных функций и свой блок ресурсов (см. ниже).

Считыватели могут быть групповыми устройствами тогда функция, возвращающая точку входа, должна оканчиваться _reader_group_handle.

Точка входа - это структура TSupSysFunctionTable_, она содержит указатель На массив структур TSupSysFunctionTableItem_. Этот массив содержит указатели на те функции, которые реализованы в библиотеке.

Процесс загрузки

Рассмотрим схему прогрузки считывателя.

При первом обращении к CSP (требующего работы со считывателем), CSP обращается к Reader для формирования списка считывателей. Reader просматривает ключ реестра

 HKLM\SOFTWARE\Crypto Pro\Cryptography\CurrentVersion\KeyDevices

Для каждого ключа реестра <name> получается значение ключа Dll - DllName. Получается значение ключа:

 HKLM\SOFTWARE\Crypto Pro\App Paths\<DllName>.dll
Прогружается DLL по пути заданному этим ключем. Из Dll вызывается функция с именем <name>_reader_get_handle

Далее Reader обращается к считывателю с просьбой проверить наличие подключения соответствующего считывателя. Если регистрация этой библиотеки прошла успешно, то считыватель возвращает контекст считывателя и этот считыватель в дальнейшем будет использоваться CSP при работе с ключами. Для Windows Reader, а соответственно и CSP, при работе обновляет список загруженных устройств по мере обнаружения изменений в этом списке.

Таблица функций

Таблица функций - это массив интерфейсных функций считывателя с номерами.

 static const TSupSysFunctionTableItem fat12_funs[] =
 {
     { SUPSYS_FUN_INSTANCE, fat12_info_instance },
     { SUPSYS_FUN_CONTEXT_DUP, fat12_context_dup },
       :
     { READER_FUN_SAME_MEDIA, fat12_info_same_media },
           :
 }

Пример. Фрагмент массива структур TSupSysFunctionTableItem_, определяющего номера интерфейсных функций считывателя и указатели на их реализации.

Для взаимодействия библиотеки устройства с CSP, определен интерфейс. Каждая функция интерфейса имеет свой уникальный номер.

При формировании таблицы интерфейсных функций, которые реализует библиотека, важно соблюсти порядок перечисления функций в массиве. Функции перечисляются в порядке возрастания их номеров.

Если функции нет в таблице функций, то считается что функция не реализована. Существует множество умолчаний, и не обязательно реализовывать все функции поддерживаемые интерфейсом.

Прототип функций

Прототип всех функций из таблицы интерфейсных функций одинаков и выглядит примерно следующим образом:

 TSupErr function( TSupSysContext *context, TSupSysInfo *info );
В качестве первого параметра context передается контекст (TSupSysContext) модуля (когда он уже присутствует), в качестве второго info структура, которая зависит от номера функции - TSupSysInfo. Для каждого номера функции передаваемая структура описана в этой документации.

Если функция отсутствует в таблице функций, то поведение Reader при вызове этой функции аналогично поведению нижеследующей функции:

 TSupErr function( TSupSysContext *context, TSupSysInfo *info )
 {
     UNUSED( context );
     UNUSED( info );
     return SUP_ERR_UNSUPPORTED;
 }

Контекст модуля

Под контекстом подразумевается структура, определяемая разработчиком библиотеки устройства, и содержащая внутреннюю информацию необходимую для взаимодействия библиотеки и устройства. См. TSupSysContext

Замечания. CSP не использует информацию о составе этой структуры. Контекст устройства создается на этапе регистрации модуля и передается практически во все функции модуля.

 typedef struct {
     TCHAR *path; // Имя дисковода.
     HANDLE handle;
     DWORD access; // Способ доступа к файлу.
     unsigned long volume_serial;
     TCHAR *volume_label;
     TCHAR *file_name; // Имя открытого файла.
     TCHAR *folder;
     unsigned flags;
 } TFat12Context;
Пример. Фрагмент структуры внутреннего контекста дискеты в формате fat12.

Интерфейсы

Подключаемый модуль должен поддерживать как минимум 2 интерфейса:

Первый интерфейс - это множество функций позволяющих CSP сформировать список доступных библиотек устройств и обеспечивающих CSP информацией об этом устройстве и об этой библиотеки. Это "Интерфейс между списком и элементом".

Вторая группа интерфейсов это "Интерфейс ко всем считывателям (RDR)", "Интерфейс к датчикам случайных чисел" и "Интерфейс ко носителям". Эти интерфейсы предоставляют единый способ обращения к различным устройствам, носителям, ДСЧ соответственно, в не зависимости от особенностей конкретного устройства и его драйвера.

Примечания

Подключаемый модуль может поддерживать 3 интерфейса: "Интерфейс между списком и элементом", "Интерфейс к датчикам случайных чисел" и один из двух интерфейсов "Интерфейс ко всем считывателям (RDR)" или "Интерфейс ко всем носителям(Media)".

Группы функций

Все функции разделены на группы по их номерам (0x1xxx, 0x2xxx,...). Например, функции в группе "функций требующих соединение с носителем" имеет номера 0x3xxx.

В каждой группе существуют по одной функции повышения группы и понижения группы. Например, в предыдущем примере, есть функция READER_FUN_FOLDER_OPEN(0x3305), которая приводит к переходу в группу "функций требующих выбора папки" и функция возврата в эту группу из "функций требующих выбора папки" - READER_FUN_FOLDER_CLOSE(0x3306).

Переход в другую группу возможен только после последовательного повышения уровня до этой группы. Таким образом порядок вызова функций определен достаточно строго.

Например, вызов функции получения уникального номера носителя не возможен без предварительного последовательного вызова функций SUPSYS_FUN_REGISTER, SUPSYS_FUN_CONNECT, READER_FUN_CONNECT_CARRIER

Замечание. Существуют исключения из этого правила, они оговорены отдельно в руководстве.

Использование ресурса

Часть информационных функций может быть реализована через ресурс. Например, получение локализованного имени считывателя, может быть задано строкой в ресурсе. Если соответствующая функция не реализована, а есть строка в ресурсе (или его заменителе для Unix) с соответствующим номером, то эта строка и будет использоваться. См. Смещения внутри ресурса

Примечания

Рекомендуется по возможности реализовать всю функциональность такого вида через использование ресурса. Реализовывать непосредственно функцию необходимо только в случае вычисления значений, например, при получении версии устройства непосредственно из драйвера этого устройства.


Криптографические замечания

Очистка буферов

Если при чтении или записи файлов с носителя используются дополнительные буферы обмена, то информация в этих областях должна быть очищена после проведения операции. Очистку буферов обмена передаваемых в CSP производит CSP.

Очистка пароля

Хранение текущего пароля внутри контекста считывателя (носителя) не рекомендуется, а, если этот пароль все-таки храниться внутри контекста, то необходимо очищать буфер содержащий пароль перед освобождением памяти.

Чтение файлов

Чтение содержимого файлов primary.key (номер 2) и masks.key (номер 1), а так же их дублей primary2.key (номер 5) masks.key (номер 4) должно осуществляться таким образом, чтобы при чтении файла ОС (или библиотеки стороннего разработчика) не загрузили в память информацию из другого файла. Например, недопускается хранить файлы primary.key и masks.key в одном блоке на дескете, во избежание прогрузки всего блока операционной системой. Так же не допускается хранение информации из этих файлов после их закрытия. Кеширование не допускается.

Шифрованный обмен информацией

Интерфейс между библиотекой устройства и CSP не требует проведения никаких криптографических операций, и подключение дополнительной библиотеки устройства к CSP не требует дополнительной сертификации. Криптографические операции (например, передача данных от смарт-карты в память компьютера) не требуется, но и не запрещается.


Соглашения о вызовах

Соглашения о передаче строк

При передаче строк всегда передается указатель на строку (string) и длина строки (length). Длина строки (length) всегда указывается в символах, не включая последний 0 символ.

  • При передаче string == NULL функция не должна заполнять строку, а выставить длину строки (length) в необходимое для передачи строки количество символов.
  • При передаче string != NULL и длине строки (length) достаточной копирования строки, функция должна скопировать строку и выставить длину строки в скопированное количество символов.
  • При передаче строки string != NULL и длине (length) не достаточной для копирования строки, функция должна скопировать length символов выставить последний нулевой символ (string[length] = 0) и выставить длину строки в значение достаточное для помещение строки в string.
  • Код возврата функции в независимости от значения string и length не выставляется.

    • Обычно копирование строки src в строку dest при передаче length символов выглядит примерно следующим образом:

 void rdk_cpy( TCHAR *dest, const TCHAR *src, size_t *length )
 {
        if( !dest ) { *length = _tcslen( src ); return; }
        _tcsncpy( dest, src, *length );
        dest[*length] = 0;
        *length = _tcslen( src );
 }

    Соглашения о выделении памяти

    Если вы выделяете память внутри библиотеки, то вы эту память должны освободить. Если CSP выделяет память и передает вам указатель, то память будет освобождать CSP.

    Соглашения о сборке

    Все библиотеки устройств для CSP мы собираем

    • В Windows под VS .NET 2003
    • В Unix с помощью gcc. Примеры для этой документации должен компилироваться под указанными компиляторами. Работоспособность ваших библиотек собранных с помощью других компиляторов нами не гарантируется, хотя и не должна составлять особых проблем.

    Соглашения о символах. TCHAR

    Под Windows все библиотеки устройств должны быть UNICODE. Под Unix должны быть ANSI. Рекомендуется использовать TCHAR с определенным макросом define UNICODE и _UNICODE в Windows и не определенным в UNIX. Рекомендуется использовать символ TCHAR.

    Соглашения о передаче информационной структуры.

    Второй параметр info из интерфейсных функций всегда структура, зависимая от этой функции. Первый параметр передаваемой структуры всегда размер этой. Функция на входе должна проверить, что размер переданной структуры не меньше, чем описано в документации. При успешном завершении функция должна установить размер этой структуры в размер документированной структуры. Поле размер введено для поддержания совместимости с последующими версиями. При добавлении полей в эту структуру в следующих версиях, программа должна корректно обрабатывать только те поля которые описаны в текущей документации и сообщить вызывающей функции, что вновь введенные поля в вычислениях не участвовали. Интерфейсная функция обычно выглядит следующим образом:

 TSupErr fat12_disconnect( TSupSysContext *context, TSupSysInfo *info )
 {
     if( *(size_t*)info < sizeof( TSupSysInfoDisconnect ) )
         return SUP_ERR_PARAM;
     inf->size_of = sizeof( TSupSysInfoDisconnect );
     ...
 }
    Или если пользоваться макросами, прерывающими выполнение при сборке в DEBUG

 TSupErr fat12_disconnect( TSupSysContext *context, TSupSysInfo *info )
 {
     SUPSYS_PRE_INFO( info, TSupSysInfoDisconnect );
     inf->size_of = sizeof( TSupSysInfoDisconnect );
     ...
 }


Замечания по втраиванию носителя в Winlogon

В тексте документации приведены требования на считыватели и носители, которые должны поддерживать все подключаемые к CSP считыватели и носители. Кроме этих требований дополнительно могут быть поддержены ряд необязательных требований, при выполнении которых возможно совместное функционирование встраиваемой библиотеки и программного продукта Winlogon. Эти требования являются не обязательными, но рекомендуются.

Ниже перечислены требования необходимые для функционирования Winlogon.

  • Функция READER_FUN_FOLDER_OPEN должна поддерживать открытие корневой (NULL) папки.
  • Функция READER_FUN_OPEN должна поддерживать открытие (создание) файла в корневой папке с правами: файл доступен для чтения всем, доступен для записи по предъявлению пароля.
  • Носитель (считыватель) должен поддерживать дополнительные окна установки (удаления) носителя в мастере установки.
  • Носитель (считыватель) должен уметь регистрироваться, удалять регистрацию носителя в Winlogon, определять наличие установленного Крипто-Про Winlogon.

    • Носители, поддерживающие только один контейнер на носителе, могут не поддерживать функциональность онтосящуюся к открытию корневой папки и файлам в корневой папке.

    Размер файла находящегося в корневой папке (файл с именем def.key) должен быть достаточен, для хранения имени любой возможной папки + 4 байта.

    Примерный код регистрации, удаления зарегистрированного носителя в Winlogon приведен в файле работы с картами РИК, Оскар: "ric_prop.c".


Руководство программиста

Руководство программиста.

Руководство разделено на две части. Первая часть: Интерфейс использования . В этой главе приводятся описания и определения, которыми пользуется csp для хранения ключей и получения случайных чисел.

Вторая часть: Интерфейс подключения . В этой главе описывается интерфейс для подключения собственного модуля поддержки.

  • Интерфейс использования
  • Интерфейс подключения


Интерфейс использования

Эта часть содержит внешний интерфейс reader.

Интерфейс, описанный в данной главе, используется как CSP (для получения случайных чисел, работы с ключами...), так и при при создании собственного модуля поддержки.

  • Терминология
  • Внешний интерфейс reader.


Терминология

Термины используемые при описании

  • считыватель
  • носитель
  • список считывателей
  • соединение
  • пароль
  • приложение
  • папка
  • уникальный номер носителя
  • контекст считывателя
  • блокирование
  • файл
  • максимальный размер файла
  • файловая организация папки
  • последовательная организация папки
  • Выпуск


считыватель

Устройство, в котором может находиться носитель информации. В некоторых случаях устройство не имеет физического аналога, но действует аналогично. В устройстве в определенный момент времени может находиться только один носитель. Носители вставляемые в один считыватель могут иметь различный тип.


носитель

Устройство (или аналог) на котором находится информация, а считывание этой информации осуществляет считыватель . Носители могут быть вставлены в несколько различных считывателей. На носителе могут находиться несколько приложений.


список считывателей

Доступ к считывателю осуществляется только через список считывателей, путем получения контекста считывателя из этого списка. При добавлении списка в считыватель осуществляется первоначальная инициализация установка флагов считывателя.


соединение

Имя соединения, посредством которого устанавливается связь со считывателем. Это может быть COMx, LPTx, A:. В качестве имени соединения может участвовать AUTO, но только на момент установки считывателя, при обычной работе соединение AUTO не используется. Если считыватель может быть только один, то в качестве имени может быть передан NULL.


пароль

Текстовая информация, которая используется для входа в приложение. Может использоваться открытая информация (строка), pin-код, пароль, мастер pin-код. Функции работы с паролями по умолчанию, так же могут устанавливать пароли не используемые для входа в приложение.


приложение

Приложение содержит набор данных имеющих одинаковую структуру для одного и того же приложения. Приложения записаны на носитель . На носителе не могут находиться два приложения. Для доступа к приложению может быть потребован пароль .


папка

Группа файлов одной структуры в пределах приложения. В одном приложении могут находиться несколько папок имеющих разные имена.


уникальный номер носителя

Символьная последовательность отличающая один носитель от другого. Носитель должен поддерживать чтение уникального номера и может поддерживать запись уникального номера.


контекст считывателя

Контекст (HANDLE) считывателя и носителя скрытый от доступа. Один контекст связан только с одним считывателем, с одним носителем, с одним приложением, с одной папкой и с одним фалом. Но могут существовать несколько контекстов связанных со всем вышеперечисленным.


блокирование

Контекст считывателя может находится в состаянии блокирования, при этом доступ к считывателю через другие контексты запрещен. Носитель может быть разблокирован, посредством вызова соответсвующей функции или при помощи удаления из считывателя.


файл

Файл в обычном понимании. Имя файла определяется или строкой или номером в зависимости от типа носителя на котором он находится. В пределах одной папки могут существовать файлы только с различными именами (номерами).


максимальный размер файла

Размер файла в пределах которого разрешаны операции чтения / записи. Предельный размер файла для разных файлов может отличаться.


файловая организация папки

Если носитель может содержвать несколько файлов в пределах одной папки, то такая организация именуется файловой в противоположность последовательная организация папки


последовательная организация папки

Если носитель не поддерживает файловую организацию в пределах одного приложения, то запись информации осуществляется последовательно в файл с именем NULL и номером 0.


Выпуск

Некоторые типы носителей требуют предварительной разметки перед работой Такая разметка может происходить на отдельно стоящей машине, в этом случае reader не участвует в процессе разметки, и используется только код ошибки RDR_ERR_PRIME. В других случаях разметку можно проводить непосредственно при первом обращении, в этом случае (и это основное отличие от обычной работы с файлами и папаками) требуется дополнительный пароль, который и предъявляется перед разметкой карты.


Внешний интерфейс reader.

  • Макросы атомарности.
  • Регистрации считывателя в списке
  • Получение информации о считывателе
  • Носитель
  • Приложение
  • Пароль
  • Shortcut
  • Папки
  • Получение доступа к папке
  • Блокировки
  • Работа с файлами
  • Уникальные номера
  • Ошибки
  • Повторы
  • Загрузка библиотки
  • Состояния контекста считывателя
  • Флаги считывателя.


Макросы атомарности.

В данной группе преведены макросы для корректного начала и завершения опереции. В тех ОС, которые позволяют перехватывать исключения, проводятся необходимые действия по корректному закрытию контекста при возникновении исключений и при нормальном завершении операции. В тех системах, где перехват исключений невозможен, происходит корректное закрытие контекста при нормальном поведении программы.

Макросы | Описание
rdr_connect_try | Начало атомарного соединения со считывателем.
rdr_connect_finally | Завершение атомарного соединения со считывателем.
rdr_connect_return | Выход по ошибке при ошибке из атомарного соединения со считывателем.
rdr_lock_try | Начало атомарной блокировки считывателя.
rdr_lock_finally | Завершение атомарной блокировки считывателя.
rdr_lock_return | Выход по ошибке при ошибке из атомарной блокировки считывателя.
rdr_login_try | Начало атомарного предъявления пароля.
rdr_prime_section | Начало атомарной разметки.
rdr_login_finally | Завершение атомарного предъявления пароля.
rdr_crear_finally | Завершение атомарного предъявления пароля и очистка папки.
rdr_login_return | Выход по ошибке при ошибке из атомарного предъявления пароля.

Примечания

Текст макроса приведен только для одной ОС, значения макроса для других ОС приведены в include файле.


rdr_connect_try

Начало атомарного соединения со считывателем.

#define rdr_connect_try(rdr, code) code = supsys_connect( rdr ); if( !code ) {

Аргументы

rdr
[in] Контекст считывателя.
code
[out] Код ошибки функции supsys_connect

Примечания

Текст макроса приведен только для одной ОС, значения макроса для других ОС приведены в include файле.

См. также

rdr_connect_finally, rdr_connect_return

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_connect_finally

Завершение атомарного соединения со считывателем.

#define rdr_connect_finally(rdr, code) supsys_disconnect( rdr ); }

Аргументы

rdr
[in] Контекст считывателя.
code
[out] Код ошибки функции supsys_connect

Примечания

Текст макроса приведен только для одной ОС, значения макроса для других ОС приведены в include файле.

См. также

rdr_connect_try, rdr_connect_return

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_connect_return

Выход по ошибке при ошибке из атомарного соединения со считывателем.

#define rdr_connect_return(rdr) supsys_disconnect( rdr )

Аргументы

rdr
[in] Контекст считывателя.

Примечания

Текст макроса приведен только для одной ОС, значения макроса для других ОС приведены в include файле.

См. также

rdr_connect_try, rdr_connect_finally

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_lock_try

Начало атомарной блокировки считывателя.

#define rdr_lock_try(rdr, code) code = rdr_lock( rdr ); if( !code ) {

Аргументы

rdr
[in] Контекст считывателя.
code
[out] Код ошибки функции supsys_connect

Примечания

Текст макроса приведен только для одной ОС, значения макроса для других ОС приведены в include файле.

См. также

rdr_lock_finally, rdr_lock_return

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_lock_finally

Завершение атомарной блокировки считывателя.

#define rdr_lock_finally(rdr, code) rdr_unlock( rdr ); }

Аргументы

rdr
[in] Контекст считывателя.
code
[out] Код ошибки функции supsys_connect

Примечания

Текст макроса приведен только для одной ОС, значения макроса для других ОС приведены в include файле.

См. также

rdr_lock_try, rdr_lock_return

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_lock_return

Выход по ошибке при ошибке из атомарной блокировки считывателя.

#define rdr_lock_return(rdr) rdr_unlock( rdr )

Аргументы

rdr
[in] Контекст считывателя.

Примечания

Текст макроса приведен только для одной ОС, значения макроса для других ОС приведены в include файле.

См. также

rdr_lock_try, rdr_lock_finally

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_login_try

Начало атомарного предъявления пароля.

#define rdr_login_try(rdr, passwd, code, retries) code = rdr_login( rdr, passwd, retries ); if( !code ) {

Аргументы

rdr
[in] Контекст считывателя.
passwd
[in] Пароль
retries
[out] Количество оставшихся попыток преъявления пароля
code
[out] Код ошибки функции rdr_login

Примечания

Текст макроса приведен только для одной ОС, значения макроса для других ОС приведены в include файле.

См. также

rdr_login_finally, rdr_login_return

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_prime_section

Начало атомарной разметки.

#define rdr_prime_section(rdr, passwd, code, retries) code = rdr_prime( rdr, passwd, retries ); if( !code ) {

Аргументы

rdr
[in] Контекст считывателя.
passwd
[in] Пароль
retries
[out] Количество оставшихся попыток преъявления пароля
code
[out] Код ошибки функции rdr_login

Примечания

Текст макроса приведен только для одной ОС, значения макроса для других ОС приведены в include файле.

См. также

rdr_login_finally, rdr_login_return

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_login_finally

Завершение атомарного предъявления пароля.

#define rdr_login_finally(rdr, code) rdr_logout( rdr ); }

Аргументы

rdr
[in] Контекст считывателя.
code
[out] Код ошибки функции rdr_login

Примечания

Текст макроса приведен только для одной ОС, значения макроса для других ОС приведены в include файле.

См. также

rdr_login_try, rdr_login_return

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_crear_finally

Завершение атомарного предъявления пароля и очистка папки.

#define rdr_crear_finally(rdr, code) rdr_folder_clear( rdr ); }

Аргументы

rdr
[in] Контекст считывателя.
code
[out] Код ошибки функции rdr_login

Примечания

Текст макроса приведен только для одной ОС, значения макроса для других ОС приведены в include файле.

См. также

rdr_login_try, rdr_login_return

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_login_return

Выход по ошибке при ошибке из атомарного предъявления пароля.

#define rdr_login_return(rdr) rdr_logout( rdr )

Аргументы

rdr
[in] Контекст считывателя.

Примечания

Текст макроса приведен только для одной ОС, значения макроса для других ОС приведены в include файле.

См. также

rdr_login_try, rdr_login_finally

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


Регистрации считывателя в списке

Функции | Описание
rdr_register_start | Функции регистрации. Начало регистрации списка считывателей.
rdr_media_register_start | Начало регистрации списка носителей.
rdr_context_default_get | Получение контекста считывателя по умолчанию. Получение контекста считывателя по умолчанию.
rdr_context_default_set | Установка контекста считывателя по умолчанию. Установка контекста считывателя по умолчанию.


rdr_register_start

Функции регистрации. Начало регистрации списка считывателей.

Функция инициализирует список зарегистрированных считывателей.

TSupErr rdr_register_start(
  TSupSysEList ** list
);

Аргументы

list
[out] Инициализированный (пустой) список считывателей.

Возвращаемые значения

Ошибки

См. также

Регистрации считывателя в списке

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_media_register_start

Начало регистрации списка носителей.

Функция инициализирует список зарегистрированных носителей.

TSupErr rdr_media_register_start(
  TSupSysEList ** list
);

Аргументы

list
[out] Инициализированный (пустой) список носителей.

Возвращаемые значения

Ошибки

См. также

Регистрации считывателя в списке , rdr_register_media

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_context_default_get

Получение контекста считывателя по умолчанию. Получение контекста считывателя по умолчанию.

Функция получает контекст считывателя по умолчанию в следующей последовательности:

  • из локального реестра
  • из глобального реестра
  • первый найденный считыватель из списка.

TSupErr rdr_context_default_get(
  const TSupSysEList * list,
  TSupSysEContext ** context
);

Аргументы

list
[in] список считывателей
context
[out] контекст считывателя по умолчению

Возвращаемые значения

Ошибки

См. также

Регистрации считывателя в списке , rdr_context_default_set

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_context_default_set

Установка контекста считывателя по умолчанию. Установка контекста считывателя по умолчанию.

Функция устанавливает контекст считывателя по умолчанию в локальный реестр.

>= SUPSYSE_STATE_REGISTERED

TSupErr rdr_context_default_set(
  const TSupSysEContext * context
);

>= SUPSYSE_STATE_REGISTERED

Аргументы

context
[in] контекст считывателя по умолчению

Возвращаемые значения

Ошибки

См. также

Регистрации считывателя в списке , rdr_context_default_get

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


Получение информации о считывателе

Функции | Описание
rdr_info_carrier_type | Текст приглашения вставки носителя Прозвище поддерживаемго типа носителей.


rdr_info_carrier_type

Текст приглашения вставки носителя Прозвище поддерживаемго типа носителей.

TSupErr rdr_info_carrier_type(
  const TSupSysEContext * context,
  TSupSysENickname carrier_type
);

Аргументы

context
[in] контекст считывателя.
carrier_type
[in] прозвище типа носитеелей.

Возвращаемые значения

Ошибки

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


Носитель

Функции | Описание
rdr_connect_carrier | Открытие соединения с носителем Открытие соединения с носителем.
rdr_format_carrier | Форматирование и открытие соединения с носителем.
rdr_disconnect_carrier | Закрытие соединения с носителем. Закрытие соединения с носителем.


rdr_connect_carrier

Открытие соединения с носителем Открытие соединения с носителем.

Функция открывает соединение с носителем.

SUPSYSE_STATE_CONNECTED

RDR_STATE_CARRIER

TSupErr rdr_connect_carrier(
  TSupSysEContext * context
);

SUPSYSE_STATE_CONNECTED

RDR_STATE_CARRIER

Аргументы

context
[in] контекст считывателя

Возвращаемые значения

Ошибки

См. также

Носитель , rdr_disconnect_carrier, supsys_connect

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_format_carrier

Форматирование и открытие соединения с носителем.

Функция форматирует и открывает соединение с носителем.

SUPSYSE_STATE_CONNECTED

RDR_STATE_CARRIER

TSupErr rdr_format_carrier(
  TSupSysEContext * context
);

SUPSYSE_STATE_CONNECTED

RDR_STATE_CARRIER

Аргументы

context
[in] контекст считывателя

Возвращаемые значения

Ошибки

См. также

Носитель , rdr_disconnect_carrier, supsys_connect, rdr_connect_carrier

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_disconnect_carrier

Закрытие соединения с носителем. Закрытие соединения с носителем.

Функция закрывает соединение с носителем. Если соединие с носителем не было открыто, то функция завершается и не выполняет никаких действий. Если не закрыто текущее приложение , то предварительно закрывается приложение.

SUPSYSE_STATE_REGISTERED

SUPSYSE_STATE_CONNECTED для состояний >= SUPSYSE_STATE_CONNECTED

TSupErr rdr_disconnect_carrier(
  TSupSysEContext * context
);

SUPSYSE_STATE_REGISTERED

SUPSYSE_STATE_CONNECTED для состояний >= SUPSYSE_STATE_CONNECTED

Аргументы

context
[in] контекст считывателя

Возвращаемые значения

Ошибки

См. также

Носитель , rdr_connect_carrier

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


Приложение

Функции | Описание
rdr_local_machine | Установка local machine. Установка local machine.


rdr_local_machine

Установка local machine. Установка local machine.

Функция устанавливает флаг использования системных приложений.

>= SUPSYSE_STATE_REGISTERED && <= RDR_STATE_FOLDER

TSupErr rdr_local_machine(
  TSupSysEContext * context,
  int local_machine
);

>= SUPSYSE_STATE_REGISTERED && <= RDR_STATE_FOLDER

Аргументы

context
[in] контекст считывателя
local_machine
[in] 1 для установки флага local_machine, 0 для снятия.

Возвращаемые значения

Ошибки

См. также

Приложение

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


Пароль

  • Типы паролей для доступа на приложение
Функции | Описание
rdr_passwd_length | Длина пароля Длина пароля.
rdr_passwd_term | Термин пароль. Термин пароль.
rdr_passwd_change | Смена пароля. Cмена пароля.
rdr_passwd_clear | Очистка пароля. Очистка пароля.
is_password_disabled_by_policy | Получение пароля по умолчанию. Получение пароля по умолчанию (запомненного пароля).
rdr_passwd_default_set | Установка пароля по умолчанию. Установка пароля по умолчанию (запомненный пароль).
rdr_passwd_default_clear | Удаление пароля по умолчанию (запомненного пароля).


Типы паролей для доступа на приложение

Определения типов | Описание
TRdrLoginInfoType | Идентификатор протокола и объекта аутентификации.
Макросы | Описание
RDR_LOGIN_INFO_NO | Пароль не требуется.
RDR_LOGIN_INFO_PASSWD | Основной пароль.
RDR_LOGIN_INFO_PASSWD_MASTER | Мастер пароль.
RDR_LOGIN_INFO_PRIME_PASSWD | Пароль используемый при разметке карты.
RDR_LOGIN_INFO_PUBLIC | Открытая информация.
RDR_LOGIN_INFO_UNKNOWN | Тип неизвестен.


RDR_LOGIN_INFO_NO

Пароль не требуется.

#define RDR_LOGIN_INFO_NO 0

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_LOGIN_INFO_PASSWD

Основной пароль.

#define RDR_LOGIN_INFO_PASSWD 1

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_LOGIN_INFO_PASSWD_MASTER

Мастер пароль.

#define RDR_LOGIN_INFO_PASSWD_MASTER 2

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_LOGIN_INFO_PRIME_PASSWD

Пароль используемый при разметке карты.

#define RDR_LOGIN_INFO_PRIME_PASSWD 3

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_LOGIN_INFO_PUBLIC

Открытая информация.

#define RDR_LOGIN_INFO_PUBLIC 4

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_LOGIN_INFO_UNKNOWN

Тип неизвестен.

#define RDR_LOGIN_INFO_UNKNOWN 0xffff

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


TRdrLoginInfoType

Идентификатор протокола и объекта аутентификации.

typedef unsigned int TRdrLoginInfoType;

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_passwd_length

Длина пароля Длина пароля.

Функция получает тип входной информации (пароль ) для открытия приложение и получения максимальной длинны этой информации.

Если контекст считывателя находится в состоянии RDR_STATE_FOLDER, то возвращаются конкретные значения для этого приложения, если считыватель находится в состоянии SUPSYSE_STATE_REGISTERED, то возвращаются максимальная длина пароля.

TSupErr rdr_passwd_length(
  const TSupSysEContext * context,
  TRdrLoginInfoType * type,
  size_t * max_length,
  size_t * min_length
);

Аргументы

context
[in] контекст считывателя.
type
[in,out] тип входной информации: пароль, мастер пароль, открытая информация и т.д. На входе информация длину, которой необходимо получить или RDR_LOGIN_INFO_UNKNOWN для получения типа и тдлины информации по умолчанию. На выходе то же или тип информации по умолчанию соответственно. Может быть NULL для получения длины входной информации по умолчанию.
max_length
[in/out] in - максимальное количество символов, для ввода информации; out - требуемое количество символов для записи информации. Длина указывается в символах не включая последний нулевой символ. Может быть NULL.
min_length
[in/out] out - минимальный размер пароля. Может быть NULL.

Возвращаемые значения

Ошибки

См. также

Пароль , rdr_login

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_passwd_term

Термин пароль. Термин пароль.

Функция получает термин пароль для данного типа носителя.

TSupErr rdr_passwd_term(
  const TSupSysEContext * context,
  size_t * length,
  TCHAR * term
);

Аргументы

context
[in] контекст считывателя
length
[in/out] in - максимальное количество символов, которые могут быть записаны; out - требуемое количество символов для записи термина. Длина указывается в символах не включая последний нулевой символ.
term
[out] термин пароль или NULL для получения только длины термина.

Возвращаемые значения

Ошибки

См. также

Пароль , rdr_folder_open

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_passwd_change

Смена пароля. Cмена пароля.

Функция изменяет пароль на приложение .

Если был сохранен пароль по умолчанию, то функция изменяет пароль по умолчанию.

>= RDR_STATE_LOGEDIN

TSupErr rdr_passwd_change(
  TSupSysEContext * context,
  const TCHAR * new_passwd
);

>= RDR_STATE_LOGEDIN

Аргументы

context
[in] контекст считывателя.
new_passwd
[in] новый пароль. Может быть NULL, для очистки пароля. Под очисткой понимается установка в значение по умолчанию, т.е. при передаче пустой строки или при передаче NULL вход в приложение будет произведен, но это не означает, что будет сброшен пароль или установлен пароль пустая строка.

Возвращаемые значения

Ошибки

См. также

Пароль , rdr_passwd_clear, rdr_passwd_default_set, rdr_login

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_passwd_clear

Очистка пароля. Очистка пароля.

Функция устанавливает пароль на приложение в значение по умолчанию.

Если был сохранен пароль по умолчанию, то он удаляется.

RDR_STATE_FOLDER

TSupErr rdr_passwd_clear(
  TSupSysEContext * context,
  const TCHAR * master_passwd
);

RDR_STATE_FOLDER

Аргументы

context
[in] контекст считывателя. В контексте должно быть выбрано приложение. Под очисткой понимается установка в значение по умолчанию, т.е. при передаче пустой строки или при передаче NULL вход в приложение будет произведен, но это не очначает, что будет сброшен пароль или установлен пароль пустая строка.
master_passwd
[in] пароль для очистки пароля. Может быть NULL, если мастер пароль не установлен.

Возвращаемые значения

Ошибки

См. также

Пароль , rdr_passwd_change, rdr_passwd_default_clear, rdr_folder_open

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


is_password_disabled_by_policy

Получение пароля по умолчанию. Получение пароля по умолчанию (запомненного пароля).

BOOL is_password_disabled_by_policy(

);

Аргументы

context
[in] контекст считывателя
passwd_length
[in,out] in - максимальное количество символов, которые могут быть возвращены; out - требуемое количество символов для возврата. Длина указывается в символах не включая последний нулевой символ.
passwd
[out] Пароль

Возвращаемые значения

Ошибки

См. также

Пароль , rdr_passwd_default_clear, rdr_passwd_default_set, rdr_connect_carrier

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_passwd_default_set

Установка пароля по умолчанию. Установка пароля по умолчанию (запомненный пароль).

Функция получает пароль установленный по умолчанию.

Если контекст находится в состоянии RDR_STATE_CARRIER, то устанавливается пароль на носитель.

>= RDR_STATE_CARRIER

TSupErr rdr_passwd_default_set(
  const TSupSysEContext * context,
  const TCHAR * passwd
);

>= RDR_STATE_CARRIER

Аргументы

context
[in] контекст считывателя.
passwd
[in] пароль, для установки пустого пароля "", для не установки пароля NULL.

Возвращаемые значения

Ошибки

См. также

Пароль , rdr_passwd_default_clear, rdr_passwd_default_get, rdr_connect_carrier

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_passwd_default_clear

Удаление пароля по умолчанию (запомненного пароля).

RDR_STATE_CARRIER

TSupErr rdr_passwd_default_clear(
  const TSupSysEContext * context
);

RDR_STATE_CARRIER

Аргументы

context
[in] контекст считывателя.

Возвращаемые значения

Ошибки

См. также

Пароль , rdr_passwd_default_get, rdr_passwd_default_set

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


Shortcut

Функции | Описание
rdr_shortcut_get | Получение уникального номера, папки и остальной информации по shortcut.
rdr_shortcut_set | Установка shortcut. Установка shortcut.
rdr_shortcut_clear | Удаление ссылки на носитель. Удаление типа носителя по умолчанию.


rdr_shortcut_get

Получение уникального номера, папки и остальной информации по shortcut.

TSupErr rdr_shortcut_get(
  int local_machine,
  const TCHAR * shortcut,
  size_t * unique_length,
  TCHAR * unique,
  size_t * folder_length,
  TCHAR * folder,
  size_t * untreated_length,
  TCHAR * untreated,
  TSupSysENickname media_type
);

Аргументы

local_machine
[in] флаг local_machine
shortcut
[in] shortcut
unique_length
[in,out] in - максимальное количество символов уникального номера, которые могут быть возвращены; out - требуемое количество символов для возврата. Длина указывается в символах не включая последний нулевой символ.
unique
[out] Уникальный номер. Может быть NULL.
folder_length
[in,out] in - максимальное количество символов имени папки, которые могут быть возвращены; out - требуемое количество символов для возврата. Длина указывается в символах не включая последний нулевой символ.
folder
[out] Имя папки. Может быть NULL.
untreated_length
[in,out] in - максимальное количество необработанной информации, которые могут быть возвращены; out - требуемое количество символов для возврата. Длина указывается в символах не включая последний нулевой символ.
untreated
[out] Необработанная информация. Может быть NULL.
media_type
[in] nickname media, для которого получанется информация

Возвращаемые значения

Ошибки

См. также

Shortcut rdr_shortcut_set

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_shortcut_set

Установка shortcut. Установка shortcut.

>= RDR_STATE_CARRIER

TSupErr rdr_shortcut_set(
  const TSupSysEContext * context,
  const TCHAR * shortcut,
  const TCHAR * untreated
);

>= RDR_STATE_CARRIER

Аргументы

context
[in] контекст считывателя.
shortcut
[in] shortcut
untreated
[in] Дополнительная неразбираемая информация

Возвращаемые значения

Ошибки

См. также

Shortcut , rdr_passwd_default_clear, rdr_passwd_default_get, rdr_connect_carrier

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_shortcut_clear

Удаление ссылки на носитель. Удаление типа носителя по умолчанию.

Функция удаляет тип носителя по умолчанию, при этом, если был сохраненный пароль, то удаляется и этот пароль, если были установлены shortcut на этот носитель, то удаляются и shortcut.

TSupErr rdr_shortcut_clear(
  int local_machine,
  const TCHAR * shortcut
);

Аргументы

local_machine
[in] 0 для удаление пользовательской, !0 для удаление local machine
shortcut
[in] удаляемый shortcut.

Возвращаемые значения

Ошибки

См. также

Shortcut

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


Папки

Структуры | Описание
TRdrFolderEnumContext_ | Структура перечисления папок.
Функции | Описание
rdr_folder_enum_open | Открытие перечисления папок. Открытие контекста перечисления папок.
rdr_folder_enum_next | Получение следующей папки. Получение следующей папки.
rdr_folder_enum_close | Открытие перечисления папок. Открытие контекста перечисления папок.
rdr_folder_open | Открытие папки. Открытие папки.
rdr_folder_close | Закрытие папки. Закрытие папки.
rdr_folder_clear | Очистка папки Очистка папки.
Макросы | Описание
RDR_FOLDER_ENUM_FLAG_NEW | Флаг указывающий, что необходимо перечислять папки, которых нет на носителе, но которые могут быть созданы.


RDR_FOLDER_ENUM_FLAG_NEW

Флаг указывающий, что необходимо перечислять папки, которых нет на носителе, но которые могут быть созданы.

#define RDR_FOLDER_ENUM_FLAG_NEW 0x1

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_folder_enum_open

Открытие перечисления папок. Открытие контекста перечисления папок.

<= RDR_STATE_CARRIER && >= RDR_STATE_PRIME

TSupErr rdr_folder_enum_open(
  const TSupSysEContext * context,
  TRdrFolderEnumContext ** enum_ctx,
  size_t * folder_length,
  const TCHAR * prototype,
  unsigned flags
);

<= RDR_STATE_CARRIER && >= RDR_STATE_PRIME

Аргументы

context
[in] контекст считывателя
enum_ctx
[out] контекст перечисления папок
folder_length
[out] размер в символах максимальной по длине имени папки, не включая завершающий 0.
prototype
[in] прототип имени папки для перечисления новых папок, при перечислении существующих папок должен быть NULL.
flags
Флаги перечисления папок

Возвращаемые значения

Ошибки

См. также

Папки , rdr_folder_enum_next, rdr_folder_enum_close

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_folder_enum_next

Получение следующей папки. Получение следующей папки.

>= RDR_STATE_CARRIER && <= RDR_STATE_PRIME

TSupErr rdr_folder_enum_next(
  TRdrFolderEnumContext * enum_ctx,
  TCHAR * folder
);

>= RDR_STATE_CARRIER && <= RDR_STATE_PRIME

Аргументы

enum_ctx
[in] контекст перечисления папок
folder
[out] имя папки; имя должно быть выделено по длинне + 1 возвращенной при открытии контекста перечисления.

Возвращаемые значения

Ошибки

См. также

Папки , rdr_folder_enum_open, rdr_folder_enum_close

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_folder_enum_close

Открытие перечисления папок. Открытие контекста перечисления папок.

RDR_STATE_CARRIER

TSupErr rdr_folder_enum_close(
  TRdrFolderEnumContext * enum_ctx
);

RDR_STATE_CARRIER

Аргументы

enum_ctx
[out] контекст перечисления папок

Возвращаемые значения

Ошибки

См. также

Папки , rdr_folder_enum_open, rdr_folder_enum_next

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_folder_open

Открытие папки. Открытие папки.

>= RDR_STATE_CARRIER && <= RDR_STATE_PRIME

RDR_STATE_FOLDER

TSupErr rdr_folder_open(
  TSupSysEContext * context,
  const TCHAR * mode,
  const TCHAR * folder
);

>= RDR_STATE_CARRIER && <= RDR_STATE_PRIME

RDR_STATE_FOLDER

Аргументы

context
[in] контекст считывателя
mode
[in] метод открытия файла. Допускаются следующие флаги:
  • "r" открытие существующего
  • "w" открытие на создание
folder
[in] имя папки

Возвращаемые значения

Ошибки

См. также

Папки , rdr_folder_close, rdr_folder_open

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_folder_close

Закрытие папки. Закрытие папки.

Функция закрывает доступ к текущей папке. Если доступ к папке не был открыт, то функция завершается и не выполняет никаких действий. Если не был закрыт доступ к файлу, то предварительно закрывается файл .

SUPSYSE_STATE_REGISTERED

RDR_STATE_CARRIER для состояний >= RDR_STATE_CARRIER

TSupErr rdr_folder_close(
  TSupSysEContext * context
);

SUPSYSE_STATE_REGISTERED

RDR_STATE_CARRIER для состояний >= RDR_STATE_CARRIER

Аргументы

context
[in] контекст считывателя

Возвращаемые значения

Ошибки

См. также

Папки , rdr_folder_open, rdr_folder_close

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_folder_clear

Очистка папки Очистка папки.

Удаление папки.

RDR_STATE_LOGEDIN

RDR_STATE_CARRIER

TSupErr rdr_folder_clear(
  TSupSysEContext * context
);

RDR_STATE_LOGEDIN

RDR_STATE_CARRIER

Аргументы

context
[in] контекст считывателя

Возвращаемые значения

Ошибки

См. также

Папки

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


TRdrFolderEnumContext_

Структура перечисления папок.

Структура используемая при перечислении папок. Содержимое структуры скрыто.

typedef struct TRdrFolderEnumContext_ {
} TRdrFolderEnumContext;

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


Получение доступа к папке

Функции | Описание
rdr_login | Открытие доступа к приложению.
rdr_logout | Закрытие доступа к приложению. Закрытие доступа к приложению.
rdr_prime | Открытие доступа к приложению. Открытие доступа к приложению.
rdr_prime_login | Открытие доступа к приложению из состояния выпуска карты. Открытие доступа к приложению из состояния выпуска карты.


rdr_login

Открытие доступа к приложению.

Функция открывает приложение .

RDR_STATE_FOLDER

RDR_STATE_LOGEDIN

TSupErr rdr_login(
  TSupSysEContext * context,
  const TCHAR * passwd,
  int * retries
);

RDR_STATE_FOLDER

RDR_STATE_LOGEDIN

Аргументы

context
[in] контекст считывателя
passwd
[in] пароль
retries
[out] количество попыток оставщееся для предъявления пароля, параметр может быть NULL.

Возвращаемые значения

Ошибки

См. также

Получение доступа к папке , rdr_logout, rdr_folder_open

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_logout

Закрытие доступа к приложению. Закрытие доступа к приложению.

Функция закрывает доступ на приложение . Если доступ к приложению не был открыт, то функция завершается и не выполняет никаких действий. Если не был закрыт доступ к папке, то предварительно папка закрывается.

SUPSYSE_STATE_REGISTERED

RDR_STATE_FOLDER для состояний >= RDR_STATE_FOLDER

TSupErr rdr_logout(
  TSupSysEContext * context
);

SUPSYSE_STATE_REGISTERED

RDR_STATE_FOLDER для состояний >= RDR_STATE_FOLDER

Аргументы

context
[in] контекст считывателя

Возвращаемые значения

Ошибки

См. также

Получение доступа к папке , rdr_login, rdr_logout

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_prime

Открытие доступа к приложению. Открытие доступа к приложению.

Функция открывает приложение на Выпуск .

RDR_STATE_CARRIER

RDR_STATE_PRIME

TSupErr rdr_prime(
  TSupSysEContext * context,
  const TCHAR * passwd,
  int * retries
);

RDR_STATE_CARRIER

RDR_STATE_PRIME

Аргументы

context
[in] контекст считывателя
passwd
[in] пароль
retries
[out] оставщееся количество попыток предъявления пароля. Может быть NULL.

Возвращаемые значения

Ошибки

См. также

Получение доступа к папке , rdr_logout, rdr_folder_open

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_prime_login

Открытие доступа к приложению из состояния выпуска карты. Открытие доступа к приложению из состояния выпуска карты.

RDR_STATE_FOLDER

RDR_STATE_LOGEDIN

TSupErr rdr_prime_login(
  TSupSysEContext * context
);

Аргументы

context
[in] Контест считывателя

RDR_STATE_FOLDER

RDR_STATE_LOGEDIN

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


Блокировки

Функции | Описание
rdr_lock | Блокировка носителя. Блокировка носителя.
rdr_unlock | Разблокировка носителя. Разблокировка носителя.


rdr_lock

Блокировка носителя. Блокировка носителя.

>= SUPSYSE_STATE_REGISTERED

TSupErr rdr_lock(
  TSupSysEContext * context
);

>= SUPSYSE_STATE_REGISTERED

Аргументы

context
[in] контекст считывателя.

Возвращаемые значения

Ошибки

См. также

Блокировки , rdr_unlock

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_unlock

Разблокировка носителя. Разблокировка носителя.

>= SUPSYSE_STATE_REGISTERED

TSupErr rdr_unlock(
  TSupSysEContext * context
);

>= SUPSYSE_STATE_REGISTERED

Аргументы

context
[in] контекст считывателя.

Возвращаемые значения

Ошибки

См. также

Блокировки , rdr_unlock

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


Работа с файлами

Функции | Описание
rdr_file_open | Открытие файла Открытие файла.
rdr_file_close | Закрытие файла. Закрытие файла.
rdr_file_write | Запись в файл. Запись в файл.
rdr_file_read | Чтение из файла Чтение из файла
rdr_file_length | Получение реального размера файла. Размер файла.
rdr_file_chsize | Изменение размера файла с проверкой максимальной длины Изменение размера файла с проверкой максимальной длины.
rdr_file_unlink | Установка длинны файла. Удаление файла.
Определения типов | Описание
TRdrFileNumber | Номер файла.


TRdrFileNumber

Номер файла.

typedef int TRdrFileNumber;

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_file_open

Открытие файла Открытие файла.

Функция открывает файл на носителе или открывает доступ к блоку последовательной записи.

>= RDR_STATE_FOLDER && <= RDR_STATE_LOGEDIN

RDR_STATE_FILE

Описание флагов
  • O_RDONLY Открытие только на чтение
  • O_WRONLY Открытие только на запись
  • O_RDWR Открытие на чтение и запись
  • O_IGNORE Пропускать ошибки
  • O_CREATE Создание файла, если не установлен флаг O_TRUNC и файл уже существует, или он существует всегда, то будет возвращен код ошибки RDR_ERR_FILE_EXIST. Не гарантируется, что размер файла будет установлен в 0.
  • O_TRUNC Если файл уже существует, то запись в файл будет производиться без предварительного чтения из него. Так же гарантируется, что запись за конец файла приведет к заполнению нулями пространства от текущего конца файла до начала записи, при этом последующее открытие файла без флага O_TRUNC не гарантирует этого эффекта.
  • O_PRIVATE Создание файла доступного только при наличии пароля.

TSupErr rdr_file_open(
  TSupSysEContext * context,
  const TCHAR * mode,
  const TCHAR * file_name,
  TRdrFileNumber filno
);

>= RDR_STATE_FOLDER && <= RDR_STATE_LOGEDIN

RDR_STATE_FILE

Аргументы

context
[in/out] контекст считывателя
mode
[in] метод открытия файла. Допускаются следующие флаги:
  • "r" O_RDONLY
  • "w" O_CREAT | O_WRONLY | O_TRUNC
  • "wp" O_PRIVATE | O_CREAT | O_WRONLY | O_TRUNC
  • "r+" O_RDWR
  • "w+" O_RDWR | O_CREAT | O_TRUNC
  • "wp+" O_PRIVATE | O_RDWR | O_CREAT | O_TRUNC

Аргументы

file_name
[in] имя открываемого файла. Для открытия носителя поддерживающего файловую систему имя должно быть отлично от NULL, для носителя не поддерживающего файловую систему имя должно быть NULL.
fileno
[in] номер открываемого файла. Для открытия носителя поддерживающего файловую систему имя должно быть отлично от 0, для носителя не поддерживающего файловую систему имя должно быть NULL.

Возвращаемые значения

Ошибки

См. также

Работа с файлами

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_file_close

Закрытие файла. Закрытие файла.

Функция закрывает файл на носителе. Если файл не был открыт, то функция ничего не далает.

SUPSYSE_STATE_REGISTERED

RDR_STATE_FOLDER, если пароль не предъявлялся, RDR_STATE_LOGEDIN если пароль предъявлялся

TSupErr rdr_file_close(
  TSupSysEContext * context
);

SUPSYSE_STATE_REGISTERED

RDR_STATE_FOLDER, если пароль не предъявлялся, RDR_STATE_LOGEDIN если пароль предъявлялся

Аргументы

context
[in] контекст считывателя

Возвращаемые значения

Ошибки

См. также

Работа с файлами , rdr_file_open

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_file_write

Запись в файл. Запись в файл.

Функция записывает size байт с носителя, заданного контекстом context начиная с позиции pos из буфера buffer.

Если была установлена функция повтора операции, то осуществляется повтор операции.

Функция производит запись информации в файл.

  • Гарантируются, что при записи за пределы файла, при открытии файла с флагом o_trunc предварительного чтения информации при записи за конец файла производиться не будет.

Не гарантируется возможность записи от конца файла, до начала записи.

RDR_STATE_FILE

TSupErr rdr_file_write(
  TSupSysEContext * context,
  size_t pos,
  size_t size,
  const void * buffer,
  size_t * writen
);

RDR_STATE_FILE

Аргументы

context
[in] контекст считывателя
pos
[in] начальная позиция записи
size
[in] количество запысываемых байт
buffer
[in] записываемая информация
writen
[out] количество записанных байт. Может быть NULL, тогда проверяется количество записанных и записываемых байт.

Возвращаемые значения

Ошибки

См. также

Работа с файлами

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_file_read

Чтение из файла Чтение из файла

Функция читает size байт с носителя, заданного контекстом context начиная с позиции pos в буфер buffer.

Если была установлена функция повтора операции, то осуществляется повтор операции.

RDR_STATE_FILE

TSupErr rdr_file_read(
  TSupSysEContext * context,
  size_t pos,
  size_t size,
  void * buffer,
  size_t * read_len
);

RDR_STATE_FILE

Аргументы

context
[in] контекст считывателя
pos
[in] начальная позиция чтения
size
[in] количество читаемых байт
buffer
[out] прочитанная информация
read
[out] количество прочитанных байт. Может быть NULL, тогда проверяется количество читаемых и прочитанных байт.

Возвращаемые значения

Ошибки

См. также

Работа с файлами

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_file_length

Получение реального размера файла. Размер файла.

Функция получает реальный размер файла, если функция не поддерживается, то возвращается максимальный размер файла.

RDR_STATE_FILE

TSupErr rdr_file_length(
  TSupSysEContext * context,
  size_t * size
);

RDR_STATE_FILE

Аргументы

context
[in] контекст считывателя
size
[out] размер файла

Возвращаемые значения

Ошибки

См. также

Работа с файлами

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_file_chsize

Изменение размера файла с проверкой максимальной длины Изменение размера файла с проверкой максимальной длины.

Функция изменяет размер файла. Если увеличение размера файла невозможно, то возвращается код ошибки и возвращается максимальная длина файла. Если размер файла не может быть уменьшен, то действий не производится и возвращается текущая длина файла.

RDR_STATE_FILE

TSupErr rdr_file_chsize(
  TSupSysEContext * context,
  size_t * size
);

RDR_STATE_FILE

Аргументы

context
[in] контекст считывателя
size
[in,out] in - требуемый размер файла, out - созданный или максимальный размер файла

Возвращаемые значения

Ошибки

См. также

Работа с файлами

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_file_unlink

Установка длинны файла. Удаление файла.

Если была установлена функция повтора операции, то осуществляется повтор операции.

RDR_STATE_LOGEDIN

TSupErr rdr_file_unlink(
  TSupSysEContext * context,
  const TCHAR * file_name,
  TRdrFileNumber filno
);

RDR_STATE_LOGEDIN

Аргументы

context
[in] контекст считывателя
file_name
[in] имя удаляемого файла. Для удаление файла на носителе поддерживающего файловую систему имя должно быть отлично от NULL, для носителя не поддерживающего файловую систему имя должно быть NULL.
fileno
[in] номер удаляемого файла. Для удаление файла на носителе поддерживающего файловую систему имя должно быть отлично от 0, для носителя не поддерживающего файловую систему имя должно быть NULL.

Возвращаемые значения

Ошибки

См. также

Работа с файлами

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


Уникальные номера

Функции | Описание
rdr_unique_get | Получение уникального номера носителя. Получение уникального номера носителя.
rdr_unique_set | Установка уникального номера носителя. Установка уникального номера носителя.


rdr_unique_get

Получение уникального номера носителя. Получение уникального номера носителя.

RDR_STATE_CARRIER

TSupErr rdr_unique_get(
  const TSupSysEContext * context,
  size_t * length,
  TCHAR * unique
);

RDR_STATE_CARRIER

Аргументы

context
[in] контекст считывателя
length
[in/out] in максимальное количество символов, которые могут быть записаны; out - требуемое количество символов для записи номера.
unique
[out] уникальный номер носителя.

Возвращаемые значения

Ошибки

См. также

Уникальные номера

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_unique_set

Установка уникального номера носителя. Установка уникального номера носителя.

RDR_STATE_CARRIER

TSupErr rdr_unique_set(
  TSupSysEContext * context,
  TCHAR * unique
);

Примечания

Функция может устанавливать не весь передаваемый уникальный номер, а так же может изменять переданный уникальный номер. Для получения установленного уникального номера необходимо вызвать rdr_unuque_get.

RDR_STATE_CARRIER

Аргументы

context
[in] контекст считывателя
unique
[out] уникальный номер носителя.

Возвращаемые значения

Ошибки

См. также

Уникальные номера

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


Ошибки

Все функции reader могут возвращать следующие коды ошибок:

  • Коды ошибок support
  • Коды ошибок reader см. Коды ошибок
  • Коды ошибок конкретного считывателя
  • Коды ошибок индикатора процесса выполнения
  • Коды ошибок функции повтора операции

  • Коды ошибок
Функции | Описание
rdr_error | Получение текста ошибки по номеру ошибки.


Коды ошибок

Макросы | Описание
RDR_ERR_NO_CARRIER | Отсуствует носитель в считывателе.
RDR_ERR_INVALID_MEDIA | Носитель не может быть использован в качестве ключевого или структура носителя искажена.
RDR_ERR_ANOTHER_MEDIA | Вставлен другой носитель.
RDR_ERR_MEDIA_CHANGED | Многократная смена носителя.
RDR_ERR_WRITE_PROTECT | Носитель защищен от записи.
RDR_ERR_NEED_PASSWD | Треубется пароль, а его нет.
RDR_ERR_INVALID_PASSWD | Введен неправильный пароль.
RDR_ERR_INVALID_PASSWD_FORMAT | Формат пароля неверный.
RDR_ERR_PASSWD_LOCKED | Пароль заблокирован.
RDR_ERR_FULL | Нет места на носителе.
RDR_ERR_FILE_NOT_FOUND | Файл не найден.
RDR_ERR_FILE_EXIST | Файл уже существует.
RDR_ERR_FILE_DISTORT | Содержимое файла искажено.
RDR_ERR_PRIME | Носитель требует предварительной разметки перед использованием.
RDR_ERR_FORMAT | Носитель не отформатирован.
RDR_ERR_VERSION_1 | Версия старше 1.0 не поддерживается.
RDR_ERR_BLOCK | Операция завершена без ошибок, записан (прочитан) очередной блок, требуется повтор операции для записи последующих блоков.
RDR_ERR_RETRY_ATTACH | Присоединение к повтору.
RDR_ERR_RETRY_DUP | Дублирование контекста повтора.
RDR_ERR_RETRY_FREE | Освобождение контекста повтора.
RDR_ERR_INVALID | Первый код ошибки не использующийся для вывода сообщения на экран.


RDR_ERR_NO_CARRIER

Отсуствует носитель в считывателе.

#define RDR_ERR_NO_CARRIER 0x3000

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_ERR_INVALID_MEDIA

Носитель не может быть использован в качестве ключевого или структура носителя искажена.

#define RDR_ERR_INVALID_MEDIA 0x3001

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_ERR_ANOTHER_MEDIA

Вставлен другой носитель.

#define RDR_ERR_ANOTHER_MEDIA 0x3002

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_ERR_MEDIA_CHANGED

Многократная смена носителя.

#define RDR_ERR_MEDIA_CHANGED 0x3003

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_ERR_WRITE_PROTECT

Носитель защищен от записи.

#define RDR_ERR_WRITE_PROTECT 0x3004

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_ERR_NEED_PASSWD

Треубется пароль, а его нет.

#define RDR_ERR_NEED_PASSWD 0x3005

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_ERR_INVALID_PASSWD

Введен неправильный пароль.

#define RDR_ERR_INVALID_PASSWD 0x3006

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_ERR_INVALID_PASSWD_FORMAT

Формат пароля неверный.

Неверный формат пароля. Пароль при этом не предъявляется носителю (то есть счетчик использования пароля не изменяется).

#define RDR_ERR_INVALID_PASSWD_FORMAT 0x3007

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_ERR_PASSWD_LOCKED

Пароль заблокирован.

Неверный пароль, пароль заблокирован, дальнейшее предьявление пароля невозможно.

#define RDR_ERR_PASSWD_LOCKED 0x3008

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_ERR_FULL

Нет места на носителе.

#define RDR_ERR_FULL 0x3009

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_ERR_FILE_NOT_FOUND

Файл не найден.

#define RDR_ERR_FILE_NOT_FOUND 0x300A

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_ERR_FILE_EXIST

Файл уже существует.

#define RDR_ERR_FILE_EXIST 0x300B

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_ERR_FILE_DISTORT

Содержимое файла искажено.

#define RDR_ERR_FILE_DISTORT 0x300C

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_ERR_PRIME

Носитель требует предварительной разметки перед использованием.

После возврата данного кода должна быть предпринята попытка (с разрешения пользователя) по разметке носителя.

#define RDR_ERR_PRIME 0x300D

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_ERR_FORMAT

Носитель не отформатирован.

После возврата данного кода должна быть предпринята попытка (с разрешения пользователя) по форматированию носителя.

#define RDR_ERR_FORMAT 0x300E

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_ERR_VERSION_1

Версия старше 1.0 не поддерживается.

#define RDR_ERR_VERSION_1 0x300F

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_ERR_BLOCK

Операция завершена без ошибок, записан (прочитан) очередной блок, требуется повтор операции для записи последующих блоков.

Текст ошибки отсутствует.

#define RDR_ERR_BLOCK 0x30FC

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_ERR_RETRY_ATTACH

Присоединение к повтору.

Присоединение контекста повтора к контексту считывателя.

#define RDR_ERR_RETRY_ATTACH 0x30FD

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_ERR_RETRY_DUP

Дублирование контекста повтора.

Дублирование контекста повтора.

#define RDR_ERR_RETRY_DUP 0x30FE

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_ERR_RETRY_FREE

Освобождение контекста повтора.

Освобождение контекста повтора от контекста считывателя.

#define RDR_ERR_RETRY_FREE 0x30FF

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_ERR_INVALID

Первый код ошибки не использующийся для вывода сообщения на экран.

#define RDR_ERR_INVALID 0x3E00

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_error

Получение текста ошибки по номеру ошибки.

Функция получает текст ошибки по его номеру, в том числе и для определенных пользователем кодов ошибок.

TSupErr rdr_error(
  const TSupSysEContext * context,
  TSupErr err,
  size_t * length,
  TCHAR * text
);

Аргументы

context
[in] контекст считывателя или NULL, если контекст не известен. Для получения текста пользовательских ошибок контекст должен быть задан.
err
[in] код ошибки
length
[in,out] in - максимальное количество символов текста, которые могут быть возвращены; out - требуемое количество символов для возврата. Длина указывается в символах не включая последний нулевой символ.
text
[out] текст сообщения об ошибке

Возвращаемые значения

Ошибки

См. также

Ошибки

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


Повторы

  • CALLBACK повтора операции.
Функции | Описание
rdr_same_media | Проверка правильности носителя. Проверка правильности носителя.
rdr_retry_proc_set | Установка функции повтора операции. Установка функции повтора операции.
rdr_cancel_consequences | Получение последствий cancel. Получение последствий cancel.
Макросы | Описание
RDR_SAME_WRITE_AVAIL | Флаг указывающий на необходимость проверки возможности записи на носитель.


CALLBACK повтора операции.

Структуры | Описание
TRdrRetryContextDup_ | Структура дублирования контекста функции повтора операции.
TRdrRetryContextAttach_ | Структура присоединения контекста считывателя к функции повтора операции.
Определения типов | Описание
TRdrRetryProc | Указатель на функцию повтора операции.


TRdrRetryProc

Указатель на функцию повтора операции.

typedef TSupErr(* TRdrRetryProc)(void *info, TSupErr code);

Аргументы

info
[in/out] информация переданная при установки функции повтора. При code == RDR_ERR_RETRY_DUP структура TRdrRetryContextDup. При code == RDR_ERR_RETRY_FREE информация переданная при установки функции. При code == RDR_ERR_RETRY_ATTACH структура TRdrRetryContextAttach.
code
[in] код ошибки вызвавщий появление окна. Возможны специальные коды ошибок:
  • RDR_ERR_RETRY_ATTACH - присоединение контекста считывателя
  • RDR_ERR_RETRY_FREE - освобождение контекста;
  • RDR_ERR_RETRY_DUP - дублирование контекста.

Возвращаемые значения

Ошибки

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


TRdrRetryContextDup_

Структура дублирования контекста функции повтора операции.

Для дублирования контекста функции повтора операции на вход функции TRdrRetryProc должен быть передан код ошибки RDR_ERR_RETRY_DUP в качестве code и описываемая структура в качестве параметра info.

typedef struct TRdrRetryContextDup_ {
  size_t size_of;
  TSupSysEContext * dest_context;
  void * src_info;
  void * dest_info;
} TRdrRetryContextDup;

Члены

size_of
Размер структуры в байтах.
dest_context
Контекст для дублирования.
src_info
Информация для повтора операции исходного контекста.
dest_info
Информация для повтора операции контекста для дублирования.

См. также

TRdrRetryProc, RDR_ERR_RETRY_DUP

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


TRdrRetryContextAttach_

Структура присоединения контекста считывателя к функции повтора операции.

Для присоединения контекста считывателя к контексту функции повтора операции на вход функции TRdrRetryProc должен быть передан код ошибки RDR_ERR_RETRY_ATTACH в качестве code и описываемая структура в качестве параметра info.

typedef struct TRdrRetryContextAttach_ {
  size_t size_of;
  TSupSysEContext * context;
  void * info;
} TRdrRetryContextAttach;

Члены

size_of
Размер структуры в байтах.
context
Контекст считывателя для присоединения к повтору операции.
info
Информация для повтора операции.

См. также

TRdrRetryProc, RDR_ERR_RETRY_ATTACH

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_SAME_WRITE_AVAIL

Флаг указывающий на необходимость проверки возможности записи на носитель.

Флаг обычно используется в случае, когда функция записи информации на носитель вернула ошибку RDR_ERR_WRITE_PROTECT.

#define RDR_SAME_WRITE_AVAIL 0x1

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_same_media

Проверка правильности носителя. Проверка правильности носителя.

Функция проверяет наличие носителя в считывателе, и, при его наличии и установленной связи с носителем, проверяет, что в считывателе находится тот носитель, с которым была установлена связь. Кроме того, если в считывателе находится другой носитель, то возвращается уникальный номер этого носителя.

>= SUPSYSE_STATE_CONNECTED

TSupErr rdr_same_media(
  const TSupSysEContext * context,
  size_t * length,
  TCHAR * unique,
  unsigned flags
);

>= SUPSYSE_STATE_CONNECTED

Аргументы

context
[in] контекст считывателя
length
[in/out] in максимальное количество символов, которые могут быть записаны; out - требуемое количество символов для записи номера.
unique
[out] уникальный номер носителя, который находится в считывателе, если там другой носитель.
flags
[in] Флаги проверки

Возвращаемые значения

Ошибки

См. также

Повторы , rdr_connect, rdr_retry_proc_set

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_retry_proc_set

Установка функции повтора операции. Установка функции повтора операции.

Функция устанавливает в контекст носителя функцию повтора операции. Функция повтора вызывается при отсутствии носителя или при попытке обращения к другому носителю.

>= SUPSYSE_STATE_REGISTERED

TSupErr rdr_retry_proc_set(
  TSupSysEContext * context,
  TRdrRetryProc proc,
  void * info
);

>= SUPSYSE_STATE_REGISTERED

Аргументы

context
[in] контекст считывателя
proc
[in] функция повтора операции, может быть NULL для снятия функции.
info
[in] информация передаваемая в функцию повтора операции.

Возвращаемые значения

Ошибки

См. также

Повторы

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


rdr_cancel_consequences

Получение последствий cancel. Получение последствий cancel.

Функция запрашивает у считывателя последствия прерывания операции

TSupErr rdr_cancel_consequences(
  const TSupSysEContext * context
);

Аргументы

context
[in] контекст считывателя

Возвращаемые значения

Ошибки
Коды возврата | Описание
RDR_ERR_NO | операция будет прервана без изменения состояния на носителе.
RDR_ERR_INVALID_MEDIA | прерывания операции может привести к икажению структуры носителя.
RDR_ERR_FILE_DISTORT | операция может привести к искажению содержимого файла.

См. также

Повторы

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


Загрузка библиотки

Крипто-Про RDK Версия: 4.0

Обратная связь для этой статьи

(c) ООО Крипто-Про. Все права защищены.


Состояния контекста считывателя

Макросы | Описание
RDR_STATE_CARRIER | Установлено соединение с носителем.
RDR_STATE_PRIME | Выпуск носителя.
RDR_STATE_LOGEDIN | Разрешен доступ к приложению.
RDR_STATE_FOLDER | Открыта папка.
RDR_STATE_FILE | Открыт файл.


RDR_STATE_CARRIER

Установлено соединение с носителем.

В считывателе находится носитель и, если это поддерживают библиотеки сопряжения, смена носителя приведет к ошибке при любой операции. Переход в это состояние осуществляется функцией rdr_connect_carrier.

#define RDR_STATE_CARRIER 11

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_STATE_PRIME

Выпуск носителя.

Осуществляется выпуск носителя, введен транспортный PIN-код. Переход в состояние папка может осуществляться минуя это состояние. Переход в это состояние осуществляется функцией rdr_prime, возврат из этого состояния возможен только через переход в состояние папка .

#define RDR_STATE_PRIME 12

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_STATE_LOGEDIN

Разрешен доступ к приложению.

Открыт доступ в приложение , при необходимости задан пароль Переход в это состояние осуществляется функцией rdr_login, rdr_prime_login возврат в предыдущее rdr_logout

#define RDR_STATE_LOGEDIN 14

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_STATE_FOLDER

Открыта папка.

Открыта папка .

#define RDR_STATE_FOLDER 13

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_STATE_FILE

Открыт файл.

Открыт файл .

#define RDR_STATE_FILE 15

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


Флаги считывателя.

Макросы | Описание
RDR_FLAG_BLOCK_RDR | Номер флагов считывателя.
RDR_FLAG_RDR_LONG_NAMES | 1 - носитель поддерживает длинные имена файлов, 0 - нет
RDR_FLAG_RDR_REMOVABLE | 1 - считыватель отчуждаемый, 0 - нет
RDR_FLAG_RDR_UNIQUE | 1 - считыватель поддерживает уникальность номера носителя, 0 - нет
RDR_FLAG_RDR_FOLDERS | 1 - считыватель поддерживает папки (директории, приложения), 0 - нет
RDR_FLAG_RDR_FOLDER_ROOT | 1 - считыватель поддерживает корневую папку, 0 - нет
RDR_FLAG_RDR_VERSION_1 | Количество флагов в версии 1.0.


RDR_FLAG_BLOCK_RDR

Номер флагов считывателя.

#define RDR_FLAG_BLOCK_RDR 0x3000

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_FLAG_RDR_LONG_NAMES

1 - носитель поддерживает длинные имена файлов, 0 - нет

Носитель поддерживающий длинные имена файлов, должен поддерживать и ВСЕ UNICODE символы в имени файла за исключением символа \.

#define RDR_FLAG_RDR_LONG_NAMES 0

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_FLAG_RDR_REMOVABLE

1 - считыватель отчуждаемый, 0 - нет

#define RDR_FLAG_RDR_REMOVABLE 1

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_FLAG_RDR_UNIQUE

1 - считыватель поддерживает уникальность номера носителя, 0 - нет

#define RDR_FLAG_RDR_UNIQUE 2

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_FLAG_RDR_FOLDERS

1 - считыватель поддерживает папки (директории, приложения), 0 - нет

#define RDR_FLAG_RDR_FOLDERS 3

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_FLAG_RDR_FOLDER_ROOT

1 - считыватель поддерживает корневую папку, 0 - нет

#define RDR_FLAG_RDR_FOLDER_ROOT 4

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


RDR_FLAG_RDR_VERSION_1

Количество флагов в версии 1.0.

#define RDR_FLAG_RDR_VERSION_1 (RDR_FLAG_RDR_FOLDER_ROOT+1)

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader\rdr.h


Интерфейс подключения

В этой главе содержится описание структур, функций, макросов необходимых для создания собственного модуля поддержки. Глава разделена на разделы по реализуемым интерфейсам:

  • Вспомогательные определения
  • Интерфейс между списком и элементом
  • Базовые определения
  • Интерфейс к считывателям
  • Интерфейс к датчикам случайных чисел
  • Интерфейс к смарт-картам
  • Интерфейс к считывателям таблеток dallas
  • Пакет установки считывателя, носителя, ДСЧ


Вспомогательные определения

  • Настройка отладочной печати для reader
  • Проверка корректности передаваемых параметров
  • Проверка состояния
  • Вспомогательные структуры передачи информации


Настройка отладочной печати для reader

Макросы | Описание
SUPSYS_FTEXT | Макрос перенаправления вывода в контекст support_context_io.
SUPSYS_PRINTSTR | Вывод строки в отладочную печать.
SUPSYS_PRINTHEX | Вывод в отладочную печать буфера в 16-ричном представлении.
SUPSYS_TYPEO_ERROR | Перенаправление ошибок.
SUPSYS_TYPEO_TRACE | Перенаправление trace.
SUPSYS_TYPEO_TEST | Перенаправление тестов.
Перечисления | Описание
NSupSysTypeO_ | Константы определяющие возможные уровни вывода отладочной информации.


SUPSYS_FTEXT

Макрос перенаправления вывода в контекст support_context_io.

#define SUPSYS_FTEXT(x) SUPPORT_DBFTEXT_(support_context_io, DTEXT( x ) )

Аргументы

x
[in] первый параметр (строка) для вывода в отладочную печать.


SUPSYS_PRINTSTR

Вывод строки в отладочную печать.

#define SUPSYS_PRINTSTR(level, param) CONCAT(SUPPORT_DB_QPRINT_,level)(support_context_io,N_##level,param)

Аргументы

level
[in] Уровень на котором производить вывод
param
[in] параметры для вывода (аналогично параметрам printf). параметр должен быть обрамлен в круглые скобки.


SUPSYS_PRINTHEX

Вывод в отладочную печать буфера в 16-ричном представлении.

#define SUPSYS_PRINTHEX(level, buffer, length) CONCAT(SUPPORT_DB_QPRINT_HEX_,level)(support_context_io,N_##level,DTEXT(__FILE__), __LINE__, SFUNC,NULL,buffer,length)

Аргументы

level
[in] Уровень на котором производить вывод
buffer
[in] буфер для вывода
length
[in] размер выводимой информации в байтах


SUPSYS_TYPEO_ERROR

Перенаправление ошибок.

Направление вывода отладочной информации уровня ошибок на консоль

#define SUPSYS_TYPEO_ERROR CONS


SUPSYS_TYPEO_TRACE

Перенаправление trace.

Направление вывода отладочной информации уровня trace на консоль

#define SUPSYS_TYPEO_TRACE CONS


SUPSYS_TYPEO_TEST

Перенаправление тестов.

Направление вывода отладочной информации уровня тестов на консоль

#define SUPSYS_TYPEO_TEST CONS


NSupSysTypeO_

Константы определяющие возможные уровни вывода отладочной информации.

,suirhtuiwerhtiuwerhtuio

typedef enum NSupSysTypeO_ {
  N_SUPSYS_TYPEO_ERROR = 1,
  N_SUPSYS_TYPEO_TRACE = 2,
  N_SUPSYS_TYPEO_TEST = 4
} NSupSysTypeO;

Элементы перечисления:

N_SUPSYS_TYPEO_ERROR
Уровень выдачи ошибок
N_SUPSYS_TYPEO_TRACE
Уровень выдачи trace
N_SUPSYS_TYPEO_TEST
Уровень выдачи результатов тестов


Проверка корректности передаваемых параметров

Макросы | Описание
SUPSYS_PRE_ACTION | реакция на ложное выражение
SUPSYS_PRE | проверка истинности выражения
SUPSYS_PRE_INFO | проверка передачи переменной, доступной для чтения / записи
SUPSYS_PRE_CONTEXT | проверка передачи контекста, доступного для чтения / записи
SUPSYS_PRE_CCONTEXT | проверка передачи контекста, доступного для чтения
SUPSYS_PRE_READ_PTRS | проверка передачи блока, доступного для чтения
SUPSYS_PRE_WRITE_PTRS | проверка передачи блока, доступного для записи
SUPSYS_PRE_READ_PTR | проверка передачи указателя на элемент доступный для чтения
SUPSYS_PRE_WRITE_PTR | проверка передачи указателя на элемент доступный для записи
SUPSYS_PRE_STRING_PTRS | проверка передачи строки не более заданного числа символов
SUPSYS_PRE_STRING_PTR | проверка передачи строки
SUPSYS_PRE_FUN | проверка передачи указателя на функцию


SUPSYS_PRE_ACTION

реакция на ложное выражение

При неправильно переданных параметрах или завершают текущую функцию с кодом ошибки (в Release версии) или прерывают (точка останова) выполнение (в Debug версии).

#define SUPSYS_PRE_ACTION return SUP_ERR_PARAM

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_PRE

проверка истинности выражения

#define SUPSYS_PRE(x) { if( !(x) ) SUPSYS_PRE_ACTION; }

Аргументы

x
[in] истинное выражение

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_PRE_INFO

проверка передачи переменной, доступной для чтения / записи

#define SUPSYS_PRE_INFO(x, t) SUPSYS_PRE_WRITE_PTRS(x,sizeof(t)); \
    SUPSYS_PRE( ( *(size_t*)info ) >= (sizeof(t)) )

Аргументы

x
[in] переменная
t
[in] тип

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_PRE_CONTEXT

проверка передачи контекста, доступного для чтения / записи

#define SUPSYS_PRE_CONTEXT(x, t) SUPSYS_PRE_WRITE_PTRS(x,sizeof(t))

Аргументы

x
[in] контекст
t
[in] тип контекста

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_PRE_CCONTEXT

проверка передачи контекста, доступного для чтения

#define SUPSYS_PRE_CCONTEXT(x, t) SUPSYS_PRE_READ_PTRS(x,sizeof(t))

Аргументы

x
[in] контекст
t
[in] тип контекста

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_PRE_READ_PTRS

проверка передачи блока, доступного для чтения

#define SUPSYS_PRE_READ_PTRS(x, s) { if( !IS_READ_PTRS(x,s) ) SUPSYS_PRE_ACTION; }

Аргументы

x
[in] блок
s
[in] размер блока

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_PRE_WRITE_PTRS

проверка передачи блока, доступного для записи

#define SUPSYS_PRE_WRITE_PTRS(x, s) { if( !IS_WRITE_PTRS(x,s) ) SUPSYS_PRE_ACTION; }

Аргументы

x
[in] блок
s
[in] размер блока

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_PRE_READ_PTR

проверка передачи указателя на элемент доступный для чтения

#define SUPSYS_PRE_READ_PTR(x) { if( !IS_READ_PTR(x) ) SUPSYS_PRE_ACTION; }

Аргументы

x
[in] указатель

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_PRE_WRITE_PTR

проверка передачи указателя на элемент доступный для записи

#define SUPSYS_PRE_WRITE_PTR(x) { if( !IS_WRITE_PTR(x) ) SUPSYS_PRE_ACTION; }

Аргументы

x
[in] указатель

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_PRE_STRING_PTRS

проверка передачи строки не более заданного числа символов

#define SUPSYS_PRE_STRING_PTRS(x, s) { if( !IS_STRING_PTRS(x,s) ) SUPSYS_PRE_ACTION; }

Аргументы

x
[in] строка
s
[in] размер строки

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_PRE_STRING_PTR

проверка передачи строки

#define SUPSYS_PRE_STRING_PTR(x) { if( !IS_STRING_PTR(x) ) SUPSYS_PRE_ACTION; }

Аргументы

x
[in] строка

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_PRE_FUN

проверка передачи указателя на функцию

#define SUPSYS_PRE_FUN(x) { if( !IS_FUN_PTR(x) ) SUPSYS_PRE_ACTION; }

Аргументы

x
[in] указатель на функцию

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


Проверка состояния

Макросы | Описание
SUPSYS_PRE_STATE_LT | Проверка, что контекст x находится в состоянии меньшем, чем y.
SUPSYS_PRE_STATE_LE | Проверка, что контекст x находится в состоянии меньше или равном, чем y.
SUPSYS_PRE_STATE_EQ | Проверка, что контекст x находится в состоянии равном y.
SUPSYS_PRE_STATE_GE | Проверка, что контекст x находится в состоянии больше или равном y.
SUPSYS_PRE_STATE_GT | Проверка, что контекст x находится в состоянии больше y.


SUPSYS_PRE_STATE_LT

Проверка, что контекст x находится в состоянии меньшем, чем y.

#define SUPSYS_PRE_STATE_LT(x, y)

Аргументы

x
контекст модуля
y
сравниваемое состояние

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_PRE_STATE_LE

Проверка, что контекст x находится в состоянии меньше или равном, чем y.

#define SUPSYS_PRE_STATE_LE(x, y)

Аргументы

x
контекст модуля
y
сравниваемое состояние

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_PRE_STATE_EQ

Проверка, что контекст x находится в состоянии равном y.

#define SUPSYS_PRE_STATE_EQ(x, y)

Аргументы

x
контекст модуля
y
сравниваемое состояние

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_PRE_STATE_GE

Проверка, что контекст x находится в состоянии больше или равном y.

#define SUPSYS_PRE_STATE_GE(x, y)

Аргументы

x
контекст модуля
y
сравниваемое состояние

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_PRE_STATE_GT

Проверка, что контекст x находится в состоянии больше y.

#define SUPSYS_PRE_STATE_GT(x, y)

Аргументы

x
контекст модуля
y
сравниваемое состояние

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


Вспомогательные структуры передачи информации

Структуры | Описание
TSupSysInfoDummy_ | Структура без полей.
TSupSysInfoUntyped_ | Структура передачи нетипизированной информации.
TSupSysInfoText_ | Структура, описывающая текстовую информацию.
TSupSysInfoBitString_ | Структура, описывающая битовую строку.


TSupSysInfoDummy_

Структура без полей.

typedef struct TSupSysInfoDummy_ {
  size_t size_of;
} TReaderInfoCancelConsequences, TReaderInfoCancelNotify, TReaderInfoLock, TReaderInfoUnlock, TReaderInfoDisconnectCarrier, TReaderInfoRestoreContext, TReaderInfoLogout, TReaderInfoPrimeLogin, TSupSysInfoDummy, TSupSysInfoContextFree, TSupSysInfoDisconnect;

Члены

size_of
Размер структуры TSupSysInfoDummy_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysInfoUntyped_

Структура передачи нетипизированной информации.

typedef struct TSupSysInfoUntyped_ {
  size_t length;
  unsigned char * info;
} TSupSysInfoUntyped;

Члены

length
Размер не типизированных данных в байтах.
info
Указатель на не типизированные данные.

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysInfoText_

Структура, описывающая текстовую информацию.

typedef struct TSupSysInfoText_ {
  size_t length;
  TCHAR * text;
} TSupSysInfoText;

Члены

length
Количество символов в строке text, не включая символ завершения строки.
text
Указатель на строку типа TCHAR.

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysInfoBitString_

Структура, описывающая битовую строку.

typedef struct TSupSysInfoBitString_ {
  size_t bits;
  unsigned char * string;
} TSupSysInfoBitString;

Члены

bits
Размер битовой строки в битах.
string
Указатель на битовую строку. Биты нумеруются с лева на право (Big-endian).

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


Интерфейс между списком и элементом

Для осуществления базового взаимодействия с CSP. Необходимо реализовать этот интерфейс. Все функции в рамках этого интерфейса разбиты на две группы. К первой относятся те функции, которые должны работать вне контекста библиотеки устройства. Это функции с номерами, начиная от SUPSYS_FUN_VERSION и до SUPSYS_FUN_VERSIONSUPPORT. Остальные функции с номерами от SUPSYS_FUN_UNREGISTER работают в контексте библиотеки устройства, и CSP при обращении к ним будет передавать этот контекст.

  • Информационные функции
  • Регистрация и работа с соединениями
Макросы | Описание
SUPSYS_FUN_START | Старт перечисления поддержки.


Информационные функции

Функции должны корректно выполнятся без использования контекста.

Для того чтобы CSP смог получить информацию об имени устройства, для которого создавалась библиотека, о версии библиотеки и пр. Нужно реализовать группу контекстно независимых функций, которые возвращают соответствующую информацию. Это функции SUPSYS_FUN_VERSION, SUPSYS_FUN_NICKNAME, SUPSYS_FUN_NAME, SUPSYS_FUN_COPYRIGHT, SUPSYS_FUN_ITEM_ICON, SUPSYS_FUN_DETAIL_NAME, SUPSYS_FUN_COMPANY, SUPSYS_FUN_PRODUCER, SUPSYS_FUN_PRODUCER_VERSION. Эти функции можно не реализовывать, но тогда всю информацию, которую они должны были бы вернуть, можно разместить в ресурсе библиотеки. См. supsys_interface_ids

  • Номера информационных функции
  • Пользовательские ошибки
  • Смещения внутри ресурса
  • Структуры передачи данных

Примечания

Эти функции (за исключением SUPSYS_FUN_NICKNAME) можно вообще не реализовывать, в этом случае пользователь получить не полную информацию о модуле в контрольной панели, что не рекомендуется.

Функции SUPSYS_FUN_PRODUCER, SUPSYS_FUN_PRODUCER_VERSION относятся к другому интерфейсу supsys_reg_fun, т.к. они могут использовать контекст при вычислении.

Для платформ отличных от UNIX используется заменитель ресурса.


Номера информационных функции

Макросы | Описание
SUPSYS_FUN_VERSION | Номер версии.
SUPSYS_FUN_NICKNAME | Получение прозвища.
SUPSYS_FUN_NAME | Получение полного имени БАП.
SUPSYS_FUN_COPYRIGHT | Функция получения copyright.
SUPSYS_FUN_ERROR | Функция получения текста ошибки.
SUPSYS_FUN_INSTANCE | Функция получения instance.
SUPSYS_FUN_CONTEXT_DUP | Функция дублирования контекста.
SUPSYS_FUN_CONTEXT_FREE | Функция удаление контекста.
SUPSYS_FUN_IDS_BLOCK | Функция получения начального смещения строк и иконок в ресурсе.
SUPSYS_FUN_ITEM_ICON | Функция получения иконки элемента перечисления.
SUPSYS_FUN_DETAIL_NAME | Функция получения подробного имени элемента перечисления.
SUPSYS_FUN_COMPANY | Получение имени производителя DLL.
SUPSYS_FUN_FLAGS | Получение флагов элемента перечисления.
SUPSYS_FUN_CALL | Вызов функции.
SUPSYS_FUN_GROUP_ENUM_OPEN |
SUPSYS_FUN_GROUP_ENUM_NEXT |
SUPSYS_FUN_GROUP_ENUM_CLOSE |
SUPSYS_FUN_GROUP_NICKNAME |
SUPSYS_FUN_VERSIONSUPPORT | Номер версии CSP с которым данный модуль совместим.


SUPSYS_FUN_VERSION

Номер версии.

Функция должна вернуть номер текущей версии DLL. Если эта функция не поддерживается, то текущая версия DLL будет получена по ресурсу версии этой DLL.

#define SUPSYS_FUN_VERSION 0

См. также

TSupSysInfoVersion_, Смещения внутри ресурса

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_NICKNAME

Получение прозвища.

Функция выдает прозвище БАП. Если функция не поддерживается, то возвращается, соответсвующая строка из ресурса этой DLL.

#define SUPSYS_FUN_NICKNAME 0x1

См. также

TSupSysInfoNickname_, Смещения внутри ресурса

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_NAME

Получение полного имени БАП.

Функция выдает полное имя БАП. Если эта функция не поддерживается, то возвращается, соответствующая строка из ресурса этой DLL. Если строка в ресурсе не найдена, то будет выдан результат работы функции SUPSYS_FUN_NICKNAME.

#define SUPSYS_FUN_NAME 0x2

См. также

TSupSysInfoItemName_, Смещения внутри ресурса

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_COPYRIGHT

Функция получения copyright.

Функция возвращает информацию о copyright. Если эта функция не поддерживается, то возвращается, соответствующая строка из ресурса этой DLL.

#define SUPSYS_FUN_COPYRIGHT 0x3

См. также

TSupSysInfoCopyright_, Смещения внутри ресурса

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_ERROR

Функция получения текста ошибки.

Функция может разбирать текущее состояние элемента списка и пользоваться контекстом. Функция должна возвращать:

  • SUP_ERR_NO, если успешно получен код ошибки.
  • SUP_ERR_UNSUPPORTED, если ошибка неизвестна. Библиотека поддержки конктретного элемента перечисления не должна возвращать тескт ошибки. Библиотека поддержки списка возвращает текст ошибки SUP_ERR_UNSUPPORTED.
  • SUP_ERR_MEMORY, если недостаточно памяти или ошибка SUP_ERR_MEMORY. Текст ошибки не устанавливается.
  • SUP_ERR_VERIFY, если возникла ошибка при получении строки. Текст ошибки не устанавливается. Библиотека поддержки списка возвращает текст ошибки SUP_ERR_VERIFY.

#define SUPSYS_FUN_ERROR 0x4

См. также

TSupSysInfoError_, Смещения внутри ресурса

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_INSTANCE

Функция получения instance.

#define SUPSYS_FUN_INSTANCE 0x5

См. также

TSupSysInfoInstance_, Смещения внутри ресурса

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_CONTEXT_DUP

Функция дублирования контекста.

Функция должна дублировать только те поля, которые были заданы при создании контекста. Функция может быть вызвана в любом состоянии и должна корректно дублировать контекст независимо от его текущего состояния.

#define SUPSYS_FUN_CONTEXT_DUP 0x6

См. также

TSupSysInfoContextDup_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_CONTEXT_FREE

Функция удаление контекста.

Функция может быть вызвана в любом состоянии и должна корректно удалять контекст в независимости от текущего состояния.

#define SUPSYS_FUN_CONTEXT_FREE 0x7

См. также

TSupSysInfoContextFree

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_IDS_BLOCK

Функция получения начального смещения строк и иконок в ресурсе.

Если функция реализована, то она должна возвращать смещение строк и иконок внутри собственного ресурса и размер блока этих строк и иконок. Если же функция не реализована, то считается, что для них заданы значения по умолчанию определяемые конкретным списком.

Функция должна реализовываться при наличии двух элементов списка, внутри одного DLL, а так же при необходимости использовать константы заданные смещением по умолчанию.

#define SUPSYS_FUN_IDS_BLOCK 0x8

См. также

TSupSysInfoIDSBaseItem_, TSupSysInfoIDSBase_, SUPSYS_IDS_BASE, SUPSYS_IDS_BLOCK_ICON Смещения внутри ресурса

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_ITEM_ICON

Функция получения иконки элемента перечисления.

Если функция не поддерживается, то будет попытка найти, соответствующую иконку в ресурсе, если в ресурсе нет этой иконки, то будет использована стандартная иконка.

#define SUPSYS_FUN_ITEM_ICON 0x9

См. также

TSupSysInfoIconItem_, Смещения внутри ресурса

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_DETAIL_NAME

Функция получения подробного имени элемента перечисления.

Если эта функция не поддерживается, то будет попытка получить имя элемента перечисления из ресурса этой DLL. Если в ресурсе имя не найдено, то будет выдан результат работы функции SUPSYS_FUN_NAME.

#define SUPSYS_FUN_DETAIL_NAME 0xA

См. также

TSupSysInfoDetailName_, Смещения внутри ресурса

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_COMPANY

Получение имени производителя DLL.

Если эта функция не поддерживается, то будет попытка получить имя производителя DLL из ресурса этой DLL.

#define SUPSYS_FUN_COMPANY 0xB

См. также

TSupSysInfoCompany_, Смещения внутри ресурса

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_FLAGS

Получение флагов элемента перечисления.

Значение флагов определяется списком перечисления.

#define SUPSYS_FUN_FLAGS 0xC

См. также

TSupSysInfoFlags_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_CALL

Вызов функции.

Функция может использоваться для выполнения каких-то действий до и после вызова любой функций. Например, блокировать вывод окон при работе с дискетой. В этом случае функция выглядит примерно следующим образом.

 TSupErr fat12_aux_call(
    TSupSysContext *context,
    TSupSysInfo *info )
 {
     TSupSysInfoCall *inf = (TSupSysInfoCall*)info;
     TSupSysInfo *inf_call;
     TSupErr code;

     SUPSYS_PRE_INFO( info, TSupSysInfoCall );
     inf->size_of = sizeof( TSupSysInfoCall );
     if( inf->fun == NULL )
               return SUP_ERR_UNSUPPORTED;
     inf_call = (TSupSysInfo*)inf->info;
     // ....
     // Выполнить какие-то действия до вызова функции
     // ....
     code = inf->fun( context, inf_call );
     // ....
     // Выполнить какие-то действия после вызова функции
     // ....
     return code;
 }

Функция так же может использоваться для перенаправления части функций на другой модуль, как это делается при разделении на считыватели и носители

 TSupErr pcsc_call(
     TSupSysContext *context,
     TSupSysInfo *info )
 {
     TSupSysInfoCall *inf = (TSupSysInfoCall*)info;
     TPCSCContext *ctx = (TPCSCContext*)context;
     // Если функция не поддерживается перенаправить
     if( inf->fun == NULL )
     {
          // ....
                    // Получить контекст другого media
          // ....
               return supsys_call( media, inf->num, inf_call);
     }
     // Если поддерживается, выполнить самим
     code = inf->fun( context, inf->info );
     return code;
 }

#define SUPSYS_FUN_CALL 0xD

См. также

TSupSysInfoCall_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_GROUP_ENUM_OPEN

#define SUPSYS_FUN_GROUP_ENUM_OPEN 0xE

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_GROUP_ENUM_NEXT

#define SUPSYS_FUN_GROUP_ENUM_NEXT 0xF

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_GROUP_ENUM_CLOSE

#define SUPSYS_FUN_GROUP_ENUM_CLOSE 0x10

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_GROUP_NICKNAME

#define SUPSYS_FUN_GROUP_NICKNAME 0x11

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_VERSIONSUPPORT

Номер версии CSP с которым данный модуль совместим.

На данный момент функция должна быть реализована и возвращать константу 3.0.0.0. Функция обычно реализуется следующим образом:

 static const TSupSysInfoVersion _VERSION =
 *{
  sizeof(TSupSysInfoVersion),{3,0,0,0}
 };

 TSupErr info_versionsupport(TSupSysContext *context, TSupSysInfo *info )
 {
     UNUSED( context );
     if(info == NULL) return SUP_ERR_PARAM;
     if((*(TSupSysInfoVersion*)info).size_of < sizeof( TSupSysInfoVersion ) )
      return SUP_ERR_PARAM;

     *(TSupSysInfoVersion*)info = _VERSION;
     return SUP_ERR_NO;
 }
 Пример: Функция info_versionsupport возвращает в параметре info структуру
 #TSupSysInfoVersion_ содержащую версию.

#define SUPSYS_FUN_VERSIONSUPPORT 0x12

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


Пользовательские ошибки

Макросы | Описание
SUPSYS_ERR_USER_FIRST | Первый пользовательский код ошибки.
SUPSYS_ERR_USER_LAST | Последний пользовательский код ошибки.


SUPSYS_ERR_USER_FIRST

Первый пользовательский код ошибки.

Для получения текста ошибки в пределах пользовательских вызываются функции элемента получения текста ошибки или происходит обращение к ресурсу для получения этого текста.

#define SUPSYS_ERR_USER_FIRST 0x1100

См. также

SUPSYS_ERR_USER_LAST

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_ERR_USER_LAST

Последний пользовательский код ошибки.

Для получения текста ошибки в пределах пользовательских вызываются функции элемента получения текста ошибки или происходит обращение к ресурсу для получения этого текста.

#define SUPSYS_ERR_USER_LAST 0x1fff

См. также

SUPSYS_ERR_USER_FIRST

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


Смещения внутри ресурса

Часть функций можно не реализовывать непосредственно, а поместить информацию в реестре (см. Информационные функции )

Что бы CSP мог, что-либо взять информацию из ресурса, он должна получить его instance. Для этого необходимо, что бы библиотека реализовывала функцию SUPSYS_FUN_INSTANCE. Эта функция возвращает структуру TSupSysInfoInstance_ содержащую instance ресурса. Следующие ресурсы предоставляют CSP информацию о библиотеке устройства. Они спроектированы с учетом того, что одна библиотека может обеспечивать работу с несколькими устройствами. Если ваша библиотека работает только с одним устройством, то всю последующую информация о функции SUPSYS_FUN_IDS_BLOCK можно не изучать и эту функцию не реализовывать. Для одного устройства номер исконки 0x1000 (SUPSYS_IDS_ICON_BASE), номера строк начинаются с 0x1000 (SUPSYS_IDS_BASE) и к последующим номерам прибавляется 0 (SUPSYS_IDS_NAME) для получения первой строки (имени модуля), 1 (SUPSYS_IDS_NICKNAME) для получения второй строки (прозвища)...

Поскольку одна библиотека может обеспечивать поддержку для нескольких устройств, то для каждого устройства в ресурсах следует выделить отдельные блоки, описывающие это устройство. Все ресурсы имеют свой числовой идентификатор. Соответственно для каждого блока ресурсов устройства выделяется свой диапазон номеров. Рассмотрим следующий пример.

 #define IDI_FAT12                       0x1000
 #define IDS_FAT12_NAME                  0x1000
 #define IDS_FAT12_NICKNAME              0x1001
 #define IDS_FAT12_DETAIL_NAME           0x1002
 #define IDS_FAT12_INSERT_TEXT           0x1300
 #define IDS_FAT12_CARRIER_TYPE          0x1302
 #define IDI_HDIMAGE                     0x2000
 #define IDS_HDIMAGE_NAME                0x2000
 #define IDS_HDIMAGE_NICKNAME            0x2001
 #define IDS_HDIMAGE_DETAIL_NAME         0x2002
 #define IDS_HDIMAGE_INSERT_TEXT         0x2300
Пример. Фрагмент файла описывающего константы для ресурсов библиотеки

FAT12. Можно видеть, что номера строк ресурсов для устройства FAT12 начинаются с 0x1000, а для HDIMAGE с 0x2000.

Следующая информация: имя производителя устройства, полное имя библиотеки, псевдоним, подробное имя библиотеки - должна быть представлена в ресурсе String Table, под заранее определенными номерами строк. Номера определяются, как сумма двух констант, одна из них непосредственно указывает, что за строку мы хотим получить. Для имени производителя устройства это константа SUPSYS_IDS_PRODUCER, для полного имени библиотеки SUPSYS_IDS_NAME, для псевдонима SUPSYS_IDS_NICKNAME, подробного имени библиотеки SUPSYS_IDS_DETAIL_NAME. Вторая константа задает блок ресурсов для каждого устройства поддержку, которого обеспечивает библиотека. Соответственно для первого устройства это константа будет SUPSYS_IDS_BASE. Она определена как

 #define SUPSYS_IDS_BASE 0x1000.

Таким образом, в примере, показанном выше, можно видеть, что константа IDS_FAT12_NAME, есть сумма констант SUPSYS_IDS_BASE и SUPSYS_IDS_NAME. Константа SUPSYS_IDS_NAME определена, как ноль. Для других констант аналогично.

Так же в ресурсе задаются номера строк пользовательского кода ошибок. Константа, определяющая номер строки, для первой пользовательской ошибки для первого устройства

 #define SUPSYS_IDS_ERROR_BASE 0x1100.

Изображение иконки для устройства определяется в ресурсе Icon. Соответственно номер иконки в этом ресурсе формируется также с учетом того, что устройств может быть несколько. Так же с одним устройством может быть связано несколько иконок. То константа

 #define SUPSYS_IDS_ICON_ITEM 0
определяет, номер первой иконки связанной с устройством, а константа

 #define SUPSYS_IDS_ICON_BASE 0x1000
задает номер блока иконок для первого устройства. Таким образом, номер иконке в ресурсе формируется как сумма этих двух констант. В примере выше

 #define IDI_FAT12 0x1000
номер первой иконки первого устройства, а

 #define IDI_HDIMAGE 0x2000
второго. Если ваша библиотека поддерживает одно устройство. То CSP обратится непосредственно к ресурсам и получит необходимый номер ресурса, используя константу SUPSYS_IDS_BASE и одну из указанных выше констант. Но если в вашей библиотеке определено несколько устройств, то СSP потребуется выяснить смещение от начала String Table и Icon, для блоков строк второго устройства. Для того что бы CSP получила это смещение необходимо реализовать функцию с номером SUPSYS_FUN_IDS_BLOCK. Эта функция возвращает уникальное смещение для устройства в виде структуры TSupSysInfoIDSBase_. Для первого устройства эту функцию реализовывать не следует, для него СSP будет использовать смещение SUPSYS_IDS_BASE относительно начала ресурса. Эта функция своя для каждого устройства.

Рассмотрим пример.

 static const TSupSysInfoIDSBase HDIMAGE_IDS =
 {
     sizeof( TSupSysInfoIDSBase ),
     sizeof( HDIMAGE_IDS_ITEMS ) / sizeof( TSupSysInfoIDSBaseItem ),
     HDIMAGE_IDS_ITEMS
 };

 TSupErr hdimage_info_ids( TSupSysContext *context, TSupSysInfo *info )
 {
     UNUSED( context );
     SUPSYS_PRE_INFO( info, TSupSysInfoIDSBase );
     memcpy( info, &HDIMAGE_IDS, sizeof( TSupSysInfoIDSBase ) );
    return SUP_ERR_NO;
 }
Пример функции SUPSYS_FUN_IDS_BLOCK устройства hdimage.

Функция возвращает структуру TSupSysInfoIDSBase_.

Из примера видно, что ф-ия hdimage_info_ids() возвращает в параметре info указатель на структуру TSupSysInfoIDSBase_. Эта структура содержит массив структур TSupSysInfoIDSBaseItem_ описывающих смещение для каждого ресурса для устройства hdimage.

Рассмотрим пример.

 const TSupSysInfoIDSBaseItem HDIMAGE_IDS_ITEMS[] =
 {
   { SUPSYS_IDS_BLOCK_BASE, IDS_HDIMAGE_NAME, SUPSYS_IDS_BASE_QUANT_V1 },
   { SUPSYS_IDS_BLOCK_ICON, IDI_HDIMAGE, SUPSYS_IDS_ICON_QUANT_V1 },
   { READER_IDS_BLOCK, IDS_HDIMAGE_INSERT_TEXT, READER_IDS_QUANT_V1 }
 };
Пример. Массив структур задающих смещение блока ресурсов для устройства hdimage для таблицы строк и иконок.

В структуре TSupSysInfoIDSBaseItem_ первый элемент задает смещение блока относительно начала ресурса, второй определяет первый элемент в блоке, и третий число строк (иконок) в ресурсе.

Следующая информация: номер текущей версии DLL, информация о copyright, имени производителя DLL, либо возвращается соответствующими функциями. Либо должна быть размещена в ресурсе версии.

Макросы | Описание
SUPSYS_IDS_BLOCK_BASE | Блок основных строк.
SUPSYS_IDS_BLOCK_ERROR | Блок строк с кодами пользовательских ошибок.
SUPSYS_IDS_BLOCK_ICON | Блок иконок.
SUPSYS_IDS_BASE | База смещенения основных строк в ресурсе.
SUPSYS_IDS_NAME | Смещение номер строки полного имени элемента перечисления в ресурсе.
SUPSYS_IDS_NICKNAME | Смещение строки прозвища элемента перечисления в ресурсе.
SUPSYS_IDS_DETAIL_NAME | Смещение номер строки подробное имя элемента перечисления.
SUPSYS_IDS_PRODUCER | Смещение номер строки имя производителя аппаратуры.
SUPSYS_IDS_GROUP_NICKNAME | SUPSYS_IDS_GROUP_NICKNAME.
SUPSYS_IDS_BASE_QUANT_V1 | Максимальное количество базовых строк.
SUPSYS_IDS_ERROR_BASE | Номер строки первый пользовательский код ошибки.
SUPSYS_IDS_ERROR_QUANT_V1 | Количество пользовательских кодов ошибок реализуемых через ресурс.
SUPSYS_IDS_ICON_BASE | Номер первой иконки.
SUPSYS_IDS_ICON_ITEM | Смещение номер иконки элемента перечисления.
SUPSYS_IDS_ICON_QUANT_V1 | Количество иконок реализуемых через ресурс.


SUPSYS_IDS_BLOCK_BASE

Блок основных строк.

#define SUPSYS_IDS_BLOCK_BASE 0

См. также

SUPSYS_IDS_BLOCK_ERROR, SUPSYS_IDS_BLOCK_ICON, SUPSYS_IDS_BLOCK_ERROR_LIST

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_IDS_BLOCK_ERROR

Блок строк с кодами пользовательских ошибок.

#define SUPSYS_IDS_BLOCK_ERROR 1

См. также

SUPSYS_IDS_BLOCK_BASE, SUPSYS_IDS_BLOCK_ICON SUPSYS_IDS_BLOCK_ERROR_LIST

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_IDS_BLOCK_ICON

Блок иконок.

#define SUPSYS_IDS_BLOCK_ICON 2

См. также

SUPSYS_IDS_BLOCK_BASE, SUPSYS_IDS_BLOCK_ERROR, SUPSYS_IDS_BLOCK_ERROR_LIST

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_IDS_BASE

База смещенения основных строк в ресурсе.

Используется для определения реального номера строки в ресурсе, если элемент перечисления не реализует функцию с номером SUPSYS_FUN_IDS_BLOCK и список не указывает другое смещение.

#define SUPSYS_IDS_BASE 0x1000

См. также

SUPSYS_FUN_IDS_BLOCK, supsys_ids

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_IDS_NAME

Смещение номер строки полного имени элемента перечисления в ресурсе.

Смещение задается относительно SUPSYS_IDS_BASE или явно (см. SUPSYS_IDS_BASE)

#define SUPSYS_IDS_NAME 0

См. также

SUPSYS_IDS_BASE, supsys_ids

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_IDS_NICKNAME

Смещение строки прозвища элемента перечисления в ресурсе.

Смещение задается относительно SUPSYS_IDS_BASE или явно (см. SUPSYS_IDS_BASE)

#define SUPSYS_IDS_NICKNAME 1

См. также

SUPSYS_IDS_BASE, supsys_ids

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_IDS_DETAIL_NAME

Смещение номер строки подробное имя элемента перечисления.

Смещение задается относительно SUPSYS_IDS_BASE или явно (см. SUPSYS_IDS_BASE)

#define SUPSYS_IDS_DETAIL_NAME 2

См. также

SUPSYS_IDS_BASE, supsys_ids

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_IDS_PRODUCER

Смещение номер строки имя производителя аппаратуры.

Смещение задается относительно SUPSYS_IDS_BASE или явно (см. SUPSYS_IDS_BASE)

#define SUPSYS_IDS_PRODUCER 3

См. также

SUPSYS_IDS_BASE, supsys_ids

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_IDS_GROUP_NICKNAME

SUPSYS_IDS_GROUP_NICKNAME.

#define SUPSYS_IDS_GROUP_NICKNAME 4

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_IDS_BASE_QUANT_V1

Максимальное количество базовых строк.

Используется для определения максимального номера строки в ресурсе, если элемент перечисления не реализует функцию с номером SUPSYS_FUN_IDS_BLOCK и список не указывает другое смещение.

#define SUPSYS_IDS_BASE_QUANT_V1 ( SUPSYS_IDS_GROUP_NICKNAME + 1 )

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_IDS_ERROR_BASE

Номер строки первый пользовательский код ошибки.

Используется для определения реального номера строки с текстом ошибки в ресурсе, если конкретный элемент не реализует функцию с номером SUPSYS_FUN_IDS_BLOCK и список не переопределяет данное значение.

#define SUPSYS_IDS_ERROR_BASE 0x1100

См. также

SUPSYS_FUN_IDS_BLOCK, supsys_ids

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_IDS_ERROR_QUANT_V1

Количество пользовательских кодов ошибок реализуемых через ресурс.

Используется для определения максимального количества пользовательских кодов ошибок реализованных в ресурсе, если элемент перечисления не реализует функцию с номером SUPSYS_FUN_IDS_BLOCK

#define SUPSYS_IDS_ERROR_QUANT_V1 0xEFF

См. также

SUPSYS_FUN_IDS_BLOCK, supsys_ids

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_IDS_ICON_BASE

Номер первой иконки.

Используется для определения реального номера иконки в ресурсе, если элемент списка не реализует функцию с номером SUPSYS_FUN_IDS_BLOCK и список не переопределяет данное значение.

#define SUPSYS_IDS_ICON_BASE 0x1000

См. также

SUPSYS_FUN_IDS_BLOCK, supsys_ids

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_IDS_ICON_ITEM

Смещение номер иконки элемента перечисления.

Смещение задается относительно SUPSYS_IDS_BASE или явно (см. SUPSYS_IDS_ICON_BASE)

#define SUPSYS_IDS_ICON_ITEM 0

См. также

SUPSYS_IDS_ICON_BASE, supsys_ids

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_IDS_ICON_QUANT_V1

Количество иконок реализуемых через ресурс.

Используется для определения максимального количества иконок реализованных в ресурсе, если элемент перечисления не реализует функцию с номером SUPSYS_FUN_IDS_BLOCK и список не переопределяет данное значение.

#define SUPSYS_IDS_ICON_QUANT_V1 ( SUPSYS_IDS_ICON_ITEM + 1 )

См. также

SUPSYS_FUN_IDS_BLOCK, supsys_ids

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


Структуры передачи данных

информационным функциям

Структуры | Описание
TSupSysInfoNickname_ | Структура, описывающая прозвище БАП.
TSupSysInfoVersion_ | Структура, описывающая версию.
TSupSysInfoItemName_ | Структура, описывающая полное имя БАП.
TSupSysInfoCopyright_ | Структура, описывающая copyright.
TSupSysInfoError_ | Структура, описывающая код ошибки и соответствующий коду ошибки текст.
TSupSysInfoInstance_ | Структура, описывающая instance.
TSupSysInfoContextDup_ | Структура, описывающая дубликат контекста. Используется при передаче/получение дублированного контекста.
TSupSysInfoIDSBaseItem_ | Элемент структуры получения информации о начальном смещении строк (иконок) и количестве строк(иконок) в ресурсе.
TSupSysInfoIconItem_ | Структура, описывающая иконку элемента перечисления.
TSupSysInfoIDSBase_ | Структура, описывающая начальное смещение строк (иконок) в ресурсе.
TSupSysInfoDetailName_ | Структура, описывающая подробное имя элемента перечисления.
TSupSysInfoProducer_ | Структура описывает имя производителя аппаратуры.
TSupSysInfoProducerVersion_ | Структура описывает версию аппаратуры.
Определения типов | Описание
TSupSysIcon | Определение иконки через определение в базовом наборе support.


TSupSysIcon

Определение иконки через определение в базовом наборе support.

TSupIcon TSupSysIcon;

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysInfoNickname_

Структура, описывающая прозвище БАП.

typedef struct TSupSysInfoNickname_ {
  size_t size_of;
  TSupSysENickname nickname;
} TSupSysInfoNickname;

Члены

size_of
Размер структуры TSupSysInfoNickname_
nickname
Строка, содержащая прозвище БАП.

См. также

SUPSYS_FUN_NICKNAME ,TSupSysENickname

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysInfoVersion_

Структура, описывающая версию.

typedef struct TSupSysInfoVersion_ {
  size_t size_of;
  unsigned int version[4];
} TSupSysInfoVersion;

Члены

size_of
Размер структуры TSupSysInfoVersion_
version
Массив содержит номер версии. Первый элемент - старший номер версии. Четвертый элемент - младший номер версии.

См. также

SUPSYS_FUN_VERSION

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysInfoItemName_

Структура, описывающая полное имя БАП.

typedef struct TSupSysInfoItemName_ {
  size_t size_of;
  TSupSysInfoText name;
} TSupSysInfoItemName;

Члены

size_of
Размер структуры TSupSysInfoItemName_
name
Структура TSupSysInfoText_, содержащая полное имя БАП.

См. также

SUPSYS_FUN_NAME ,TSupSysInfoText_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysInfoCopyright_

Структура, описывающая copyright.

typedef struct TSupSysInfoCopyright_ {
  size_t size_of;
  TSupSysInfoText copyright;
} TSupSysInfoCopyright;

Члены

size_of
Размер структуры TSupSysInfoCopyright_
copyright
Структура TSupSysInfoText_, содержащая информацию о Copyright.

См. также

SUPSYS_FUN_COPYRIGHT ,TSupSysInfoText_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysInfoError_

Структура, описывающая код ошибки и соответствующий коду ошибки текст.

typedef struct TSupSysInfoError_ {
  size_t size_of;
  TSupErr code;
  TSupSysInfoText message;
} TSupSysInfoError;

Члены

size_of
Размер структуры TSupSysInfoError_
code
Поле TSupErr содержит код ошибки.
message
Структура TSupSysInfoText_ содержит текстовое описание ошибки.

См. также

SUPSYS_FUN_ERROR

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysInfoInstance_

Структура, описывающая instance.

typedef struct TSupSysInfoInstance_ {
  size_t size_of;
  TSupResourceInstance instance;
} TSupSysInfoInstance;

Члены

size_of
Размер структуры TSupSysInfoInstance_
instance
Структура TSupResourceInstance содержит instance ресурса.

См. также

SUPSYS_FUN_INSTANCE

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysInfoContextDup_

Структура, описывающая дубликат контекста. Используется при передаче/получение дублированного контекста.

typedef struct TSupSysInfoContextDup_ {
  size_t size_of;
  TSupSysContext * dest_context;
} TSupSysInfoContextDup;

Члены

size_of
Размер структуры TSupSysInfoContextDup_
dest_context
Структура TSupSysContext, содержит дубликат контекста.

См. также

SUPSYS_FUN_CONTEXT_DUP

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysInfoIDSBaseItem_

Элемент структуры получения информации о начальном смещении строк (иконок) и количестве строк(иконок) в ресурсе.

typedef struct TSupSysInfoIDSBaseItem_ {
  size_t block;
  int base;
  size_t quant;
} TSupSysInfoIDSBaseItem;

Члены

block
Номер Блока.
base
Начальное смещение строк (иконок) в ресурсе.
quant
Число строк (иконок) в ресурсе.

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysInfoIconItem_

Структура, описывающая иконку элемента перечисления.

typedef struct TSupSysInfoIconItem_ {
  size_t size_of;
  TSupSysIcon icon;
} TSupSysInfoIconItem;

Члены

size_of
Размер структуры TSupSysInfoIconItem_
icon
Иконка элемента перечисления.

См. также

SUPSYS_FUN_ITEM_ICON

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysInfoIDSBase_

Структура, описывающая начальное смещение строк (иконок) в ресурсе.

typedef struct TSupSysInfoIDSBase_ {
  size_t size_of;
  size_t blocks;
  const TSupSysInfoIDSBaseItem * items;
} TSupSysInfoIDSBase;

Члены

size_of
Размер структуры TSupSysInfoIDSBase_
blocks
Количество элементов items
items
Указатель на массив структур TSupSysInfoIDSBaseItem_, содержащих информацию о начальном смещении строк(иконок) и количестве строк(иконок) в ресурсе.

См. также

SUPSYS_FUN_IDS_BLOCK, TSupSysInfoIDSBaseItem_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysInfoDetailName_

Структура, описывающая подробное имя элемента перечисления.

typedef struct TSupSysInfoDetailName_ {
  size_t size_of;
  TSupSysInfoText name;
} TSupSysInfoDetailName;

Члены

size_of
Размер структуры TSupSysInfoDetailName_
name
Структура TSupSysInfoText_, содержит подробное имя элемента перечисления.

См. также

SUPSYS_FUN_DETAIL_NAME

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysInfoProducer_

Структура описывает имя производителя аппаратуры.

typedef struct TSupSysInfoProducer_ {
  size_t size_of;
  TSupSysInfoText producer;
} TSupSysInfoProducer;

Члены

size_of
Размер структуры TSupSysInfoProducer_
producer
Структура TSupSysInfoText_, содержащая имя производителя аппаратуры.

См. также

SUPSYS_FUN_PRODUCER

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysInfoProducerVersion_

Структура описывает версию аппаратуры.

typedef struct TSupSysInfoProducerVersion_ {
  size_t size_of;
  TSupSysInfoText version;
} TSupSysInfoProducerVersion;

Члены

size_of
Размер структуры TSupSysInfoProducerVersion_
version
Структура TSupSysInfoText_, содержащая версию аппаратуры.

См. также

SUPSYS_FUN_PRODUCER_VERSION

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


Регистрация и работа с соединениями

  • Номера регистрационных функций и функций работы с соединениями
  • Флаги соединений
  • Предопределенные соединения
  • Структуры передачи данных функциям


Номера регистрационных функций и функций работы с соединениями

Макросы | Описание
SUPSYS_FUN_REGISTER | Регистрация элемента перечисления.
SUPSYS_FUN_UNREGISTER | Разрегистрация элемента перечисления. Функция должна освободить все занятые ресурсы.
SUPSYS_FUN_PRODUCER | Имя производителя физического элемента перечисления.
SUPSYS_FUN_PRODUCER_VERSION | Версия от производителя аппаратуры.
SUPSYS_FUN_CONNECT_OPEN | Открытие контекста перечисления соединений.
SUPSYS_FUN_CONNECT_NEXT | Получение следующего соединения.
SUPSYS_FUN_CONNECT_CLOSE | Закрытие контекста перечисления соединений.
SUPSYS_FUN_CONNECT_VALID | Проверка наличия элемента на заданном соединении.
SUPSYS_FUN_CONNECT | Соединение с подключенным элементом.
SUPSYS_FUN_DISCONNECT | Отключение от подключенного элемента.
SUPSYS_FUN_CONNECT_REMOVE |


SUPSYS_FUN_REGISTER

Регистрация элемента перечисления.

Функция регистрации должна вызываться один раз за сессию. И может создать контекст, который затем будет передаваться в другие функции.

#define SUPSYS_FUN_REGISTER 0x1000

См. также

TSupSysInfoRegister_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_UNREGISTER

Разрегистрация элемента перечисления. Функция должна освободить все занятые ресурсы.

#define SUPSYS_FUN_UNREGISTER 0x1001

См. также

TSupSysInfoUnregister_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_PRODUCER

Имя производителя физического элемента перечисления.

Обычно возвращается имя производителя драйвера или непосредственно аппаратного обеспечения, в отличии от имени SUPSYS_FUN_COMPANY в которой возвращается имя создателя DLL.

Если функция не поддерживается, то возвращается, соответствующая строка из ресурса. Если в ресурсе строки нет, то будет возвращено SUP_ERR_UNSUPPORTED

#define SUPSYS_FUN_PRODUCER 0x1002

См. также

TSupSysInfoProducer_, Смещения внутри ресурса

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_PRODUCER_VERSION

Версия от производителя аппаратуры.

Обычно возвращается версия драйвера или непосредственно аппаратного обеспечения, в отличии от имени SUPSYS_FUN_VERSION в которой возвращается версия DLL.

Если функция не поддерживается, то возвращается, SUP_ERR_UNSUPPORTED.

#define SUPSYS_FUN_PRODUCER_VERSION 0x1003

См. также

TSupSysInfoProducerVersion_, Смещения внутри ресурса

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_CONNECT_OPEN

Открытие контекста перечисления соединений.

#define SUPSYS_FUN_CONNECT_OPEN 0x1004

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_CONNECT_NEXT

Получение следующего соединения.

В случае ошибки, функция должна вернуть SUP_ERR_CONNECT.

#define SUPSYS_FUN_CONNECT_NEXT 0x1005

См. также

TSupSysInfoConnectNext_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_CONNECT_CLOSE

Закрытие контекста перечисления соединений.

#define SUPSYS_FUN_CONNECT_CLOSE 0x1006

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_CONNECT_VALID

Проверка наличия элемента на заданном соединении.

#define SUPSYS_FUN_CONNECT_VALID 0x1007

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_CONNECT

Соединение с подключенным элементом.

#define SUPSYS_FUN_CONNECT 0x1008

См. также

TSupSysInfoConnect_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_DISCONNECT

Отключение от подключенного элемента.

#define SUPSYS_FUN_DISCONNECT 0x1009

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_CONNECT_REMOVE

#define SUPSYS_FUN_CONNECT_REMOVE 0x100A

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


Флаги соединений

Макросы | Описание
SUPSYS_FLAG_BLOCK_CONNECT | Номер блока флагов информации о поддерживаемых соединениях.
SUPSYS_FLAG_CONNECT_MANY | Поддерживается несколько соединений.
SUPSYS_FLAG_CONNECT_COM | Поддерживаются соединения через COM.
SUPSYS_FLAG_CONNECT_LPT | Поддерживаются соединения через LPT.
SUPSYS_FLAG_CONNECT_AUTO | Поддерживается автоопределение соединения.
SUPSYS_FLAG_CONNECT_VERSION_1 | Количество флагов в версии 1 блока поддерживаемых соединений.
SUPSYS_FLAG_CONNECT_MULTY |
SUPSYS_FLAG_CONNECT_VERSION_2 | Количество флагов в версии 2 блока поддерживаемых соединений.
SUPSYS_FLAG_CONNECT_PNPGROUP |
SUPSYS_FLAG_CONNECT_VERSION_3 | Количество флагов в версии 2 блока поддерживаемых соединений.


SUPSYS_FLAG_BLOCK_CONNECT

Номер блока флагов информации о поддерживаемых соединениях.

#define SUPSYS_FLAG_BLOCK_CONNECT 1

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FLAG_CONNECT_MANY

Поддерживается несколько соединений.

#define SUPSYS_FLAG_CONNECT_MANY 0

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FLAG_CONNECT_COM

Поддерживаются соединения через COM.

#define SUPSYS_FLAG_CONNECT_COM 1

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FLAG_CONNECT_LPT

Поддерживаются соединения через LPT.

#define SUPSYS_FLAG_CONNECT_LPT 2

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FLAG_CONNECT_AUTO

Поддерживается автоопределение соединения.

#define SUPSYS_FLAG_CONNECT_AUTO 3

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FLAG_CONNECT_VERSION_1

Количество флагов в версии 1 блока поддерживаемых соединений.

#define SUPSYS_FLAG_CONNECT_VERSION_1 4

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FLAG_CONNECT_MULTY

#define SUPSYS_FLAG_CONNECT_MULTY 4

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FLAG_CONNECT_VERSION_2

Количество флагов в версии 2 блока поддерживаемых соединений.

#define SUPSYS_FLAG_CONNECT_VERSION_2 5

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FLAG_CONNECT_PNPGROUP

#define SUPSYS_FLAG_CONNECT_PNPGROUP 5

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FLAG_CONNECT_VERSION_3

Количество флагов в версии 2 блока поддерживаемых соединений.

#define SUPSYS_FLAG_CONNECT_VERSION_3 6

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


Предопределенные соединения

При выставлении данных флагов соответствующие соединения перечислять не требуется, они будут автоматически выставлны. Кроме того можно использовать номера соединений, а не текстовые строки их представляющие.

Макросы | Описание
SUPSYS_CONNECT_START | Номер соединения с которого начинается перечисление соединений.
SUPSYS_CONNECT_AUTO | Автоматическое определение соединения.
SUPSYS_CONNECT_COM1 | Соединение через порт COM1.
SUPSYS_CONNECT_COM2 | Соединение через порт COM2.
SUPSYS_CONNECT_COM3 | Соединение через порт COM3.
SUPSYS_CONNECT_COM4 | Соединение через порт COM4.
SUPSYS_CONNECT_COM_MAX | Максимальный номер поддерживаемого COM порта.
SUPSYS_CONNECT_LPT1 | Соединение через порт LPT1.
SUPSYS_CONNECT_LPT2 | Соединение через порт LPT2.
SUPSYS_CONNECT_LPT_MAX | Максимальный номер поддерживаемого LPT порта.
SUPSYS_CONNECT_USER | Первое пользовательское соединение.
SUPSYS_CONNECT_MAX | Последнее соединение.


SUPSYS_CONNECT_START

Номер соединения с которого начинается перечисление соединений.

#define SUPSYS_CONNECT_START 0

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_CONNECT_AUTO

Автоматическое определение соединения.

#define SUPSYS_CONNECT_AUTO 1

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_CONNECT_COM1

Соединение через порт COM1.

#define SUPSYS_CONNECT_COM1 0x10

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_CONNECT_COM2

Соединение через порт COM2.

#define SUPSYS_CONNECT_COM2 0x11

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_CONNECT_COM3

Соединение через порт COM3.

#define SUPSYS_CONNECT_COM3 0x12

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_CONNECT_COM4

Соединение через порт COM4.

#define SUPSYS_CONNECT_COM4 0x13

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_CONNECT_COM_MAX

Максимальный номер поддерживаемого COM порта.

#define SUPSYS_CONNECT_COM_MAX SUPSYS_CONNECT_COM4

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_CONNECT_LPT1

Соединение через порт LPT1.

#define SUPSYS_CONNECT_LPT1 0x20

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_CONNECT_LPT2

Соединение через порт LPT2.

#define SUPSYS_CONNECT_LPT2 0x21

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_CONNECT_LPT_MAX

Максимальный номер поддерживаемого LPT порта.

#define SUPSYS_CONNECT_LPT_MAX SUPSYS_CONNECT_LPT2

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_CONNECT_USER

Первое пользовательское соединение.

#define SUPSYS_CONNECT_USER 0x100

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_CONNECT_MAX

Последнее соединение.

Используется для запрета дальнейшего перечисления.

#define SUPSYS_CONNECT_MAX UINT_MAX

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


Структуры передачи данных функциям

регистрации и работы с соединениями.

Структуры | Описание
TSupSysInfoConnectNext_ | Структура получения следующего соединения.
TSupSysInfoConnect_ | Структура передачи параметров в функцию соединения с элементом.
TSupSysInfoCompany_ | Структура, описывающая имя производителя элемента перечисления.
TSupSysInfoFlags_ | Структура, описывающая флаги элемента перечисления.
TSupSysInfoCall_ | Структура передачи информации в функцию вызова функции.
TSupSysInfoGroupEnumOpen_ |
TSupSysInfoRegister_ | Структура, описывающая информацию необходимую для регистрации элемента перечисления.
TSupSysInfoUnregister_ | Структура, описывающая информацию необходимую для раз регистрации.


TSupSysInfoConnectNext_

Структура получения следующего соединения.

typedef struct TSupSysInfoConnectNext_ {
  size_t size_of;
  const TSupSysEContext * context;
  TSupSysInfoText name;
  TSupSysConnectNum num;
  TSupSysInfoUntyped add_info;
} TSupSysInfoConnectNext, TSupSysInfoConnectOpen, TSupSysInfoConnectClose;

Члены

size_of
Размер структуры TSupSysInfoConnectNext_
context
Структура TSupSysEContext_, содержит контекст считывателя.
name
Структура TSupSysInfoText_, содержащая имя соединения.
num
Структура TSupSysConnectNum, содержащая номер соединения.
add_info
Структура TSupSysInfoUntyped_, содержит не типизированный контекст перечисления соединения.

См. также

SUPSYS_FUN_CONNECT_NEXT

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysInfoConnect_

Структура передачи параметров в функцию соединения с элементом.

typedef struct TSupSysInfoConnect_ {
  size_t size_of;
  TSupSysInfoText name;
  TSupSysConnectNum num;
} TSupSysInfoConnect, TSupSysInfoConnectValid, TSupSysInfoConnectRemove;

Члены

size_of
Размер структуры TSupSysInfoConnect_
name
Структура TSupSysInfoText_, содержащая имя соединения.
num
Структура TSupSysConnectNum_, содержащая номер соединения.

См. также

SUPSYS_FUN_CONNECT

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysInfoCompany_

Структура, описывающая имя производителя элемента перечисления.

typedef struct TSupSysInfoCompany_ {
  size_t size_of;
  TSupSysInfoText company;
} TSupSysInfoCompany;

Члены

size_of
Размер структуры TSupSysInfoCompany_
company
Структура TSupSysInfoText_ содержит имя производителя элемента перечисления.

См. также

SUPSYS_FUN_COMPANY

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysInfoFlags_

Структура, описывающая флаги элемента перечисления.

typedef struct TSupSysInfoFlags_ {
  size_t size_of;
  size_t type;
  TSupSysInfoBitString string;
} TSupSysInfoFlags;

Члены

size_of
Размер структуры TSupSysInfoFlags_
type
Тип флагов элемента перечисления. SUPSYS_FLAG_BLOCK_CONNECT
string
Структура TSupSysInfoBitString_ содержит битовую строку флагов элемента перечисления.

См. также

SUPSYS_FUN_FLAGS

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysInfoCall_

Структура передачи информации в функцию вызова функции.

typedef struct TSupSysInfoCall_ {
  size_t size_of;
  TSupSysInfoFun num;
  TSupSysFunction fun;
  TSupSysInfo * info;
} TSupSysInfoCall;

Члены

size_of
Размер структуры TSupSysInfoCall_
num
Номер функции.
fun
Структура TSupSysFunction_, содержащая адрес функции.
info
Указатель на структуру TSupSysInfo, содержащую передаваемые в функцию параметры.

См. также

SUPSYS_FUN_CALL

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysInfoGroupEnumOpen_

typedef struct TSupSysInfoGroupEnumOpen_ {
  size_t size_of;
  const TSupSysEContext * context;
  TSupSysInfoText name;
  TSupSysInfoUntyped add_info;
  unsigned short change_mark;
  TSupSysComputeCheckMark compute_mark_func;
} TSupSysInfoGroupEnumOpen, TSupSysInfoGroupEnumNext, TSupSysInfoGroupEnumClose;

Члены

size_of
context
name
add_info
change_mark
compute_mark_func

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysInfoRegister_

Структура, описывающая информацию необходимую для регистрации элемента перечисления.

typedef struct TSupSysInfoRegister_ {
  size_t size_of;
  TSupSysContext * context;
  TSupSysInfoText in_group_name;
  TSupSysInfoText path_to_item;
} TSupSysInfoRegister;

Члены

size_of
Размер структуры TSupSysInfoRegister_
context
Контекст, возвращаемый функцией регистрации.
in_group_name
path_to_item

См. также

SUPSYS_FUN_REGISTER

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysInfoUnregister_

Структура, описывающая информацию необходимую для раз регистрации.

typedef struct TSupSysInfoUnregister_ {
  size_t size_of;
  int unload;
} TSupSysInfoUnregister;

Члены

size_of
Размер структуры TSupSysInfoUnregister_
unload
Этот параметр определяет требуется ли выгружать дополнительные dll.

См. также

SUPSYS_FUN_UNREGISTER

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


SUPSYS_FUN_START

Старт перечисления поддержки.

Номер функции, которая не должна быть реализована в библиотеке в глобальной нумерации функций. Функция используется как стартовый номер при перечислении всех поддерживаемых функций.

#define SUPSYS_FUN_START ((TSupSysInfoFun)UINT_MAX)

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


Базовые определения

  • Точка входа в DLL. Массив функций
Определения типов | Описание
TSupSysConnectNum | Тип перечисления соединений.
TSupSysInfoFun | Тип глобальной нумерации информационных функций.
TSupSysInfo | Информация передаваемая через info функцию.
TSupSysDummy | Мнимое поле используемое для объявления структур без информации.
TSupSysContext | Структура контекста элемента перечисления.


Точка входа в DLL. Массив функций

Структуры | Описание
TSupSysFunctionTableItem_ | Элемент таблицы входов в модуль.
TSupSysFunctionTable_ | Таблица входов в модуль.
Определения типов | Описание
TSupSysFunction | Функция обмена с элементом перечисления.
TSupSysExportFunction | Точка входа в модуль.


TSupSysFunction

Функция обмена с элементом перечисления.

Указатель на функцию обмена с элементом перечисления. Должна заполнять только поля принятые для передаваемой функции и только в том размере, который передан. Так же должна возвращать длину информации, которая учитывалась ей при принятии решения.

typedef TSupErr(* TSupSysFunction)(TSupSysContext *context, TSupSysInfo *info);

Аргументы

context
контекст элемента
info
in - запрашиваемая информация, out - возвращаемая информация

Возвращаемые значения

Код ошибки

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysExportFunction

Точка входа в модуль.

Основная функция, которая используется для доступа к элементу списка.

typedef const TSupSysFunctionTable *(* TSupSysExportFunction)(void);

Возвращаемые значения

Точку входа в элемент

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysFunctionTableItem_

Элемент таблицы входов в модуль.

typedef struct TSupSysFunctionTableItem_ {
  TSupSysInfoFun num;
  TSupSysFunction function;
} TSupSysFunctionTableItem;

Члены

num
номер функции
function
Вызываемая функция.

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysFunctionTable_

Таблица входов в модуль.

typedef struct TSupSysFunctionTable_ {
  size_t size_of;
  size_t quant;
  const TSupSysFunctionTableItem * table;
} TSupSysFunctionTable;

Члены

size_of
quant
table

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysConnectNum

Тип перечисления соединений.

typedef unsigned TSupSysConnectNum;

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysInfoFun

Тип глобальной нумерации информационных функций.

typedef int TSupSysInfoFun;

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysInfo

Информация передаваемая через info функцию.

typedef void TSupSysInfo;

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysDummy

Мнимое поле используемое для объявления структур без информации.

typedef int TSupSysDummy;

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


TSupSysContext

Структура контекста элемента перечисления.

typedef void TSupSysContext;

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\sup_sys.h


Интерфейс к считывателям

  • Информационные функции
  • Регистрация и работа с соединениями
  • Функции считывателя
  • Функции носителя
  • Функции работы в папке
  • Функций работы с файлами
  • Функции чтения / изменения файла
  • Смещения внутри ресурса


Информационные функции

Функции дополняющие информационные функции из Интерфейс между списком и элементом

  • Номера информационных функций
  • Структуры передачи данных


Номера информационных функций

Функции дополняющие информационные функции из Интерфейс между списком и элементом

Макросы | Описание
READER_FUN_PASSWD_TYPE | Тип пароля, поддерживаемого считывателем.
READER_FUN_PASSWD_LENGTH | Размеры пароля.
READER_FUN_PASSWD_TERM | Термин пароль.
READER_FUN_CARRIER_TYPE | Тип носителя или поддерживаемых носителей.


READER_FUN_PASSWD_TYPE

Тип пароля, поддерживаемого считывателем.

Это может быть: пароль, пин-код и т.д.

Если функция не поддерживается, то считается, что при доступе к контейнеру аппаратного пароля не требуется и будет использоваться только программный пароль.

#define READER_FUN_PASSWD_TYPE 0x302

См. также

TReaderInfoPasswdType_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_FUN_PASSWD_LENGTH

Размеры пароля.

Размер пароля определяется его максимальной и минимальной длиной. При вводе пароля в оконном режиме, размер вводимого пароля будет ограничен на эту величину и пользователь не сможет ввести количество символов большее, чем вернет данная функция. Минимальный размер пароля так же будет проконтролирован, до передачи в модуль поддержки.

Если функция не поддерживается, то для пароля и мастер пароля будет установлено значение по умолчанию: максимальное - READER_PASSWD_DEF_SIZE, минимальное - 0. Для носителей не поддерживающих аппаратный пароль оба значения будут установлены в 0.

#define READER_FUN_PASSWD_LENGTH 0x303

См. также

TReaderInfoPasswdInfo_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_FUN_PASSWD_TERM

Термин пароль.

Функция получает термин пароль (пароль, пин-код, ...).

Если функция не поддерживается, то будет возвращена стока из ресурса READER_IDS_PASSWD_TERM, если такой строки нет, то для пароля будет возвращена стандартная строка "пароль". Для носителей не требующих аппаратного пароля, данная функция не вызывается.

#define READER_FUN_PASSWD_TERM 0x304

См. также

TReaderInfoPasswdName_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_FUN_CARRIER_TYPE

Тип носителя или поддерживаемых носителей.

Данная функция должна быть реализована при разделении на считыватели и носители. В этом случае функция должна быть реализована как в считывателях, так и в носителях. Если функция не поддерживается, то будет возвращена строка из ресурса READER_IDS_CARRIER_TYPE. Если строка в ресурсе отсутствует,

  • то для считывателя будет считаться, что он сам поддерживает интерфейс носителя
  • для носителя, библиотека не будет использоваться.

    См. также

    TReaderInfoCarrierType_

    Требования:

    Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
    Solaris: 10 или выше.
    FreeBSD: 7 или выше.
    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
    Ядро ОС: Не поддерживает.
    Include: reader.kit\reader.h

#define READER_FUN_CARRIER_TYPE 0x305


Структуры передачи данных

Структуры | Описание
TReaderInfoPasswdType_ | Структура передачи типа аппаратного пароля.
TReaderInfoPasswdInfo_ | Структура передачи размеров аппаратного пароля.
TReaderInfoPasswdName_ | Структура передачи термина пароля.
TReaderInfoCarrierType_ | Структура передачи типа носителя или типа потдерживаемого носителя.


TReaderInfoPasswdType_

Структура передачи типа аппаратного пароля.

typedef struct TReaderInfoPasswdType_ {
  size_t size_of;
  TRdrLoginInfoType type;
} TReaderInfoPasswdType;

Члены

size_of
Размер структуры TReaderInfoPasswdType_
type
Тип поддерживаемого пароля

См. также

READER_FUN_PASSWD_TYPE, TRdrLoginInfoType

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


TReaderInfoPasswdInfo_

Структура передачи размеров аппаратного пароля.

typedef struct TReaderInfoPasswdInfo_ {
  size_t size_of;
  TRdrLoginInfoType type;
  size_t max_length;
  size_t min_length;
} TReaderInfoPasswdInfo;

Члены

size_of
Размер структуры TReaderInfoPasswdInfo_
type
[in] Тип поддерживаемого пароля. Передается тип пароля, для которого требуется получить ограничения. Носитель может поддерживать одновременно несколько паролей, например, пин-код и мастер пин-код.
max_length
Максимально возможный размер пароля
min_length
Минимально возможный размер пароля

См. также

READER_FUN_PASSWD_LENGTH, TRdrLoginInfoType

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


TReaderInfoPasswdName_

Структура передачи термина пароля.

typedef struct TReaderInfoPasswdName_ {
  size_t size_of;
  TSupSysInfoText term;
} TReaderInfoPasswdName;

Члены

size_of
Размер структуры TReaderInfoPasswdName_
term
Термин пароль

См. также

READER_FUN_PASSWD_TERM, TSupSysInfoText_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


TReaderInfoCarrierType_

Структура передачи типа носителя или типа потдерживаемого носителя.

typedef struct TReaderInfoCarrierType_ {
  size_t size_of;
  TSupSysENickname type;
  const TCHAR * path_to_item;
} TReaderInfoCarrierType;

Члены

size_of
Размер структуры TReaderInfoCarrierType_
type
  • Для считывателя: тип поддерживаемых носителей
  • Для носителя: тип данного носителя
path_to_item

См. также

READER_FUN_CARRIER_TYPE, TSupSysENickname

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


Регистрация и работа с соединениями

Функции дополняющие функции регистрации и работы с соединениеями из Интерфейс между списком и элементом

  • Номера функций работы с соединениями
  • Структуры передачи данных


Номера функций работы с соединениями

Макросы | Описание
READER_FUN_CANCEL_CONSEQUENCES | Последствия прерывания операции.
READER_FUN_CANCEL_NOTIFY | Уведомление о прерывании операции.


READER_FUN_CANCEL_CONSEQUENCES

Последствия прерывания операции.

Функция запрашивает у считывателя последствия прерывания операции. Подключаемый модуль не должен сам выводить окна. При прерывании операции Reader сам производит необходимые вызовы для возобновления соединения с носителем и повторы операций. Если окна повтора Reader выводит, то пользователь может отказаться от операции. Во избежание искажения файла или всего носителя Reader запрашивает последствия прерывания такой операции:

Она может вернуть:

  • RDR_ERR_NO операция будет прервана без изменения состояния на носителе.
  • RDR_ERR_INVALID_MEDIA прерывания операции может привести к искажению структуры носителя.
  • RDR_ERR_FILE_DISTORT операция может привести к искажению содержимого файла.

Reader сам отслеживает состояние прерывание записи в открытый файл и по умолчанию возвращает RDR_ERR_FILE_DISTORT при таких операциях. Во всех остальных случаях (например, при прерывании записи в fat) функция должна возвращать корректные коды возврата.

Если функция не поддерживается, то считается, что любая операция, кроме записи, не может привести к искажению файла или носителя.

#define READER_FUN_CANCEL_CONSEQUENCES 0x1300

См. также

TReaderInfoCancelConsequences

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_FUN_CANCEL_NOTIFY

Уведомление о прерывании операции.

Если, несмотря на предупреждение пользователя о возможных последствиях прерывания операции, пользователь все-таки прерывает эту опреацию, то Reader уведомляет модуль о прерывании этой операции. Модуль должен только выполнять освобождение ресурсов и не обращаться к носителу или считывателю. Модуль так же может запоминать флаг о необходимости перечитывания файловой структуры при следующей операции.

Если функция не поддерживается, то не требуется освобождать дополнительные ресурсы.

#define READER_FUN_CANCEL_NOTIFY 0x1301

См. также

TReaderInfoCancelNotify

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


Структуры передачи данных

Крипто-Про RDK Версия: 4.0

Обратная связь для этой статьи

(c) ООО Крипто-Про. Все права защищены.


Функции считывателя

Функции требующие соединения со считывателем

  • Номера функций считывателя
  • Константы функций считывателя
  • Структуры передачи данных


Номера функций считывателя

Макросы | Описание
READER_FUN_SAME_MEDIA | Идентичность вставленного носителя контексту.
READER_FUN_LOCK | Блокирование доступа к носителю.
READER_FUN_UNLOCK | Разблокирование доступа к носителю.
READER_FUN_CONNECT_CARRIER | Соединение с носителем.
READER_FUN_DISCONNECT_CARRIER | Разрыв соединения с носителем.
READER_FUN_RESTORE_CONTEXT | Восстановление соединения после обрыва связи с носителем.
READER_FUN_LOCAL_MACHINE | Установка флага работы в контексте пользователя или машины.


READER_FUN_SAME_MEDIA

Идентичность вставленного носителя контексту.

Функция вызывается при потере соединения со считывателем. Функцция должна проверить, что в считывателе находится носитель соответствующий текущему контексту и вернуть соответствующий код ошибки.

Если функция не поддерживается, то считается, что в считывателе всегда находится правильный носитель, как например для неотчуждаемого носителя.

#define READER_FUN_SAME_MEDIA 0x2300

Примечания

Если в считывателе находится другой носитель, то, кроме возврата кода ошибки, функция должна вернуть уникальный номер вставленного носителя для отображения номера вставленного носителя в окне.

См. также

TReaderInfoSameMedia_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_FUN_LOCK

Блокирование доступа к носителю.

Функция блокирования канала связи с носителем. Функция должна приводить к невозможности доступа других ниток и процессов для доступа к вставленному носителю. Если невозможно выполнить блокировку канала связи до соединения с носителем, блокировка может быть отложена на момент выполнения функции READER_FUN_CONNECT_CARRIER, но в этом случаем блокировку требуется реализовывать непосредственно в этой функции, а разблокировку в функции READER_FUN_DISCONNECT_CARRIER.

Считыватель должен поддерживать монопольный доступ к носителю, поддержка не монопольного доступа к носителю не обязательна, но рекомендуется. При возможности разделяемого доступа к носителю (только операции чтения), все функции должны работать как в монопольном так и в разделяемом режиме.

Если функция не поддерживается, то считается, что блокирование операции идет на момент соединения с носителем или считывателем, и всегда осуществляется только монопольный доступ к носителю.

#define READER_FUN_LOCK 0x2301

См. также

TReaderInfoLock_, READER_FUN_UNLOCK

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_FUN_UNLOCK

Разблокирование доступа к носителю.

Если функция не поддерживается, то считается, что блокирование операции идет на момент соединения с носителем или считывателем и всегда осуществляется только монопольный доступ к носителю.

#define READER_FUN_UNLOCK 0x2302

См. также

READER_FUN_LOCK

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_FUN_CONNECT_CARRIER

Соединение с носителем.

Функция должна выполнить соединение с носителем. После соединения с носителем, все функции должны обращаться только к этому носителю и при обнаружении удаления носителя из считывателя возвращать код ошибки RDR_ERR_NO_CARRIER, при вставке другого носителя - RDR_ERR_ANOTHER_MEDIA, при смене носителя - RDR_ERR_MEDIA_CHANGED. Функции (кроме восстановления соединения с носителем и READER_FUN_SAME_MEDIA) могут не возвращать код ошибки RDR_ERR_ANOTHER_MEDIA, если они не могут обнаружить, что вставлен другой носитель, кроме как способом аналогичным READER_FUN_SAME_MEDIA; в этом случаем возможно возвращать код ошибки RDR_ERR_MEDIA_CHANGED, что приведет к вызову функции READER_FUN_SAME_MEDIA. После успешного выполнения этой функции контекст переходит в состояние RDR_STATE_CARRIER

Если функция не поддерживается, то считается, что в считывателе всегда находится только один носитель, и соединение с носителем не требуется, как например для неотчуждаемого носителя.

#define READER_FUN_CONNECT_CARRIER 0x2303

См. также

TReaderInfoConnectCarrier_, READER_FUN_DISCONNECT_CARRIER

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_FUN_DISCONNECT_CARRIER

Разрыв соединения с носителем.

После выполнения этой функции контекст переходит в состояние SUPSYSE_STATE_CONNECTED

Если функция не поддерживается, то считается, что в считывателе всегда находится только один носитель, и отсоединение от носителя не требуется, как например для неотчуждаемого носителя.

#define READER_FUN_DISCONNECT_CARRIER 0x2304

См. также

TReaderInfoDisconnectCarrier_, READER_FUN_CONNECT_CARRIER

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_FUN_RESTORE_CONTEXT

Восстановление соединения после обрыва связи с носителем.

Функция вызывается при разрыве соединения с носителем, т.е. когда одна из функций вернула ошибку: RDR_ERR_NO_CARRIER, RDR_ERR_ANOTHER_MEDIA, RDR_ERR_INVALID_MEDIA, RDR_ERR_MEDIA_CHANGED, SUP_ERR_CONNECT, RDR_ERR_WRITE_PROTECT.

Функция должна восстановить состояние полностью аналогичное, состоянию в котором находился носитель до разрыва соединения.

Если функция не поддерживается, то считается, то для восстановления контекста не требуется никаких дополнительных действий.

#define READER_FUN_RESTORE_CONTEXT 0x2305

Примечания

Функция может вызываться в любом состояниии >= SUPSYSE_STATE_REGISTERED

См. также

TReaderInfoRestoreContext_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_FUN_LOCAL_MACHINE

Установка флага работы в контексте пользователя или машины.

Функция должна переводить носитель в состояние записи ключей для текущей машины или для текущего пользователя.

Если функция не поддерживается, то считается, что контейнеры пользователя и машины не разделяются, как например, для отчуждаемых носителей.

#define READER_FUN_LOCAL_MACHINE 0x2306

Примечания

Запрещается реализовывать данную функцию для отчуждаемых ключевых носителей.

См. также

TReaderInfoLocalMachine_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


Константы функций считывателя

Константы для работы со считывателем

Макросы | Описание
READER_CONNECT_CARRIER_FLAG_FORMAT | Флаг выставляемый reader для уведомления библиотеки о том, что после соединения с носителем необходимо произвести форматирование носителя.


READER_CONNECT_CARRIER_FLAG_FORMAT

Флаг выставляемый reader для уведомления библиотеки о том, что после соединения с носителем необходимо произвести форматирование носителя.

Установка данного флага производится reader только в случае, если библиотека поддержки считывателя при соединении вернула ошибку RDR_ERR_FORMAT и пользователь не отказался от форматирования данного носителя.

#define READER_CONNECT_CARRIER_FLAG_FORMAT 0x1


Структуры передачи данных

Структуры | Описание
TReaderInfoSameMedia_ | Стуктура проверки соответствия носителя контексту.
TReaderInfoConnectCarrier_ | Структура передачи информации для соединения с носителем.
TReaderInfoLocalMachine_ | Структура передачи флага LOCALMACHINE.


TReaderInfoSameMedia_

Стуктура проверки соответствия носителя контексту.

typedef struct TReaderInfoSameMedia_ {
  size_t size_of;
  TSupSysInfoText unique;
  TSupSysEList * media_list;
  unsigned flags;
  TSupSysFindInfo * rdr_info;
  TSupSysFindValidFun valid_fun;
} TReaderInfoSameMedia;

Члены

size_of
Содержит размер структуры TReaderInfoSameMedia_
unique
Уникальный номер вставленного носителя
media_list

Список всех поддерживаемых носителей

Может использоваться при написании считывателей, которые поддерживаемают несколько носителей. В остальных случаях не используется.

flags
Флаги проверки. При установленном флаге RDR_SAME_WRITE_AVAIL, функция должна проверить кроме совпадения носителей еще и возможность записи на этот носитель.
rdr_info

Информация которая должна быть передана в функцию поиска носителя соответствующую данному считывателю.

Может использоваться при написании считывателей, которые поддерживаемают несколько носителей. В остальных случаях не используется.

valid_fun

Функция проверки соответствия носителя данному считывателю.

Может использоваться при написании считывателей, которые поддерживаемают несколько носителей. В остальных случаях не используется.

См. также

READER_FUN_SAME_MEDIA, TSupSysEList, TSupSysFindInfo, TSupSysFindValidFun

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


TReaderInfoConnectCarrier_

Структура передачи информации для соединения с носителем.

typedef struct TReaderInfoConnectCarrier_ {
  size_t size_of;
  unsigned flags;
  TSupSysEList * media_list;
  TSupSysFindInfo * rdr_info;
  TSupSysFindValidFun valid_fun;
} TReaderInfoConnectCarrier;

Члены

size_of
Содержит размер структуры TReaderInfoConnectCarrier_
flags
Флаги соединения. При установленном флаге RDR_SAME_WRITE_AVAIL, функция должна по возможности проверить возможность записи на этот носитель.
media_list

Список всех поддерживаемых носителей

Может использоваться при написании считывателей, которые поддерживаемают несколько носителей. В остальных случаях не используется.

rdr_info

Информация которая должна быть передана в функцию поиска носителя соответствующую данному считывателю.

Может использоваться при написании считывателей, которые поддерживаемают несколько носителей. В остальных случаях не используется.

valid_fun

Функция проверки соответствия носителя данному считывателю.

Может использоваться при написании считывателей, которые поддерживаемают несколько носителей. В остальных случаях не используется.

См. также

READER_FUN_CONNECT_CARRIER, TReaderInfoDisconnectCarrier_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


TReaderInfoLocalMachine_

Структура передачи флага LOCALMACHINE.

typedef struct TReaderInfoLocalMachine_ {
  size_t size_of;
  int flag;
} TReaderInfoLocalMachine;

Члены

size_of
Содержит размер структуры TReaderInfoLocalMachine_
flag
Флаг 1 для установки флага local_machine, 0 для снятия.

См. также

READER_FUN_LOCAL_MACHINE

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


Функции носителя

Функции требующие соединения с носителем.

  • Номера функций носителя
  • Структуры передачи данных


Номера функций носителя

Макросы | Описание
READER_FUN_UNIQUE_GET | Получение уникального номера носителя.
READER_FUN_UNIQUE_SET | Установка уникального номера носителя.
READER_FUN_FOLDER_ENUM_OPEN | Открытие контекста поиска следующей папки.
READER_FUN_FOLDER_ENUM_NEXT | Получение следующей папки.
READER_FUN_FOLDER_ENUM_CLOSE | Закрытие контекста поиска следующей папок.
READER_FUN_FOLDER_OPEN | Открытие или создание папки.
READER_FUN_FOLDER_CLOSE | Функция закрывает доступ к текущей папке.
READER_FUN_PRIME | Открытие доступа к приложению.


READER_FUN_UNIQUE_GET

Получение уникального номера носителя.

Функция должна вернуть уникальный номер носителя. Функция вызывается если установлен флаг поддержки уникальных номеров данным считывателем: RDR_FLAG_RDR_UNIQUE. Уникальное имя носителя не должно содержать символы зависящие от кодовой страницы, символ "\\" и " ". Уникальность должна обеспечиваться внутри одного типа носителя.

Функция должна быть реализована при установленном флаге RDR_FLAG_RDR_UNIQUE

#define READER_FUN_UNIQUE_GET 0x3300

См. также

TReaderInfoUniqueGet_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_FUN_UNIQUE_SET

Установка уникального номера носителя.

Если носитель поддерживает уникальность номеров носителей, но существует предопределенные номера (например, при получении носителей с завода), то воизбежание перекрытия уникальных номеров, может использваться функция установки уникального номера. Функция может устанавливать не весь передаваемый уникальный номер, а так же может изменять переданный уникальный номер. Для получения установленного уникального номера будет вызвана READER_FUN_UNIQUE_GET.

Если функция не поддерживается и установлен флаг RDR_FLAG_RDR_UNIQUE, то считается, что уникальные номера неизменяемы.

#define READER_FUN_UNIQUE_SET 0x3301

См. также

TReaderInfoUniqueSet_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_FUN_FOLDER_ENUM_OPEN

Открытие контекста поиска следующей папки.

Есть три функции перечисления папок на носителе: READER_FUN_FOLDER_ENUM_OPEN, READER_FUN_FOLDER_ENUM_NEXT, READER_FUN_FOLDER_ENUM_CLOSE. Вначале вызывается функция: READER_FUN_FOLDER_ENUM_OPEN. Затем последовательно несколько раз функция READER_FUN_FOLDER_ENUM_NEXT до тех пор, пока функция не вернет ошибку. Ошибка RDR_ERR_FILE_NOT_FOUND считается успешным окончанием перечисления папок. Гарантируется, что по окончании перечисления папок, будет вызвана функция READER_FUN_FOLDER_ENUM_CLOSE. При вызове функции READER_FUN_FOLDER_ENUM_OPEN необходимо вычислить или установить в макимально возможное длину самого длинного имени папки, так же возможно создать контекст перечисления папок.

Есть два способа вызова данной функции:

  • перечисление имеющихся папок.
  • перечисление еще не соданных папок.

    • При перечислении имеющихся папок разрешается возвращать имена папок, в которых отсутствуют ключи.

    Перечисление еще не соданных папок необходимо для того, чтобы избежать конфликта при создании ключей. Т.к. не требуется, чтобы имя папки однозначно соответствовало контейнеру, то необходим механизм поиска места под заданную папку. Кроме того, папка может быть занята еще не созданным, но находящимся в процессе создания контейнером.

    Функции READER_FUN_FOLDER_ENUM_OPEN, READER_FUN_FOLDER_ENUM_NEXT должны быть реализована, при установленном флаге RDR_FLAG_RDR_FOLDERS. Функцию READER_FUN_FOLDER_ENUM_CLOSE можно не реализовывать, тогда считается, что освобождение контекста перечисления не требуется.

    #define READER_FUN_FOLDER_ENUM_OPEN 0x3302

    См. также

    TReaderInfoFolderEnumOpen_

    Требования:

    Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
    Solaris: 10 или выше.
    FreeBSD: 7 или выше.
    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
    Ядро ОС: Не поддерживает.
    Include: reader.kit\reader.h


READER_FUN_FOLDER_ENUM_NEXT

Получение следующей папки.

Описание см. READER_FUN_FOLDER_ENUM_OPEN

#define READER_FUN_FOLDER_ENUM_NEXT 0x3303

См. также

TReaderInfoFolderEnumNext_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_FUN_FOLDER_ENUM_CLOSE

Закрытие контекста поиска следующей папок.

Описание см. READER_FUN_FOLDER_ENUM_OPEN

#define READER_FUN_FOLDER_ENUM_CLOSE 0x3304

См. также

TReaderInfoFolderEnumClose_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_FUN_FOLDER_OPEN

Открытие или создание папки.

После выполнения этой функции контекст переходит в состояние "RDR_STATE_FOLDER"

Функция должна быть реализована, если носитель поддерживает несколько папок (установлен флаг RDR_FLAG_RDR_FOLDERS). Функция может быть реализована, да же в случае, если носитель не поддерживает несколько папок, тогда в качестве имени папки будет передаваться NULL.

Функция должна возвращать следующие ошибки в специальных ситуациях:

  • RDR_ERR_FILE_NOT_FOUND - папка уже существует, при попытке, открытия еще не существующей папки;
  • RDR_ERR_FILE_EXIST - папка отсутствует, при попытке создания, уже существующей папки.
  • RDR_ERR_PRIME - при попытке создать папку, если носитель не поддерживает создание папок без предъявления пароля.

#define READER_FUN_FOLDER_OPEN 0x3305

См. также

TReaderInfoFolderOpen_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_FUN_FOLDER_CLOSE

Функция закрывает доступ к текущей папке.

После выполнения этой функции контекст переходит в состояние "RDR_STATE_CARRIER"

Функция должна быть реализована, если носитель поддерживает несколько папок (установлен флаг RDR_FLAG_RDR_FOLDERS). Функция может быть реализована, да же в случае, если носитель не поддерживает несколько папок, тогда в качестве имени папки будет передаваться NULL.

#define READER_FUN_FOLDER_CLOSE 0x3306

См. также

TReaderInfoFolderClose

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_FUN_PRIME

Открытие доступа к приложению.

После выполнения этой функции контекст переходит в состояние "RDR_STATE_PRIME".

Если при создании папки носитель возвращает код ошибки RDR_ERR_PRIME, то после этого будет вызвана данная функция.

Функция создана для тех носителей, которые требуют наличия пароля при создании папок. При этом считается, что пароль общий на весь носитель. Кроме того, считается, что после создания папки доступ к папке осуществляется на известном пароле.

После вызова этой функции, будет осуществлен последовательно вызов функций READER_FUN_FOLDER_OPEN, READER_FUN_FOLDER_CLOSE, READER_FUN_LOGOUT

#define READER_FUN_PRIME 0x3307

См. также

TReaderInfoPrime_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


Структуры передачи данных

Структуры | Описание
TReaderInfoUniqueGet_ | Структура получения уникального номера носителя.
TReaderInfoUniqueSet_ | Структура установки уникального номера носителя.
TReaderInfoFolderEnumNext_ | Структура перечисления папок. Получение следующей.
TReaderInfoFolderOpen_ | Структура передачи информации для открытия папки.
TReaderInfoPrime_ | Структура переадчи информации для разметки папки.


TReaderInfoUniqueGet_

Структура получения уникального номера носителя.

typedef struct TReaderInfoUniqueGet_ {
  size_t size_of;
  TSupSysInfoText unique;
} TReaderInfoUniqueGet;

Члены

size_of
Содержит размер структуры TReaderInfoUniqueGet_
unique
Уникальный номер носителя

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


TReaderInfoUniqueSet_

Структура установки уникального номера носителя.

typedef struct TReaderInfoUniqueSet_ {
  size_t size_of;
  TSupSysInfoText unique;
} TReaderInfoUniqueSet;

Члены

size_of
Содержит размер структуры TReaderInfoUniqueSet_
unique
Строка, которая может быть использована для установки уникального номера носителя.

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


TReaderInfoFolderEnumNext_

Структура перечисления папок. Получение следующей.

typedef struct TReaderInfoFolderEnumNext_ {
  size_t size_of;
  const TSupSysEContext * context;
  TSupSysInfoText name;
  TSupSysInfoUntyped add_info;
  TSupSysInfoText prototype;
  unsigned flags;
} TReaderInfoFolderEnumNext, TReaderInfoFolderEnumOpen, TReaderInfoFolderEnumClose;

Члены

size_of
Содержит размер структуры TReaderInfoFolderEnumNext_
context
Контекст считывателя.
name
Имя перечисленной папки. При вызове функции READER_FUN_FOLDER_ENUM_OPEN поле length необходимо установить в максимально возможную длину папки.
add_info
Любая информация по усмотрению производителя модуля поддержки. Используется как контекст перечисления папок. Может быть выделена при вызове функции READER_FUN_FOLDER_ENUM_OPEN, должна быть освобождена при вызове функции READER_FUN_FOLDER_ENUM_CLOSE
prototype
Прототип имени для вновь содаваемой папки.
flags
Флаги перечисления папок. Флаг RDR_FOLDER_ENUM_FLAG_NEW означает необходимость перечисления еще не созданной папки.

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


TReaderInfoFolderOpen_

Структура передачи информации для открытия папки.

typedef struct TReaderInfoFolderOpen_ {
  size_t size_of;
  TSupSysInfoText name;
  size_t mode_bits;
  TReaderInfoOpenFlags * mode;
} TReaderInfoFolderOpen;

Члены

size_of
Содержит размер структуры TReaderInfoFolderOpen_
name
Имя открываемой или создаваемой папки
mode_bits
Количество установленных в 0 или 1 битов в поле mode В данной версии READER_MODEFLAG_BITS.
mode
Битовые флаги открытия или создания папки. Используется только бит: o_creat - если бит выставлен, то требуется создание папки, если нет, то требуется открытие папки.

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


TReaderInfoPrime_

Структура переадчи информации для разметки папки.

typedef struct TReaderInfoPrime_ {
  size_t size_of;
  TSupSysInfoText passwd;
  int retries;
} TReaderInfoPrime;

Члены

size_of
Содержит размер структуры TReaderInfoPrime_
passwd
Пароль доступа к носителю
retries
Функция должна вернуть количество попыток оставшееся для ввода пароля, при неправильно введенном пароле. Если носитель не имеет ограничения по количеству попыток ввода пароля, то поле не должно быть изменено, а CSP будет использовать 3 попытки для ввода пароля.

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


Функции работы в папке

  • Номера функции работы в папке
  • Константы
  • Структуры передачи данных


Номера функции работы в папке

Макросы | Описание
READER_FUN_PASSWD_CLEAR | Очистка пароля.
READER_FUN_LOGIN | Открытие доступа к папке.
READER_FUN_LOGOUT | Закрытие доступа к папке.
READER_FUN_PRIME_LOGIN | Открытие доступа к приложению из состояния выпуска карты. После выполнения этой функции контекст переходит в состояние "RDR_STATE_LOGEDIN".


READER_FUN_PASSWD_CLEAR

Очистка пароля.

Функция устанавливает пароль на контейнер в значение по умолчанию. Функции передается значение master пароля.

Функция создана для носителей поддерживающих 2 пароля:

  • пароль для доступа к папке
  • пароль для очистки пользовательского пароля

Функция может быть не реализована. Рекомендуется ее реализовывать, для носителей в которых возможно создание двух паролей, и поддерживающих счетчик числа попыток доступа к папке.

#define READER_FUN_PASSWD_CLEAR 0x5300

См. также

TReaderInfoPasswdClear_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_FUN_LOGIN

Открытие доступа к папке.

Предъявление пароля носителю.

Функция должна быть реализована для носителей, поддерживающих аппаратную защиту файлов. Функция может быть реализована для носителей, без такой поддержки, в этом случае, в качестве пароля будет передан NULL. Доступ к файлам открытым на чтения без предъявления пароля, должен предоставляться без вызова данной функции.

После выполнения этой функции контекст переходит в состояние "RDR_STATE_LOGEDIN"

#define READER_FUN_LOGIN 0x5301

См. также

TReaderInfoLogin_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_FUN_LOGOUT

Закрытие доступа к папке.

Функция должна закрыть доступ к файлам доступным по предъявлению аппаратного пароля. Если функция содержала пароль внутри контекста, то он так же должен быть вычищен и освобожден.

Функция должна быть реализована, если поддерживаются аппаратные пароли.

После выполнения этой функции контекст переходит в состояние "RDR_STATE_FOLDER"

#define READER_FUN_LOGOUT 0x5302

См. также

TReaderInfoLogout

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_FUN_PRIME_LOGIN

Открытие доступа к приложению из состояния выпуска карты. После выполнения этой функции контекст переходит в состояние "RDR_STATE_LOGEDIN".

Функция может быть реализована.

#define READER_FUN_PRIME_LOGIN 0x5303

См. также

TReaderInfoPrimeLogin

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


Константы

Константы значений по умолчанию.

Макросы | Описание
READER_PASSWD_DEF_SIZE | Максимальный размер пароля, для считывателя не предоставляющего данную информацию.
READER_PASSWD_DEF_PUBLIC_SIZE | Максимальный размер открытой информации, для считывателя не предоставляющего данную информацию.


READER_PASSWD_DEF_SIZE

Максимальный размер пароля, для считывателя не предоставляющего данную информацию.
#define READER_PASSWD_DEF_SIZE 0x20


READER_PASSWD_DEF_PUBLIC_SIZE

Максимальный размер открытой информации, для считывателя не предоставляющего данную информацию.
#define READER_PASSWD_DEF_PUBLIC_SIZE 0xff


Структуры передачи данных

Структуры | Описание
TReaderInfoPasswdClear_ | Структура передачи мастер пароля в очистку пароля.
TReaderInfoLogin_ | Структура передачи информации для получения доступа к папке.


TReaderInfoPasswdClear_

Структура передачи мастер пароля в очистку пароля.

typedef struct TReaderInfoPasswdClear_ {
  size_t size_of;
  TSupSysInfoText passwd;
} TReaderInfoPasswdClear;

Члены

size_of
Содержит размер структуры TReaderInfoPasswdClear_
passwd
Мастер пароль

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


TReaderInfoLogin_

Структура передачи информации для получения доступа к папке.

typedef struct TReaderInfoLogin_ {
  size_t size_of;
  TSupSysInfoText passwd;
  int retries;
} TReaderInfoLogin;

Члены

size_of
Содержит размер структуры TReaderInfoLogin_
passwd
Пароль доступа или passwd.text == NULL для носителей не поддерживающих аппаратной защиты.
retries
Модуль должен вернуть количество оставшихся попыток для предъявления пароля или оставить поле без изменений, если носитель не поддерживает счетчик оставшихся попыток.

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


Функций работы с файлами

  • Номера функций работы с файлами
  • Константы для работы с файлами
  • Структуры передачи данных


Номера функций работы с файлами

Макросы | Описание
READER_FUN_FOLDER_CLEAR | Очистка папки.
READER_FUN_PASSWD_CHANGE | Смена пароля.
READER_FUN_OPEN | Открытие файла.
READER_FUN_CLOSE | Закрытие файла. Функция закрывает файл на носителе.
READER_FUN_UNLINK | Удаление файла.


READER_FUN_FOLDER_CLEAR

Очистка папки.

Функция должна по возможности удалить папку.

Если носитель не поддерживает удаление папок, то функцию можно не реализовывать.

После выполнения этой функции контекст переходит в состояние "RDR_STATE_CARRIER"

#define READER_FUN_FOLDER_CLEAR 0x6300

См. также

TReaderInfoFolderClear

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_FUN_PASSWD_CHANGE

Смена пароля.

Функция должна изменить текущий пароль на папку или на носитель.

Если носитель поддерживает аппаратный пароль и поддерживает смену пароля, то рекомендуется реализовать данную функцию.

#define READER_FUN_PASSWD_CHANGE 0x6301

См. также

TReaderInfoPasswdChange_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_FUN_OPEN

Открытие файла.

Функция должна открыть или создать файл.

Функция должна быть реализована.

После выполнения этой функции контекст переходит в состояние "RDR_STATE_FILE"

#define READER_FUN_OPEN 0x6302

См. также

TReaderInfoOpen_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_FUN_CLOSE

Закрытие файла. Функция закрывает файл на носителе.

В зависимости от состояния флага mode_flags->o_unauthenticated в контексте считывателя после выполнения этой функции контекст переходит в состояние "RDR_STATE_FILE" или в состояние "RDR_STATE_LOGEDIN"

Функция должна быть реализована.

#define READER_FUN_CLOSE 0x6303

См. также

TReaderInfoClose

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_FUN_UNLINK

Удаление файла.

Рекомендуется реализовать данную функцию.

#define READER_FUN_UNLINK 0x6304

См. также

TReaderInfoUnlink

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


Константы для работы с файлами

Константы для работы с файлами

Макросы | Описание
READER_MODEFLAG_BITS | Количество установленных в 0 или 1 битов в поле mode структуры TReaderInfoFolderOpen_.


READER_MODEFLAG_BITS

Количество установленных в 0 или 1 битов в поле mode структуры TReaderInfoFolderOpen_.
#define READER_MODEFLAG_BITS 8


Структуры передачи данных

Структуры | Описание
TReaderInfoPasswdChange_ | Структура передачи нового пароля для смены.
TReaderInfoOpen_ | Структура содержащая информацию об открываемом файле и о методе открытия файла.
TReaderInfoUnlink_ | Структура определяющая удаляемый файл.
TReaderInfoOpenFlags_ | Флаги открытия файла.


TReaderInfoPasswdChange_

Структура передачи нового пароля для смены.

typedef struct TReaderInfoPasswdChange_ {
  size_t size_of;
  TSupSysInfoText new_passwd;
} TReaderInfoPasswdChange;

Члены

size_of
Содержит размер структуры TReaderInfoPasswdChange_
new_passwd
Новый пароль. Значение new_passwd.text может быть NULL, в этом случае рекондуется удалить пароль для доступа, а если это невозможно, то использовать предопределенный пароль. Обычно CSP использует предопределенный пароль, состоящий из необходимого количества ASCII '1' (0x31, 0x31...)

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


TReaderInfoOpen_

Структура содержащая информацию об открываемом файле и о методе открытия файла.

typedef struct TReaderInfoOpen_ {
  size_t size_of;
  size_t mode_bits;
  TReaderInfoOpenFlags * mode;
  TSupSysInfoText name;
  TRdrFileNumber num;
} TReaderInfoOpen;

Члены

size_of
Содержит размер структуры TReaderInfoOpen_
mode_bits
Количество выставленных в 0 или 1 битов открытия файла. В данной версии всегда выставлено в READER_MODEFLAG_BITS
mode
Флаги открытия файла. Подробнее см. TReaderInfoOpenFlags_
name
Структура TSupSysInfoText содержащая имя открываемого файла. Открытие файла может происходить как по его имени так и по его номеру. В данной версии продукта используются следующие имена файлов в папке: "masks.key", "primary.key", "header.key", "masks2.key", "primary2.key", "name.key"; в корне: "def.key". Подробнее см. описание файловой системы.
num
Номер открываемого файла. В данной версии продукта определены следующие номера файлов в папке: 1 - 6, в корне: 7. Нумерация файлов соответствует именам файлов приведенным в описании name.

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


TReaderInfoUnlink_

Структура определяющая удаляемый файл.

typedef struct TReaderInfoUnlink_ {
  size_t size_of;
  TSupSysInfoText name;
  TRdrFileNumber num;
} TReaderInfoUnlink;

Члены

size_of
Содержит размер структуры TReaderInfoUnlink_
name
Структура TSupSysInfoText содержащая имя открываемого файла.
num
Номер открываемого файла.

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


TReaderInfoOpenFlags_

Флаги открытия файла.

typedef struct TReaderInfoOpenFlags_ {
  unsigned o_read;
  unsigned o_write;
  unsigned o_trunc;
  unsigned o_creat;
  unsigned o_unauthenticated;
  unsigned o_private;
} TReaderInfoOpenFlags;

Члены

o_read
Открыть файл на чтение.
o_write
Открыть файл на запись
o_trunc
Запись файла с усечением. Реальное усечение файла проводится не должно, т.к. это может повлечь осталвение данных на носителе, без их предварительной очистки. Данный флаг должен использоваться, только для тех случаев, когда контрлируется целостность записи данных, например при помощи контрольной суммы; в этом случае запись данных должна производится без предварительного контроля целостности уже существующих данных, а при закрытии файла выставляться правильная вновь сформированная контрольная сумма. Так же должно гарантироваться, что запись информации за конец файла будет приводить к заполнению нулями пространства от предыдущего конца файла, до начала записи. Открытие файла без этого флага, может не гарантировать этих эффектов.
o_creat

Флаг используемый при создании файла.

Флаг может не приводить к реальному созданию файла, если необходимые файлы на носителе уже существуют. При отсутствии наличии файла и открытии файла с флагом o_trunc функция должна возвращать RDR_ERR_EXIST. Не требуется, чтобы длина вновь созданного файла установливалась в 0.

o_unauthenticated
Этот флаг устанавливается, если текущее состояние считывателя RDR_STATE_FOLDER и требуется чтение файла без предварительного выполнения функции READER_FUN_LOGIN. Флаг может игнорироваться, если носитель не поддерживает аппаратных паролей.
o_private
Флаг выставляется при создании файлов доступ к которым запрещен на чтение без предварительного предъявления пароля. Флаг может игнорироваться, если носитель не поддерживает аппаратных паролей. Доступ к файлам на запись всегда требует предварительного login.

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


Функции чтения / изменения файла

Функции требующие открытия файла.

  • Номера функции чтения / изменения файла
  • Структуры передачи данных


Номера функции чтения / изменения файла

Макросы | Описание
READER_FUN_READ | Чтение из файла.
READER_FUN_WRITE | Запись в файл.
READER_FUN_CHSIZE | Изменение размера файла с проверкой максимальной длины.
READER_FUN_LENGTH | Размер файла.


READER_FUN_READ

Чтение из файла.

Функция должна быть реализована.

Функция может читать данные поблочно в этом случае, после прочтения очередного блока, функция должна изменить ушиньшить количество данных для чтения и вернуть код ошибки RDR_ERR_BLOCK

#define READER_FUN_READ 0x7300

См. также

TReaderInfoRead_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_FUN_WRITE

Запись в файл.

Функция должна быть реализована.

Функция может записывать данные поблочно в этом случае, после дозаписи очередного блока, функция должна ушиньшить количество данных для записи вернуть код ошибки RDR_ERR_BLOCK

#define READER_FUN_WRITE 0x7301

См. также

TReaderInfoWrite_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_FUN_CHSIZE

Изменение размера файла с проверкой максимальной длины.

Функция изменяет размер файла. Если увеличение размера файла невозможно, то должен возвращатся код ошибки. Размер файла не должен уменьшаться и должна возвращаться текущая длина файла. При увеличении размера файла содержимое должно сохраняться.

Функция может исменять длину поблочно в этом случае, после исзменения очередного блока, функция должна установить текущий размер файла вернуть код ошибки RDR_ERR_BLOCK

Функция должна быть реализована.

#define READER_FUN_CHSIZE 0x7302

См. также

TReaderInfoChSize_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_FUN_LENGTH

Размер файла.

Функция должна вернуть реальный размер файла.

Функция может быть реализована.

#define READER_FUN_LENGTH 0x7303

См. также

TReaderInfoLength_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


Структуры передачи данных

Структуры | Описание
TReaderInfoRead_ | Структура иснформации для чтения.
TReaderInfoWrite_ | Структура иснформации для записи.
TReaderInfoChSize_ | Структура параметров изменения размера.
TReaderInfoLength_ | Структура иснформации получения длины файла.


TReaderInfoRead_

Структура иснформации для чтения.

typedef struct TReaderInfoRead_ {
  size_t size_of;
  size_t from;
  TSupSysInfoUntyped info;
} TReaderInfoRead;

Члены

size_of
Содержит размер структуры TReaderInfoRead_
from
Начальная позиция для чтения файла.
info
Указатель под прочитанные данные и размер читаемых данных.

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


TReaderInfoWrite_

Структура иснформации для записи.

typedef struct TReaderInfoWrite_ {
  size_t size_of;
  size_t from;
  TSupSysInfoUntyped info;
} TReaderInfoWrite;

Члены

size_of
Содержит размер структуры TReaderInfoWrite_
from
Начальная позиция для записи в файл.
info
Записываемые данные

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


TReaderInfoChSize_

Структура параметров изменения размера.

typedef struct TReaderInfoChSize_ {
  size_t size_of;
  size_t length;
} TReaderInfoChSize;

Члены

size_of
Содержит размер структуры TReaderInfoChSize_
length
На входе - требуемая длина файла, на выходе, существующая длина файла

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


TReaderInfoLength_

Структура иснформации получения длины файла.

typedef struct TReaderInfoLength_ {
  size_t size_of;
  size_t length;
} TReaderInfoLength;

Члены

size_of
Содержит размер структуры TReaderInfoLength_
length
Текущий размер файла.

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


Смещения внутри ресурса

Макросы | Описание
READER_IDS_BLOCK | Блок строк считывателя.
READER_IDS_BASE | База смещения блока строк считывателя.
READER_IDS_PASSWD_TERM | Смещение строки термина пароль.
READER_IDS_CARRIER_TYPE | Смещение строки типа носителя.
READER_IDS_QUANT_V1 | Количество строк в текущей версии Reader.


READER_IDS_BLOCK

Блок строк считывателя.

#define READER_IDS_BLOCK 0x400

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_IDS_BASE

База смещения блока строк считывателя.

#define READER_IDS_BASE 0x1300

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_IDS_PASSWD_TERM

Смещение строки термина пароль.

#define READER_IDS_PASSWD_TERM 1

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_IDS_CARRIER_TYPE

Смещение строки типа носителя.

#define READER_IDS_CARRIER_TYPE 2

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


READER_IDS_QUANT_V1

Количество строк в текущей версии Reader.

#define READER_IDS_QUANT_V1 ( READER_IDS_CARRIER_TYPE + 1 )

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\reader.h


Интерфейс к датчикам случайных чисел

  • Информационные функции
  • Функции ДСЧ


Информационные функции

Функции дополняющие информационные функции из Интерфейс между списком и элементом

  • Номера информационных функций
  • Структуры общей информации.


Номера информационных функций

Функции дополняющие информационные функции из Интерфейс между списком и элементом

Макросы | Описание
RANDOM_FUN_TYPE | Функция получения типа ДСЧ.


RANDOM_FUN_TYPE

Функция получения типа ДСЧ.

Номер функции получения типа ДСЧ в глобальной нумерации функций. Функция должна корректно работать без контекста ДСЧ. Если функция не реализована, то считается, что все флаги сброшены. В данной версии такой ДСЧ не используется.

#define RANDOM_FUN_TYPE 0x100

См. также

TRandomInfoType_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\rndm_sys.h


Структуры общей информации.

Структуры для передачи информации в функции, реализуемые для конкретного типа ДСЧ, но не требующие проверки физического наличия ДСЧ и типа подключения.

Структуры | Описание
TRandomInfoType_ | Структура информации о типе ДСЧ.


TRandomInfoType_

Структура информации о типе ДСЧ.

typedef struct TRandomInfoType_ {
  size_t size_of;
  TRndmType type;
} TRandomInfoType;

Члены

size_of
Размер структуры.
type
Функция должна выставить битовые флаги соответствующие данному типу ДСЧ:
  • RNDM_TYPE_WINDOWLESS - ДСЧ не выдающий окон;
  • RNDM_TYPE_REMOVABLE - отчуждаемый ДСЧ;
  • RNDM_TYPE_CERTIFIED - сертифицированный ФАПСИ ДСЧ;
  • RNDM_TYPE_HARD - физический ДСЧ;
  • RNDM_TYPE_FAPSI_GAMMA - сгенеренная в ФАПСИ гамма.

См. также

RANDOM_FUN_TYPE

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\rndm_sys.h


Функции ДСЧ

  • Номера функций ДСЧ
  • Структуры передачи случайных чисел


Номера функций ДСЧ

Макросы | Описание
RANDOM_FUN_RNDM | Функция получения случайного числа.
RANDOM_FUN_HWND | Функция установления HWND для выдачи диалога случайного числа.


RANDOM_FUN_RNDM

Функция получения случайного числа.

Номер функции получения случайного числа в глобальной нумерации функций.

Основная функция получения случайного числа. Функция должна быть реализована в библиотеке поддержки.

#define RANDOM_FUN_RNDM 0x2100

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\rndm_sys.h


RANDOM_FUN_HWND

Функция установления HWND для выдачи диалога случайного числа.

Номер функции установки parent HWND диалога в глобальной нумерации функций.

Функция может быть реализована для оконных ДСЧ.

#define RANDOM_FUN_HWND 0x2101

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\rndm_sys.h


Структуры передачи случайных чисел

Структуры для передачи информации в функции, реализующие ДСЧ.

Структуры | Описание
TRandomInfoRndm_ | Структура передачи случайной информации.
TRandomInfoParentHwnd_ | Структура передачи parent HWND в ДСЧ.


TRandomInfoRndm_

Структура передачи случайной информации.

typedef struct TRandomInfoRndm_ {
  size_t size_of;
  TSupSysInfoUntyped info;
} TRandomInfoRndm;

Члены

size_of
Размер структуры.
info
Случайная последовательность сгенеренная ДСЧ. При вызове функции RANDOM_FUN_RNDM в поле length структуры содержится размер выделенной памяти для массива случайных байт. А info структуры содержит указатель на выделенную память. Функция RANDOM_FUN_RNDM должна полностью заполнить поле info случайными байтами.

См. также

RANDOM_FUN_RNDM ,TSupSysInfoUntyped_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\rndm_sys.h


TRandomInfoParentHwnd_

Структура передачи parent HWND в ДСЧ.

struct TRandomInfoParentHwnd_ {
};

См. также

RANDOM_FUN_HWND

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\rndm_sys.h


Интерфейс к смарт-картам

Библиотека поддержки смарт-карт должена поддерживать практически все функции поддержки считывателя, за исключением нескольких функций реализованных в библиотеке поддержки считывателя PC/SC. Часть функций в библиотеке PC/SC реализована неполностью и должна быть дореализована в библиотеке поддержки смарт-карт. Несмотря на то, что количество реализованных PC/SC функций незначительно, рекомендуется написание библиотеки поддержки носителя (смарт-карты), а не полной библиотеки считывателя (хотя и этот вариант возможен) по нескольким причинам.

  • Библиотека PC/SC предоставляет единый, независимый от считывателя и от операционной системы механизм доступа к карте. Это основной довод в пользу библиотеки поддержки смарт-карт и отказываться от него в сторону написания библиотеки поддержки считывателя, рекомендуется только в случае отсутствия драйверов для PC/SC библиотеки или в случае, когда понятия носителя и считывателя не разделимо (как в случае электронных USB ключей).
  • В библиотеке PC/SC практически полностью реализованы механизм блокировок.
  • Частично реализованы механизмы восстановления соединения, перечисления папок и т.д.
  • Реализованы вспомогательные функции.

    • К функциям реализованным в библиотеке PC/SC и имеющие независимый интерфейс, относятся:

    • Информационные функции;
    • Функции для управления считывателем и его контекстом.

    Частично реализованы функции (функции которые выполняют ряд действий, а затем вызывают функции носителя) в интерфейсе PC/SC:

    • определения носителя (READER_FUN_CONNECT_CARRIER) в части получения ATR, и перекрываемый механизм поиска носителя по ATR и маске; изменен интерфейс функции; см. RSCARD_FUN_CONNECT_CARRIER;
    • проверка соответствия носителя, вставленному (READER_FUN_SAME_MEDIA) в части PC/SC и ATR; изменен интерфейс функции; см. RSCARD_FUN_SAME_MEDIA;
    • восстановление связи с носителем (READER_FUN_RESTORE_CONTEXT) в части PC/SC и ATR; интерфейс не изменен; см. RSCARD_FUN_RESTORE_CONTEXT.

    Функции, которые не могут быть перекрыты на собственные, а вызываются только функции PC/SC:

    • Блокирование носителя (READER_FUN_LOCK, READER_FUN_UNLOCK);

    Функции, которые реализованы в интерфейсе PC/SC и могут быть перекрыты стандартным образом:

    • Перечисление папок (READER_FUN_FOLDER_ENUM_OPEN, READER_FUN_FOLDER_ENUM_NEXT, READER_FUN_FOLDER_ENUM_CLOSE). Этот механизм можно перекрывать, перекрывая функцию READER_FUN_FOLDER_ENUM_OPEN.

    Если смарт-карта поддерживает нисколько контейнеров на одном носителе, то есть два способа реализации функций перечисления папок на носителе. Первый, - стандартный способ описанный в перечислении папок для считывателя.

    Второй способ применим исключительно к смарт-картам и используется, когда количество контейнеров на смарт-карте по каким-либо причинам ограничено и имена папок предопределены. В этом случае достаточно при регистрации считывателя в реестр (или его заменитель) добавить строковый параметр Folders для каждой конфигурации носителя. Строка должна содержать имена папок разделенных символом '\'.

    Ниже приводится документация по библиотеке поддержки смарт-карт.

    • Общие определения
    • Специфические функции управления смарт-картами
    • Перекрытие стандартных функций интерфейса


Общие определения

Структуры | Описание
TSCardInfoAPDU_ | Структура передачи APDU команды.
TSCardInfoBerTLVSearch_ | Структура используемая для поиска объекта данных в структуре BER-TLV.
TSCardInfoSimpleTLVSearch_ | Структура используемая для поиска объекта данных в структуре SIMPLE-TLV.
Определения типов | Описание
TDisposition | Перечисление действий выполняемых PC/SC в конкретных ситуациях.
TSCardAPDUCmd | Функция выполнения APDU команды.
TSCardBerTLVSearch | Указатель на функцию поиска объекта в структуре BER-TLV.
TSCardSimpleTLVSearch | Указатель на функцию поиска объекта в структуре SIMPLE-TLV.
Макросы | Описание
RSCARD_PROTOCOL_T0 | Протокол T0.
RSCARD_PROTOCOL_T1 | Протокол T1.
RSCARD_DISPOSITION_LEAVE | Реакция на команду: без изменений.
RSCARD_DISPOSITION_RESET | Реакция на команду: передача команды RESET карте.
RSCARD_DISPOSITION_UNPOWER | Реакция на команду: выключение питания на карте.
RSCARD_DISPOSITION_EJECT | Реакция на команду: выброс карты из считывателя.


RSCARD_PROTOCOL_T0

Протокол T0.

#define RSCARD_PROTOCOL_T0 0x1

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\scard.h


RSCARD_PROTOCOL_T1

Протокол T1.

#define RSCARD_PROTOCOL_T1 0x2

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\scard.h


RSCARD_DISPOSITION_LEAVE

Реакция на команду: без изменений.

#define RSCARD_DISPOSITION_LEAVE 0

См. также

TDisposition

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\scard.h


RSCARD_DISPOSITION_RESET

Реакция на команду: передача команды RESET карте.

#define RSCARD_DISPOSITION_RESET 1

См. также

TDisposition

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\scard.h


RSCARD_DISPOSITION_UNPOWER

Реакция на команду: выключение питания на карте.

#define RSCARD_DISPOSITION_UNPOWER 2

См. также

TDisposition

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\scard.h


RSCARD_DISPOSITION_EJECT

Реакция на команду: выброс карты из считывателя.

#define RSCARD_DISPOSITION_EJECT 3

См. также

TDisposition

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\scard.h


TDisposition

Перечисление действий выполняемых PC/SC в конкретных ситуациях.

unsigned TDisposition;

См. также

RSCARD_DISPOSITION_LEAVE ,RSCARD_DISPOSITION_RESET ,RSCARD_DISPOSITION_UNPOWER ,RSCARD_DISPOSITION_EJECT ,TSCardInfoConnectCarrier_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\scard.h


TSCardAPDUCmd

Функция выполнения APDU команды.

Функция, которая выполняет APDU команду для вставленной карты на считывателе указанном в параметре ctx.

TSupErr(* TSCardAPDUCmd)(TSupSysEContext *ctx, TSCardInfoAPDU *apdu);

См. также

TSCardInfoAPDU_ ,TSCardInfoConnectCarrier_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\scard.h


TSCardBerTLVSearch

Указатель на функцию поиска объекта в структуре BER-TLV.

Вспомогательная функция, может использоваться для поиска объекта в структуре BER-TLV.

TSupErr(* TSCardBerTLVSearch)(TSCardInfoBerTLVSearch *);

См. также

TSCardInfoBerTLVSearch_ ,TSCardSimpleTLVSearch ,TSCardInfoConnectCarrier_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\scard.h


TSCardSimpleTLVSearch

Указатель на функцию поиска объекта в структуре SIMPLE-TLV.

Вспомогательная функция, может использоваться для поиска объекта в структуре SIMPLE-TLV.

TSupErr(* TSCardSimpleTLVSearch)(TSCardInfoSimpleTLVSearch *);

См. также

TSCardInfoSimpleTLVSearch_ ,TSCardBerTLVSearch ,TSCardInfoConnectCarrier_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\scard.h


TSCardInfoAPDU_

Структура передачи APDU команды.

typedef struct TSCardInfoAPDU_ {
  unsigned char cla;
  unsigned char ins;
  unsigned char p1;
  unsigned char p2;
  TSupSysInfoUntyped input;
  TSupSysInfoUntyped output;
  unsigned char sw1;
  unsigned char sw2;
} TSCardInfoAPDU;

Члены

cla
CLA
ins
INS
p1
P1
p2
P2
input
Входные данные для команды, для команд case:0 и case:2 input.length должен быть равен 0, input.data должен быть равен NULL.
output
Выходные данные для команды, для команд case:1 и case:3 output.length должен быть равен 0, output.data должен быть равен NULL. Перед вызовом output.length должна быть выставлена в количество ожидаемых байт, а output.data должна указывать на выделенную под output.length область памяти.
sw1
SW1
sw2
SW2

См. также

TSupSysInfoUntyped_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\scard.h


TSCardInfoBerTLVSearch_

Структура используемая для поиска объекта данных в структуре BER-TLV.

typedef struct TSCardInfoBerTLVSearch_ {
  unsigned char class_type;
  unsigned char class_tag;
  unsigned char simple_tag;
  TSupSysInfoUntyped input;
  TSupSysInfoUntyped output;
} TSCardInfoBerTLVSearch;

Члены

class_type
"Класс" поля тега BER-TLV (биты 6-8).
class_tag
"Номер тега" поля тега BER-TLV (биты 1-5).
simple_tag
Тег искомого объекта данных.
input
Входная структура для поиска в формате BER-TLV.
output
Найденная структура: элементарный объект. При вызове функции необходимо выделить память под максимально возможный результат и указать его размер в output.length. На выходе output.length возвращает размер найденных данных.

См. также

TSupSysInfoUntyped_ ,TSCardInfoConnectCarrier_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\scard.h


TSCardInfoSimpleTLVSearch_

Структура используемая для поиска объекта данных в структуре SIMPLE-TLV.

typedef struct TSCardInfoSimpleTLVSearch_ {
  unsigned char simple_tag;
  TSupSysInfoUntyped input;
  TSupSysInfoUntyped output;
} TSCardInfoSimpleTLVSearch;

Члены

simple_tag
Тег искомого объекта данных.
input
Входная структура для поиска в формате SIMPLE-TLV.
output
Найденная структура: элементарный объект. При вызове функции необходимо выделить память под максимально возможный результат и указать его размер в output.length. На выходе output.length возвращает размер найденных данных.

См. также

TSupSysInfoUntyped_ ,TSCardInfoConnectCarrier_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\scard.h


Специфические функции управления смарт-картами

  • Номера специфичных для смарт-карт функций
  • Структуры передачи данных


Номера специфичных для смарт-карт функций

Номера функций не объявленных в интерфейсе считывателя и носителя, имеющих специальное значения при реализации библиотеки поддержки смарт-карт.

Макросы | Описание
RSCARD_FUN_IS_SAME_ATR | Функция проверки поддержки ATR библиотекой поддержки смарт-карты.
RSCARD_FUN_PRECONNECT_CARRIER | Соединение с носителем.
RSCARD_FUN_POSTCONNECT_CARRIER | Соединение с носителем.


RSCARD_FUN_IS_SAME_ATR

Функция проверки поддержки ATR библиотекой поддержки смарт-карты.

Существует два способа определения соответствия вставленной карты и библиотеки поддержки этой карты.

Первый способ наиболее используемый и основан на ATR и маски на этот ATR. Для этого в реестр или его заменитель необходимо записать два бинарных параметра в "\\CONFIG\\KeyCarriers\\<nickname>\\<connect>" ATR и Mask. где nickname - имя смарт-карты, connect - текущая конфигурация смарт-карты. Пусть ATR вставленной смарт-карты равен SRC_ATR, пусть значение параметра ATR в реестре REG_ATR, значение маски REG_MASK, тогда, если длины всех (SRC_ATR, REG_ATR, REG_MASK) бинарных параметров совпадают и SRC_ATR^REG_MASK==REG_ATR, то смарт-карта поддерживается данной конфигурацией библиотеки поддержки.

Второй способ основан на функции проверки смарт-карты. В этом случае необходимо реализовать данную функцию и выполнить необходимые действия по проверке. Возврат кода SUP_ERR_NO означает что библиотека в данной конфигурации поддерживает вставленную карту.

#define RSCARD_FUN_IS_SAME_ATR 0x2500

См. также

TSCardInfoIsSame_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\scard.h


RSCARD_FUN_PRECONNECT_CARRIER

Соединение с носителем.

Эта функция аналогична READER_FUN_CONNECT_CARRIER, имеет другую структуру передачи информации и перед ее выполнением модуль поддержки считывателя выполняет ряд действий; в частности:

  • Проверку наличия карты в считывателе (что, вообще говоря, не гарантирует что к моменту вызова функции карта будет находится в считывателе);
  • Определение протокола и ATR вставленного носителя;
  • Поиск необходимой библиотеки поддержки смарт-карты в соответствии с ATR вставленной карты (что, опять же, не гарантирует наличие соединения с картой при последующем обращении к карте).

    • #define RSCARD_FUN_PRECONNECT_CARRIER 0x2501

    См. также

    TSCardInfoPreconnectCarrier_ ,TReaderInfoConnectCarrier_ ,READER_FUN_CONNECT_CARRIER ,RSCARD_FUN_POSTCONNECT_CARRIER

    Требования:

    Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
    Solaris: 10 или выше.
    FreeBSD: 7 или выше.
    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
    Ядро ОС: Не поддерживает.
    Include: reader.kit\scard.h


RSCARD_FUN_POSTCONNECT_CARRIER

Соединение с носителем.

Эта функция вызывается после RSCARD_FUN_PRECONNECT_CARRIER, и выполняет формирование структуры обращения к карте.

#define RSCARD_FUN_POSTCONNECT_CARRIER 0x2502

См. также

TSCardInfoPostconnectCarrier_ ,TReaderInfoConnectCarrier_ ,READER_FUN_CONNECT_CARRIER ,RSCARD_FUN_PRECONNECT_CARRIER

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.
Solaris: 10 или выше.
FreeBSD: 7 или выше.
Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.
Ядро ОС: Не поддерживает.
Include: reader.kit\scard.h


Структуры передачи данных

Структуры | Описание
TSCardInfoIsSame_ | Структура передачи ATR На проверку поддержки.
TSCardInfoPreconnectCarrier_ | Структура предварительного соединения с носителем.
TSCardInfoPostconnectCarrier_ | Структура окончательного соединения с носителем.


TSCardInfoIsSame_

Структура передачи ATR На проверку поддержки.

Данная структура передает информацию о протоколе и ATR вставленной карты, для проверки на поддержку карты данной библиотекой.

typedef struct TSCardInfoIsSame_ {
  size_t size_of;
  unsigned protocol;
  TSupSysInfoUntyped atr;
} TSCardInfoIsSame;

Члены

size_of
Размер передаваемой структуры
protocol
Протокол передачи данных для данной карты.
atr
ATR вставленной карты.

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

Требования:

Solaris: 10 или выше.

Требования:

FreeBSD: 7 или выше.

Требования:

Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

Требования:

Ядро ОС: Не поддерживает.

Требования:

Include: reader.kit\scard.h


TSCardInfoPreconnectCarrier_

Структура предварительного соединения с носителем.

typedef struct TSCardInfoPreconnectCarrier_ {
  size_t size_of;
  unsigned protocol;
  TSupSysInfoUntyped atr;
  TSupSysEContext * reader;
  TSCardBerTLVSearch ber_tlv_search;
  TSCardSimpleTLVSearch simple_tlv_search;
  TDisposition begin_transaction_disposition;
  TDisposition end_transaction_disposition;
  TDisposition disconnect_disposition;
  TDisposition connect_disposition;
  TDisposition reconnect_disposition;
  TCHAR * connect;
} TSCardInfoPreconnectCarrier;

Члены

size_of
Размер передаваемой структуры.
protocol
Протокол выбранный по умолчанию для текущей карты.
atr
ATR карты
reader
Контекст считывателя, в котором находится карта. Обычно контекст считывателя запоминается при соединении с картой внутри контекста носителя и используется для передачи в функцию TSCardAPDUCmd.
ber_tlv_search
Указатель на вспомогательную функцию, которая может использоваться при поиске внутри BER-TLV структуры. Обычно указатель на функцию запоминается при соединении с картой внутри контекста носителя и используется по мере необходимости.
simple_tlv_search
Указатель на вспомогательную функцию, которая может использоваться при поиске внутри SIMPLE-TLV структуры. Обычно указатель на функцию запоминается при соединении с картой внутри контекста носителя и используется по мере необходимости.
begin_transaction_disposition
Действия выполняемые терминалом при начале транзакции
end_transaction_disposition
Действия выполняемые терминалом при окончании транзакции
disconnect_disposition
Действия выполняемые терминалом при отсоединении от карты
connect_disposition
Действия выполняемые терминалом при соединении с картой
reconnect_disposition
Действия выполняемые терминалом при восстановлении соединения с картой
connect
Имя текущей кофигурации, для которой было установлено соответствие по ATR.

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

Требования:

Solaris: 10 или выше.

Требования:

FreeBSD: 7 или выше.

Требования:

Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

Требования:

Ядро ОС: Не поддерживает.

Требования:

Include: reader.kit\scard.h


TSCardInfoPostconnectCarrier_

Структура окончательного соединения с носителем.

typedef struct TSCardInfoPostconnectCarrier_ {
  size_t size_of;
  TSCardAPDUCmd apdu_cmd;
} TSCardInfoPostconnectCarrier;

Члены

size_of
Размер передаваемой структуры.
apdu_cmd
Функция передачи APDU-команды.

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

Требования:

Solaris: 10 или выше.

Требования:

FreeBSD: 7 или выше.

Требования:

Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

Требования:

Ядро ОС: Не поддерживает.

Требования:

Include: reader.kit\scard.h


Перекрытие стандартных функций интерфейса

Функции, которые определены в интерфейсе библиотеки считывателя, но частично реализованы в библиотеке поддержки PC/SC, т.е. перед вызовом функции библиотеки поддержки смарт-карты выполняется ряд действий, а затем вызывается функция смарт-карты.

  • Номера перекрытых для смарт-карт функций
  • Структуры передачи данных


Номера перекрытых для смарт-карт функций

Макросы | Описание
RSCARD_FUN_CONNECT_CARRIER | Соединение с носителем.
RSCARD_FUN_SAME_MEDIA | Проверка соотвествия носителя.
RSCARD_FUN_RESTORE_CONTEXT | Восстановление соединения после потери контакта.


RSCARD_FUN_CONNECT_CARRIER

Соединение с носителем.

Эта функция аналогична READER_FUN_CONNECT_CARRIER и имеет тот же номер функции, но имеет другую структуру передачи информации и перед ее выполнением модуль поддержки считывателя выполняет ряд действий; в частности:

  • Проверку наличия карты в считывателе (что, вообще говоря, не гарантирует что к моменту вызова функции карта будет находится в считывателе);
  • Определение протокола и ATR вставленного носителя;
  • Поиск необходимой библиотеки поддержки смарт-карты в соответствии с ATR вставленной карты (что, опять же, не гарантирует наличие соединения с картой при последующем обращении к карте);
  • Формирование структуры обращения к карте.

    • #define RSCARD_FUN_CONNECT_CARRIER READER_FUN_CONNECT_CARRIER

    См. также

    TSCardInfoConnectCarrier_ ,TReaderInfoConnectCarrier_ ,READER_FUN_CONNECT_CARRIER

    Требования:

    Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Требования:

    Solaris: 10 или выше.

    Требования:

    FreeBSD: 7 или выше.

    Требования:

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Требования:

    Ядро ОС: Не поддерживает.

    Требования:

    Include: reader.kit\scard.h


RSCARD_FUN_SAME_MEDIA

Проверка соотвествия носителя.

Эта функция аналогична READER_FUN_SAME_MEDIA имеет тот же номер и ту же структуру передачи информации, но перед ее вызовом модель поддержки PC/SC считывателя выполняет ряд действий.

Функция может быть вызвана в двух случаях. 1. Был разрыв соединения и идет проверка, что в считывателе находится тот же носитель, что и ранее. При этом гарантируется, что при следующем обращении к носителю либо функция вернет ошибку (при отсутствии носителя и при смене носителя за момент вызова данной функции), либо ATR и протокол носителя будет в точности совпадать с ATR ранее вставленного носителя.

2. Идет определение уникального номера носителя. В этом случае гарантируется, что при следующем обращении к носителю либо функция вернет ошибку (при отсутствии носителя и при смене носителя за момент вызова данной функции), либо ATR и протокол носителя поддерживаются данной библиотекой.

#define RSCARD_FUN_SAME_MEDIA READER_FUN_SAME_MEDIA

См. также

READER_FUN_SAME_MEDIA ,TReaderInfoSameMedia_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

Требования:

Solaris: 10 или выше.

Требования:

FreeBSD: 7 или выше.

Требования:

Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

Требования:

Ядро ОС: Не поддерживает.

Требования:

Include: reader.kit\scard.h


RSCARD_FUN_RESTORE_CONTEXT

Восстановление соединения после потери контакта.

Эта функция аналогична READER_FUN_RESTORE_CONTEXT имеет тот же номер и ту же структуру передачи информации, но перед ее вызовом модель поддержки PC/SC считывателя выполняет ряд действий.

Гарантируется, что при следующем обращении к носителю либо функция вернет ошибку (при отсутствии носителя и при смене носителя за момент вызова данной функции), либо смарт-карта вставленная в носитель та же, что и перед потерей соединения. Так же гарантируется, что если до потери соединения вызовы к носителю были заблокированы, то и они так же заблокированы.

#define RSCARD_FUN_RESTORE_CONTEXT READER_FUN_RESTORE_CONTEXT

См. также

TReaderInfoRestoreContext_ ,READER_FUN_RESTORE_CONTEXT

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

Требования:

Solaris: 10 или выше.

Требования:

FreeBSD: 7 или выше.

Требования:

Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

Требования:

Ядро ОС: Не поддерживает.

Требования:

Include: reader.kit\scard.h


Структуры передачи данных

Структуры | Описание
TSCardInfoConnectCarrier_ | Структура соединения с носителем.


TSCardInfoConnectCarrier_

Структура соединения с носителем.

typedef struct TSCardInfoConnectCarrier_ {
  size_t size_of;
  unsigned protocol;
  TSupSysInfoUntyped atr;
  TSupSysEContext * reader;
  TSCardAPDUCmd apdu_cmd;
  TSCardBerTLVSearch ber_tlv_search;
  TSCardSimpleTLVSearch simple_tlv_search;
  TDisposition begin_transaction_disposition;
  TDisposition end_transaction_disposition;
  TDisposition disconnect_disposition;
  TDisposition connect_disposition;
  TDisposition reconnect_disposition;
  TCHAR * connect;
} TSCardInfoConnectCarrier;

Члены

size_of
Размер передаваемой структуры.
protocol
Протокол выбранный по умолчанию для текущей карты.
atr
ATR карты
reader
Контекст считывателя, в котором находится карта. Обычно контекст считывателя запоминается при соединении с картой внутри контекста носителя и используется для передачи в функцию TSCardAPDUCmd.
apdu_cmd
Функция передачи APDU-команды.
ber_tlv_search
Указатель на вспомогательную функцию, которая может использоваться при поиске внутри BER-TLV структуры. Обычно указатель на функцию запоминается при соединении с картой внутри контекста носителя и используется по мере необходимости.
simple_tlv_search
Указатель на вспомогательную функцию, которая может использоваться при поиске внутри SIMPLE-TLV структуры. Обычно указатель на функцию запоминается при соединении с картой внутри контекста носителя и используется по мере необходимости.
begin_transaction_disposition
Действия выполняемые терминалом при начале транзакции
end_transaction_disposition
Действия выполняемые терминалом при окончании транзакции
disconnect_disposition
Действия выполняемые терминалом при отсоединении от карты
connect_disposition
Действия выполняемые терминалом при соединении с картой
reconnect_disposition
Действия выполняемые терминалом при восстановлении соединения с картой
connect
Имя текущей кофигурации, для которой было установлено соответствие по ATR.

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

Требования:

Solaris: 10 или выше.

Требования:

FreeBSD: 7 или выше.

Требования:

Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

Требования:

Ядро ОС: Не поддерживает.

Требования:

Include: reader.kit\scard.h


Интерфейс к считывателям таблеток dallas

Интерфейс подключения считывателей таблеток Dallas создан для унификации подобных считывателей. Разработка таких считывателей возможна как с помощью данного интерфейса так и без его помощи (в рамках интерфейса считывателя).

Интерфейс подключения считывателей таблеток Dallas содержит внутри себя реализацию файловой системы таких таблеток совместимую с файловой системой Информзащиты, т.е. возможно совместное хранение информации CSP и информации необходимой для функционирования плат типа Соболь. Использование данного интерфейса позволяет перенаправить функции работы с папками и файлами на модуль поддержки носителя (таблеток Dallas).

Несмотря на то, что на текущий момент поддерживаются только таблетки с последовательной памятью без пароля большого размера (таблетки DS1995, DS1996), модуль поддержки таблеток разрабатывался с учетом возможного расширения количества поддерживаемых типов таблеток. Поэтому взаимодействие считывателя и моделя таблеток происходит через стандартный интерфес носителя (с некоторыми дополнениями и ограничениями).

Для корректной реализации считывателя поддерживающих таблетки, необходимо реализовать модуль поддержки считывателя со следующими интерфейсами:

  • Интерфейс между списком и элементом
  • Интерфейс к считывателям в части Информационные функции , и функцию READER_FUN_UNIQUE_GET
  • Реализация специфичных для Dallas функций (DALLAS_FUN_IS_SAME_SER_NUM)
Реализация части функций приводимых ниже в документации должна иметь отличное от интерфеса считывателя функционирование.

Замечание по блокировкам. Реализация блокировок в носителях поддерживающих таблетки dallas рекомендуется сохранить в том виде как они привидены в примере. Эта реализация схемы блокировок рекомендованна Dallas.

Рекомендуется так же обратить внимание на Примечания по callback функциям.

  • Функции считывателя
  • Константы
  • Callback функции для поддержки файловой системы


Функции считывателя

Специальные функции считывателя для поддержания носителей Dallas

  • Номера функций
  • Структуры передачи данных


Номера функций

Макросы | Описание
DALLAS_FUN_IS_SAME_SER_NUM | Проверка поддержки таблеток с заданным серийным номером.


DALLAS_FUN_IS_SAME_SER_NUM

Проверка поддержки таблеток с заданным серийным номером.

Номер функции осуществляющий проверку, что носитель поддерживает данный тип таблеток по его серийному номеру.

#define DALLAS_FUN_IS_SAME_SER_NUM 0x2500

См. также

TDSInfoIsSame_

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

Требования:

Solaris: 10 или выше.

Требования:

FreeBSD: 7 или выше.

Требования:

Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

Требования:

Ядро ОС: Не поддерживает.

Требования:

Include: reader.kit\ds_ctx.h


Структуры передачи данных

Структуры | Описание
TDSInfoIsSame_ | Структура проверки соответствия присоедиенной таблетки.
TDSInfoConnectCarrier_ | Структура присоединения считывателя таблеток к файловой системе таблетки.
TDSInfoUnique_ | Структура преобразования уникального номера таблетки к текстовому представлению.
TDSInfoRestoreContext_ | Структура восстановления состояния файловой системы после прерывания операции.


TDSInfoIsSame_

Структура проверки соответствия присоедиенной таблетки.

typedef struct TDSInfoIsSame_ {
  size_t size_of;
  unsigned char unique[8];
} TDSInfoIsSame;

Члены

size_of
Размер структуры TDSInfoIsSame_
unique
Уникальный номер носителя

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

Требования:

Solaris: 10 или выше.

Требования:

FreeBSD: 7 или выше.

Требования:

Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

Требования:

Ядро ОС: Не поддерживает.

Требования:

Include: reader.kit\ds_ctx.h


TDSInfoConnectCarrier_

Структура присоединения считывателя таблеток к файловой системе таблетки.

typedef struct TDSInfoConnectCarrier_ {
  size_t size_of;
  unsigned char unique[8];
  TSupSysContext * context;
  DSReadFun read_proc;
  DSWriteFun write_proc;
  unsigned flags;
} TDSInfoConnectCarrier;

Члены

size_of
Размер структуры TDSInfoConnectCarrier_
unique
Уникальный номер носителя
context
Контекст считывателя.
read_proc
CALLBACK функция чтения информации с носителя.
write_proc
CALLBACK функция записи информации на носитель.
flags
Флаги соединения с носителем. (см TReaderInfoConnectCarrier_)

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

Требования:

Solaris: 10 или выше.

Требования:

FreeBSD: 7 или выше.

Требования:

Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

Требования:

Ядро ОС: Не поддерживает.

Требования:

Include: reader.kit\ds_ctx.h


TDSInfoUnique_

Структура преобразования уникального номера таблетки к текстовому представлению.

typedef struct TDSInfoUnique_ {
  size_t size_of;
  unsigned char unique[8];
  TSupSysInfoText unique_str;
} TDSInfoUnique;

Члены

size_of
Размер структуры TDSInfoUnique_
unique
Уникальный номер носителя
unique_str
Строковое представление уникального номера носителя

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

Требования:

Solaris: 10 или выше.

Требования:

FreeBSD: 7 или выше.

Требования:

Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

Требования:

Ядро ОС: Не поддерживает.

Требования:

Include: reader.kit\ds_ctx.h


TDSInfoRestoreContext_

Структура восстановления состояния файловой системы после прерывания операции.

typedef struct TDSInfoRestoreContext_ {
  TReaderInfoRestoreContext * base;
  unsigned flags;
} TDSInfoRestoreContext;

Члены

base
Информация переданная reader для восстановления контекста файловой системы
flags
Флаги восстановления соединения для файловой системы dallas (см. DALLAS_RESTORE_FLAG_HARD)

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

Требования:

Solaris: 10 или выше.

Требования:

FreeBSD: 7 или выше.

Требования:

Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

Требования:

Ядро ОС: Не поддерживает.

Требования:

Include: reader.kit\ds_ctx.h


Константы

Макросы | Описание
DALLAS_RESTORE_FLAG_HARD | Восстановление после переключения Флаг восстановления контекста после вклинивания в операцию другой нити.


DALLAS_RESTORE_FLAG_HARD

Восстановление после переключения Флаг восстановления контекста после вклинивания в операцию другой нити.

#define DALLAS_RESTORE_FLAG_HARD 0x1

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

Требования:

Solaris: 10 или выше.

Требования:

FreeBSD: 7 или выше.

Требования:

Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

Требования:

Ядро ОС: Не поддерживает.

Требования:

Include: reader.kit\ds_ctx.h


Callback функции для поддержки файловой системы

Определения типов | Описание
DSReadFun | CALLBACK функция чтения информации из таблетки.
DSWriteFun | CALLBACK функция записи информации в таблетку.


DSReadFun

CALLBACK функция чтения информации из таблетки.

typedef TSupErr(* DSReadFun)(TSupSysContext *context, size_t from, size_t *length, unsigned char *buffer);

Аргументы

context
[in] Контекст считывателя
from
[in] начальная позиция для чтения
length
[in] Количество байт, которые необходимо прочитать
buffer
[out] Буфер, в который необходимо поместить прочитанные байты

Примечания

Функция чтения при плохом коткакте с таблеткой должна, либо обнаруживать наличие плохого контакта самостоятельно (т.е. возвращать соответствующий код ошибки), либо должна выставлять логическую единицу на протяжении всей последовательности плохого сигнала (так как это рекомендовано dallas). При невозможности реализации данных требований должно быть реализовано повторное считывание страницы, это замедляет процесс чтения, но ведет к приемлимой вероятности ошибки при текущей организации файловой системы.

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

Требования:

Solaris: 10 или выше.

Требования:

FreeBSD: 7 или выше.

Требования:

Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

Требования:

Ядро ОС: Не поддерживает.

Требования:

Include: reader.kit\ds_ctx.h


DSWriteFun

CALLBACK функция записи информации в таблетку.

typedef TSupErr(* DSWriteFun)(TSupSysContext *context, size_t from, size_t *length, const unsigned char *buffer);

Аргументы

context
[in] Контекст считывателя
from
[in] начальная позиция для записи
length
[in] Количество байт, которые необходимо записать
buffer
[in] Буфер, который необходимо записать

Примечания

Запись блока информации на носитель должна проходить атомарно, т.е. информация передаваемая в функцию записи должна быть, либо записана (или записана ее часть), либо должна привести к ошибке. Так как таблетки dallas обеспечивают атомарность записи только в рамках одной страницы, то запись должна проводится постранично.

При записи неполной страницы, если возникает необходимость чтения страницы должны быть выполнены рекомендации по чтениию страницы DSReadFun

Требования:

Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

Требования:

Solaris: 10 или выше.

Требования:

FreeBSD: 7 или выше.

Требования:

Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

Требования:

Ядро ОС: Не поддерживает.

Требования:

Include: reader.kit\ds_ctx.h


Пакет установки считывателя, носителя, ДСЧ

Существует несколько возможных вариантов установки считывателей, носителей и ДСЧ для CSP.

Во-первых, возможна установка носителей в составе CSP. Таким способом устанавливается например считыватель "Дисковод" и Биологический ДСЧ. Этот подход используется Крипто-Про, но возможен вариант создания дистрибутива CSP совместно с другими считывателями или носителями. Этот подход наиболее удобен с точки зрения пользователя, но он имеет ряд недостатков.

  • Создание такового дистрибутива невозможно без предварительного согласование с компанией Крипто-Про.
  • Подпись дистрибутива Msi осуществляется на весь продукт, включая модули компании Крипто-Про и модули производителя носителя.
  • Изготовление Patch пакетов выходящих на CSP требует переизготовления Patch пакетов и для данного совместного продукта.
  • Это достаточно сложный по реализации механизм.

Второй способ, наиболее простой с точки зрения производителя библиотеки поддержки, но наименее удобен пользователю (администратору). Он основан на изготовлении дополнительного отдельного дистрибутива для библиотеки поддержки, он имеет следующие недостатки:

  • Пользователь не имеет возможности установить оба дистрибутива "одной кнопкой".
  • Удаление CSP не приведет к удалению библиотеки поддержки.
  • Различные библиотеки поддержки имеют различные инсталяторы.

Третий способ, рекомендуемые компанией Крипто-Про, основан на создании Patch-пакетов для КриптоПро CSP и основан на Windows Installer. Установка таких пакетов возможна различными способами:

  • Создание собственного небольшого инсталятора на основе Microsoft Windows Installer устанавливающего последовательно CSP и модуль поддержки.
  • Установка пакета из контрольной панели CSP с дистрибутивного диска или с WEB сервера Крипто-Про.
  • Script установка при помощи команды msiexec.
  • Установка в составе установки КриптоПро CSP.

    • Ниже описываются способы создания пактов установки.

    • Создание пакета установки.


Создание пакета установки.

На данный момент для изготовления Patch Package, содержищего библиотеку поддержки, для КриптоПро CSP 3.6 необходимо обратиться в компанию Крипто-Про.


Список требований

Структуры данных TDSInfoConnectCarrier_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    • Структуры данных TDSInfoConnectCarrier_

  • Solaris: 10 или выше.

    • Структуры данных TDSInfoConnectCarrier_

  • FreeBSD: 7 или выше.

    • Структуры данных TDSInfoConnectCarrier_

  • Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    • Структуры данных TDSInfoConnectCarrier_

  • Ядро ОС: Не поддерживает.

    • Структуры данных TDSInfoConnectCarrier_

  • Include: reader.kit\ds_ctx.h

    • Структуры данных TDSInfoIsSame_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    • Структуры данных TDSInfoIsSame_

  • Solaris: 10 или выше.

    • Структуры данных TDSInfoIsSame_

  • FreeBSD: 7 или выше.

    • Структуры данных TDSInfoIsSame_

  • Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    • Структуры данных TDSInfoIsSame_

  • Ядро ОС: Не поддерживает.

    • Структуры данных TDSInfoIsSame_

  • Include: reader.kit\ds_ctx.h

    • Структуры данных TDSInfoRestoreContext_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    • Структуры данных TDSInfoRestoreContext_

  • Solaris: 10 или выше.

    • Структуры данных TDSInfoRestoreContext_

  • FreeBSD: 7 или выше.

    • Структуры данных TDSInfoRestoreContext_

  • Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    • Структуры данных TDSInfoRestoreContext_

  • Ядро ОС: Не поддерживает.

    • Структуры данных TDSInfoRestoreContext_

  • Include: reader.kit\ds_ctx.h

    • Структуры данных TDSInfoUnique_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    • Структуры данных TDSInfoUnique_

  • Solaris: 10 или выше.

    • Структуры данных TDSInfoUnique_

  • FreeBSD: 7 или выше.

    • Структуры данных TDSInfoUnique_

  • Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    • Структуры данных TDSInfoUnique_

  • Ядро ОС: Не поддерживает.

    • Структуры данных TDSInfoUnique_

  • Include: reader.kit\ds_ctx.h

    • Структуры данных TRandomInfoParentHwnd_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\rndm_sys.h

    • Структуры данных TRandomInfoRndm_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\rndm_sys.h

    • Структуры данных TRandomInfoType_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\rndm_sys.h

    • Структуры данных TRdrFolderEnumContext_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Структуры данных TRdrRetryContextAttach_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Структуры данных TRdrRetryContextDup_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Структуры данных TReaderInfoCarrierType_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Структуры данных TReaderInfoChSize_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Структуры данных TReaderInfoConnectCarrier_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Структуры данных TReaderInfoFolderEnumNext_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Структуры данных TReaderInfoFolderOpen_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Структуры данных TReaderInfoLength_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Структуры данных TReaderInfoLocalMachine_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Структуры данных TReaderInfoLogin_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Структуры данных TReaderInfoOpen_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Структуры данных TReaderInfoOpenFlags_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Структуры данных TReaderInfoPasswdChange_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Структуры данных TReaderInfoPasswdClear_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Структуры данных TReaderInfoPasswdInfo_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Структуры данных TReaderInfoPasswdName_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Структуры данных TReaderInfoPasswdType_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Структуры данных TReaderInfoPrime_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Структуры данных TReaderInfoRead_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Структуры данных TReaderInfoSameMedia_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Структуры данных TReaderInfoUniqueGet_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Структуры данных TReaderInfoUniqueSet_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Структуры данных TReaderInfoUnlink_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Структуры данных TReaderInfoWrite_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Структуры данных TSCardInfoAPDU_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\scard.h

    • Структуры данных TSCardInfoBerTLVSearch_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\scard.h

    • Структуры данных TSCardInfoConnectCarrier_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    • Структуры данных TSCardInfoConnectCarrier_

  • Solaris: 10 или выше.

    • Структуры данных TSCardInfoConnectCarrier_

  • FreeBSD: 7 или выше.

    • Структуры данных TSCardInfoConnectCarrier_

  • Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    • Структуры данных TSCardInfoConnectCarrier_

  • Ядро ОС: Не поддерживает.

    • Структуры данных TSCardInfoConnectCarrier_

  • Include: reader.kit\scard.h

    • Структуры данных TSCardInfoIsSame_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    • Структуры данных TSCardInfoIsSame_

  • Solaris: 10 или выше.

    • Структуры данных TSCardInfoIsSame_

  • FreeBSD: 7 или выше.

    • Структуры данных TSCardInfoIsSame_

  • Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    • Структуры данных TSCardInfoIsSame_

  • Ядро ОС: Не поддерживает.

    • Структуры данных TSCardInfoIsSame_

  • Include: reader.kit\scard.h

    • Структуры данных TSCardInfoPostconnectCarrier_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    • Структуры данных TSCardInfoPostconnectCarrier_

  • Solaris: 10 или выше.

    • Структуры данных TSCardInfoPostconnectCarrier_

  • FreeBSD: 7 или выше.

    • Структуры данных TSCardInfoPostconnectCarrier_

  • Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    • Структуры данных TSCardInfoPostconnectCarrier_

  • Ядро ОС: Не поддерживает.

    • Структуры данных TSCardInfoPostconnectCarrier_

  • Include: reader.kit\scard.h

    • Структуры данных TSCardInfoPreconnectCarrier_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    • Структуры данных TSCardInfoPreconnectCarrier_

  • Solaris: 10 или выше.

    • Структуры данных TSCardInfoPreconnectCarrier_

  • FreeBSD: 7 или выше.

    • Структуры данных TSCardInfoPreconnectCarrier_

  • Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    • Структуры данных TSCardInfoPreconnectCarrier_

  • Ядро ОС: Не поддерживает.

    • Структуры данных TSCardInfoPreconnectCarrier_

  • Include: reader.kit\scard.h

    • Структуры данных TSCardInfoSimpleTLVSearch_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\scard.h

    • Структуры данных TSupSysFunctionTable_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Структуры данных TSupSysFunctionTableItem_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Структуры данных TSupSysInfoBitString_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Структуры данных TSupSysInfoCall_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Структуры данных TSupSysInfoCompany_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Структуры данных TSupSysInfoConnect_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Структуры данных TSupSysInfoConnectNext_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Структуры данных TSupSysInfoContextDup_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Структуры данных TSupSysInfoCopyright_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Структуры данных TSupSysInfoDetailName_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Структуры данных TSupSysInfoDummy_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Структуры данных TSupSysInfoError_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Структуры данных TSupSysInfoFlags_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Структуры данных TSupSysInfoGroupEnumOpen_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Структуры данных TSupSysInfoIconItem_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Структуры данных TSupSysInfoIDSBase_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Структуры данных TSupSysInfoIDSBaseItem_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Структуры данных TSupSysInfoInstance_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Структуры данных TSupSysInfoItemName_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Структуры данных TSupSysInfoNickname_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Структуры данных TSupSysInfoProducer_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Структуры данных TSupSysInfoProducerVersion_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Структуры данных TSupSysInfoRegister_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Структуры данных TSupSysInfoText_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Структуры данных TSupSysInfoUnregister_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Структуры данных TSupSysInfoUntyped_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Структуры данных TSupSysInfoVersion_

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный rdr_connect_finally

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_connect_return

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_connect_try

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_crear_finally

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_lock_finally

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_lock_return

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_lock_try

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_login_finally

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_login_return

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_login_try

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_prime_section

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_context_default_get

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_context_default_set

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_media_register_start

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_register_start

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_info_carrier_type

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_connect_carrier

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_disconnect_carrier

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_format_carrier

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_local_machine

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный is_password_disabled_by_policy

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_passwd_change

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_passwd_clear

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_passwd_default_clear

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_passwd_default_set

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_passwd_length

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_passwd_term

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_shortcut_clear

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_shortcut_get

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_shortcut_set

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_FOLDER_ENUM_FLAG_NEW

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный TRdrFolderEnumContext

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_folder_clear

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_folder_close

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_folder_enum_close

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_folder_enum_next

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_folder_enum_open

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_folder_open

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_login

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_logout

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_prime

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_prime_login

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_lock

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_unlock

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный TRdrFileNumber

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_file_chsize

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_file_close

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_file_length

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_file_open

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_file_read

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_file_unlink

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_file_write

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_unique_get

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_unique_set

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_error

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_SAME_WRITE_AVAIL

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_cancel_consequences

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_retry_proc_set

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный rdr_same_media

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_STATE_CARRIER

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_STATE_FILE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_STATE_FOLDER

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_STATE_LOGEDIN

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_STATE_PRIME

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_LOGIN_INFO_NO

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_LOGIN_INFO_PASSWD

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_LOGIN_INFO_PASSWD_MASTER

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_LOGIN_INFO_PRIME_PASSWD

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_LOGIN_INFO_PUBLIC

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_LOGIN_INFO_UNKNOWN

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный TRdrLoginInfoType

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный TRdrLoginInfoType

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_ERR_ANOTHER_MEDIA

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_ERR_BLOCK

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_ERR_FILE_DISTORT

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_ERR_FILE_EXIST

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_ERR_FILE_NOT_FOUND

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_ERR_FORMAT

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_ERR_FULL

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_ERR_INVALID

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_ERR_INVALID_MEDIA

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_ERR_INVALID_PASSWD

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_ERR_INVALID_PASSWD_FORMAT

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_ERR_MEDIA_CHANGED

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_ERR_NEED_PASSWD

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_ERR_NO_CARRIER

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_ERR_PASSWD_LOCKED

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_ERR_PRIME

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_ERR_RETRY_ATTACH

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_ERR_RETRY_DUP

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_ERR_RETRY_FREE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_ERR_VERSION_1

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_ERR_WRITE_PROTECT

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_FLAG_BLOCK_RDR

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_FLAG_RDR_FOLDER_ROOT

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_FLAG_RDR_FOLDERS

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_FLAG_RDR_LONG_NAMES

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_FLAG_RDR_REMOVABLE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_FLAG_RDR_UNIQUE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный RDR_FLAG_RDR_VERSION_1

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный TRdrRetryContextAttach

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный TRdrRetryContextDup

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный TRdrRetryProc

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader\rdr.h

    • Глобальный SUPSYS_PRE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_PRE_ACTION

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_PRE_CCONTEXT

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_PRE_CONTEXT

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_PRE_FUN

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_PRE_INFO

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_PRE_READ_PTR

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_PRE_READ_PTRS

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_PRE_STRING_PTR

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_PRE_STRING_PTRS

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_PRE_WRITE_PTR

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_PRE_WRITE_PTRS

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_PRE_STATE_EQ

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_PRE_STATE_GE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_PRE_STATE_GT

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_PRE_STATE_LE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_PRE_STATE_LT

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_START

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_CALL

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_COMPANY

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_CONTEXT_DUP

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_CONTEXT_FREE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_COPYRIGHT

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_DETAIL_NAME

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_ERROR

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_FLAGS

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_GROUP_ENUM_CLOSE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_GROUP_ENUM_NEXT

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_GROUP_ENUM_OPEN

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_GROUP_NICKNAME

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_IDS_BLOCK

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_INSTANCE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_ITEM_ICON

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_NAME

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_NICKNAME

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_VERSION

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_VERSIONSUPPORT

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_CONNECT

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_CONNECT_CLOSE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_CONNECT_NEXT

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_CONNECT_OPEN

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_CONNECT_REMOVE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_CONNECT_VALID

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_DISCONNECT

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_PRODUCER

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_PRODUCER_VERSION

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_REGISTER

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FUN_UNREGISTER

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FLAG_BLOCK_CONNECT

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FLAG_CONNECT_AUTO

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FLAG_CONNECT_COM

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FLAG_CONNECT_LPT

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FLAG_CONNECT_MANY

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FLAG_CONNECT_MULTY

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FLAG_CONNECT_PNPGROUP

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FLAG_CONNECT_VERSION_1

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FLAG_CONNECT_VERSION_2

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_FLAG_CONNECT_VERSION_3

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_CONNECT_AUTO

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_CONNECT_COM1

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_CONNECT_COM2

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_CONNECT_COM3

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_CONNECT_COM4

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_CONNECT_COM_MAX

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_CONNECT_LPT1

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_CONNECT_LPT2

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_CONNECT_LPT_MAX

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_CONNECT_MAX

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_CONNECT_START

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_CONNECT_USER

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_ERR_USER_FIRST

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_ERR_USER_LAST

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_IDS_BASE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_IDS_BASE_QUANT_V1

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_IDS_BLOCK_BASE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_IDS_BLOCK_ERROR

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_IDS_BLOCK_ICON

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_IDS_DETAIL_NAME

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_IDS_ERROR_BASE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_IDS_ERROR_QUANT_V1

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_IDS_GROUP_NICKNAME

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_IDS_ICON_BASE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_IDS_ICON_ITEM

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_IDS_ICON_QUANT_V1

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_IDS_NAME

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_IDS_NICKNAME

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный SUPSYS_IDS_PRODUCER

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный TSupSysConnectNum

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный TSupSysContext

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный TSupSysDummy

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный TSupSysInfo

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный TSupSysInfoFun

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный TSupSysIcon

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный TSupSysInfoGroupNickname

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный TSupSysExportFunction

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный TSupSysFunction

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\sup_sys.h

    • Глобальный READER_FUN_CARRIER_TYPE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_PASSWD_LENGTH

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_PASSWD_TERM

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_PASSWD_TYPE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_CANCEL_CONSEQUENCES

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_CANCEL_NOTIFY

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_CONNECT_CARRIER

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_DISCONNECT_CARRIER

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_LOCAL_MACHINE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_LOCK

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_RESTORE_CONTEXT

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_SAME_MEDIA

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_UNLOCK

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_FOLDER_CLOSE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_FOLDER_ENUM_CLOSE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_FOLDER_ENUM_NEXT

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_FOLDER_ENUM_OPEN

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_FOLDER_OPEN

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_PRIME

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_UNIQUE_GET

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_UNIQUE_SET

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_LOGIN

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_LOGOUT

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_PASSWD_CLEAR

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_PRIME_LOGIN

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_CLOSE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_FOLDER_CLEAR

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_OPEN

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_PASSWD_CHANGE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_UNLINK

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_CHSIZE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_LENGTH

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_READ

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_FUN_WRITE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_IDS_BASE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_IDS_BLOCK

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_IDS_CARRIER_TYPE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_IDS_PASSWD_TERM

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный READER_IDS_QUANT_V1

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\reader.h

    • Глобальный RANDOM_FUN_TYPE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\rndm_sys.h

    • Глобальный RANDOM_FUN_HWND

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\rndm_sys.h

    • Глобальный RANDOM_FUN_RNDM

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\rndm_sys.h

    • Глобальный RSCARD_DISPOSITION_EJECT

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\scard.h

    • Глобальный RSCARD_DISPOSITION_LEAVE

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\scard.h

    • Глобальный RSCARD_DISPOSITION_RESET

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\scard.h

    • Глобальный RSCARD_DISPOSITION_UNPOWER

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\scard.h

    • Глобальный RSCARD_PROTOCOL_T0

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\scard.h

    • Глобальный RSCARD_PROTOCOL_T1

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\scard.h

    • Глобальный TDisposition

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\scard.h

    • Глобальный TSCardAPDUCmd

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\scard.h

    • Глобальный TSCardBerTLVSearch

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\scard.h

    • Глобальный TSCardSimpleTLVSearch

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\scard.h

    • Глобальный RSCARD_FUN_IS_SAME_ATR

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\scard.h

    • Глобальный RSCARD_FUN_POSTCONNECT_CARRIER

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\scard.h

    • Глобальный RSCARD_FUN_PRECONNECT_CARRIER

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    Solaris: 10 или выше.

    FreeBSD: 7 или выше.

    Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    Ядро ОС: Не поддерживает.

    Include: reader.kit\scard.h

    • Глобальный RSCARD_FUN_CONNECT_CARRIER

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    • Глобальный RSCARD_FUN_CONNECT_CARRIER

  • Solaris: 10 или выше.

    • Глобальный RSCARD_FUN_CONNECT_CARRIER

  • FreeBSD: 7 или выше.

    • Глобальный RSCARD_FUN_CONNECT_CARRIER

  • Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    • Глобальный RSCARD_FUN_CONNECT_CARRIER

  • Ядро ОС: Не поддерживает.

    • Глобальный RSCARD_FUN_CONNECT_CARRIER

  • Include: reader.kit\scard.h

    • Глобальный RSCARD_FUN_RESTORE_CONTEXT

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    • Глобальный RSCARD_FUN_RESTORE_CONTEXT

  • Solaris: 10 или выше.

    • Глобальный RSCARD_FUN_RESTORE_CONTEXT

  • FreeBSD: 7 или выше.

    • Глобальный RSCARD_FUN_RESTORE_CONTEXT

  • Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    • Глобальный RSCARD_FUN_RESTORE_CONTEXT

  • Ядро ОС: Не поддерживает.

    • Глобальный RSCARD_FUN_RESTORE_CONTEXT

  • Include: reader.kit\scard.h

    • Глобальный RSCARD_FUN_SAME_MEDIA

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    • Глобальный RSCARD_FUN_SAME_MEDIA

  • Solaris: 10 или выше.

    • Глобальный RSCARD_FUN_SAME_MEDIA

  • FreeBSD: 7 или выше.

    • Глобальный RSCARD_FUN_SAME_MEDIA

  • Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    • Глобальный RSCARD_FUN_SAME_MEDIA

  • Ядро ОС: Не поддерживает.

    • Глобальный RSCARD_FUN_SAME_MEDIA

  • Include: reader.kit\scard.h

    • Глобальный DALLAS_FUN_IS_SAME_SER_NUM

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    • Глобальный DALLAS_FUN_IS_SAME_SER_NUM

  • Solaris: 10 или выше.

    • Глобальный DALLAS_FUN_IS_SAME_SER_NUM

  • FreeBSD: 7 или выше.

    • Глобальный DALLAS_FUN_IS_SAME_SER_NUM

  • Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    • Глобальный DALLAS_FUN_IS_SAME_SER_NUM

  • Ядро ОС: Не поддерживает.

    • Глобальный DALLAS_FUN_IS_SAME_SER_NUM

  • Include: reader.kit\ds_ctx.h

    • Глобальный DALLAS_RESTORE_FLAG_HARD

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    • Глобальный DALLAS_RESTORE_FLAG_HARD

  • Solaris: 10 или выше.

    • Глобальный DALLAS_RESTORE_FLAG_HARD

  • FreeBSD: 7 или выше.

    • Глобальный DALLAS_RESTORE_FLAG_HARD

  • Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    • Глобальный DALLAS_RESTORE_FLAG_HARD

  • Ядро ОС: Не поддерживает.

    • Глобальный DALLAS_RESTORE_FLAG_HARD

  • Include: reader.kit\ds_ctx.h

    • Глобальный DSReadFun

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    • Глобальный DSReadFun

  • Solaris: 10 или выше.

    • Глобальный DSReadFun

  • FreeBSD: 7 или выше.

    • Глобальный DSReadFun

  • Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    • Глобальный DSReadFun

  • Ядро ОС: Не поддерживает.

    • Глобальный DSReadFun

  • Include: reader.kit\ds_ctx.h

    • Глобальный DSWriteFun

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    • Глобальный DSWriteFun

  • Solaris: 10 или выше.

    • Глобальный DSWriteFun

  • FreeBSD: 7 или выше.

    • Глобальный DSWriteFun

  • Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    • Глобальный DSWriteFun

  • Ядро ОС: Не поддерживает.

    • Глобальный DSWriteFun

  • Include: reader.kit\ds_ctx.h

    • Глобальный TDSInfoConnectCarrier

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    • Глобальный TDSInfoConnectCarrier

  • Solaris: 10 или выше.

    • Глобальный TDSInfoConnectCarrier

  • FreeBSD: 7 или выше.

    • Глобальный TDSInfoConnectCarrier

  • Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    • Глобальный TDSInfoConnectCarrier

  • Ядро ОС: Не поддерживает.

    • Глобальный TDSInfoConnectCarrier

  • Include: reader.kit\ds_ctx.h

    • Глобальный TDSInfoDisconnectCarrier

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    • Глобальный TDSInfoDisconnectCarrier

  • Solaris: 10 или выше.

    • Глобальный TDSInfoDisconnectCarrier

  • FreeBSD: 7 или выше.

    • Глобальный TDSInfoDisconnectCarrier

  • Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    • Глобальный TDSInfoDisconnectCarrier

  • Ядро ОС: Не поддерживает.

    • Глобальный TDSInfoDisconnectCarrier

  • Include: reader.kit\ds_ctx.h

    • Глобальный TDSInfoIsSame

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    • Глобальный TDSInfoIsSame

  • Solaris: 10 или выше.

    • Глобальный TDSInfoIsSame

  • FreeBSD: 7 или выше.

    • Глобальный TDSInfoIsSame

  • Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    • Глобальный TDSInfoIsSame

  • Ядро ОС: Не поддерживает.

    • Глобальный TDSInfoIsSame

  • Include: reader.kit\ds_ctx.h

    • Глобальный TDSInfoRestoreContext

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    • Глобальный TDSInfoRestoreContext

  • Solaris: 10 или выше.

    • Глобальный TDSInfoRestoreContext

  • FreeBSD: 7 или выше.

    • Глобальный TDSInfoRestoreContext

  • Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    • Глобальный TDSInfoRestoreContext

  • Ядро ОС: Не поддерживает.

    • Глобальный TDSInfoRestoreContext

  • Include: reader.kit\ds_ctx.h

    • Глобальный TDSInfoUnique

  • Windows 2000 или выше: Необходимо Windows 2000 SP4 или старше с Internet Explorer 6.0 или старше.

    • Глобальный TDSInfoUnique

  • Solaris: 10 или выше.

    • Глобальный TDSInfoUnique

  • FreeBSD: 7 или выше.

    • Глобальный TDSInfoUnique

  • Linux: LSB 3.1 (RHEL 4, SuSE 10) или выше.

    • Глобальный TDSInfoUnique

  • Ядро ОС: Не поддерживает.

    • Глобальный TDSInfoUnique

  • Include: reader.kit\ds_ctx.h

    • Крипто-Про RDK Версия: 4.0